aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-23 04:51:54 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-23 04:51:54 +0000
commit6b96b8b53dc5ee93370b331f69fd2c1ad8bd2413 (patch)
treefbc2c653a3641bbbc5a26ce82405dde7118e9398 /devel
parent4b1b4c16b12e873f307c2c785f111bce1b015769 (diff)
downloadports-6b96b8b53dc5ee93370b331f69fd2c1ad8bd2413.tar.gz
ports-6b96b8b53dc5ee93370b331f69fd2c1ad8bd2413.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-Record/Makefile22
-rw-r--r--devel/p5-Config-Record/distinfo3
-rw-r--r--devel/p5-Config-Record/pkg-descr10
-rw-r--r--devel/p5-Config-Record/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 99df2b649e6a..dfc554340520 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -838,6 +838,7 @@
SUBDIR += p5-Config-General
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Config-Objective
+ SUBDIR += p5-Config-Record
SUBDIR += p5-Config-Setting
SUBDIR += p5-Config-Simple
SUBDIR += p5-Config-Std
diff --git a/devel/p5-Config-Record/Makefile b/devel/p5-Config-Record/Makefile
new file mode 100644
index 000000000000..afdad11a4a31
--- /dev/null
+++ b/devel/p5-Config-Record/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Config-Record
+# Date created: 22 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Record
+PORTVERSION= 1.1.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Configuration file access
+
+MAN3= Config::Record.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-Record/distinfo b/devel/p5-Config-Record/distinfo
new file mode 100644
index 000000000000..86ba3fb451c5
--- /dev/null
+++ b/devel/p5-Config-Record/distinfo
@@ -0,0 +1,3 @@
+MD5 (Config-Record-1.1.1.tar.gz) = d5170d92989313a8b5f0ceac3aa829ef
+SHA256 (Config-Record-1.1.1.tar.gz) = 688ff17cb4028808f447977cbc798e90b863b94c586c8c9c857b113ec21c6d83
+SIZE (Config-Record-1.1.1.tar.gz) = 25462
diff --git a/devel/p5-Config-Record/pkg-descr b/devel/p5-Config-Record/pkg-descr
new file mode 100644
index 000000000000..6d835a55126c
--- /dev/null
+++ b/devel/p5-Config-Record/pkg-descr
@@ -0,0 +1,10 @@
+This module provides an API for loading and saving of simple configuration
+file records. Entries in the configuration file are essentially key,value
+pairs, with the key and values separated by a single equals symbol. The
+key consists only of alphanumeric characters. There are three types of
+values, scalar values can contain anything except newlines. Trailing
+whitespace will be trimmed unless the value is surrounded in double
+quotes.
+
+WWW: http://search.cpan.org/dist/Config-Record
+Author: Daniel Berrange <dan@berrange.com>
diff --git a/devel/p5-Config-Record/pkg-plist b/devel/p5-Config-Record/pkg-plist
new file mode 100644
index 000000000000..151f82ec1de5
--- /dev/null
+++ b/devel/p5-Config-Record/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Config/Record.pm
+%%SITE_PERL%%/Config/Record.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Record/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Record
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config
+@dirrmtry %%SITE_PERL%%/Config