aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-04-29 06:32:03 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-04-29 06:32:03 +0000
commit75f25621a6f8656572deec1b98b2ae7c8684da6f (patch)
tree6167d0eaad46f08df1b16d805a3ef66cdd9c2b1e /devel
parentd129d3d87080bd8bb94c085522599b117929d9ae (diff)
downloadports-75f25621a6f8656572deec1b98b2ae7c8684da6f.tar.gz
ports-75f25621a6f8656572deec1b98b2ae7c8684da6f.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/ace/Makefile2
-rw-r--r--devel/caf/Makefile2
-rw-r--r--devel/compiler-rt/Makefile4
-rw-r--r--devel/cssc/Makefile2
-rw-r--r--devel/e2fsprogs-libss/Makefile2
-rw-r--r--devel/ffcall/Makefile2
-rw-r--r--devel/kBuild/Makefile4
-rw-r--r--devel/libhoard/Makefile2
-rw-r--r--devel/libosmo-netif/Makefile2
-rw-r--r--devel/libpru/Makefile2
-rw-r--r--devel/llvm-devel/Makefile2
-rw-r--r--devel/llvm33/Makefile2
-rw-r--r--devel/llvm38/Makefile2
-rw-r--r--devel/objecthash/Makefile4
-rw-r--r--devel/php-uprofiler/Makefile2
-rw-r--r--devel/py-llfuse/Makefile2
-rw-r--r--devel/py-pyinstaller/Makefile2
-rw-r--r--devel/tex-libtexluajit/Makefile2
-rw-r--r--devel/zpu-gcc/Makefile4
19 files changed, 23 insertions, 23 deletions
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index 23ac31de323f..6be203d9eb8c 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -35,7 +35,7 @@ CONFLICTS= ace+tao-5*
BROKEN_aarch64= Fails to link: missing sbrk
BROKEN_powerpc= Does not compile on ${ARCH}
-BROKEN_powerpc64= Does not build on ${ARCH}
+BROKEN_powerpc64= Does not build on ${ARCH}: undefined reference to fmodl
BROKEN_sparc64= Does not compile on ${ARCH}
OPTIONS_DEFINE= FLTK QT4 SSL TK TRIO X11
diff --git a/devel/caf/Makefile b/devel/caf/Makefile
index 428a60323c28..984387aa77cc 100644
--- a/devel/caf/Makefile
+++ b/devel/caf/Makefile
@@ -12,7 +12,7 @@ COMMENT= C++ actor framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= does not build: error: to_string is not a member of std
CXXFLAGS+= -std=c++11 -Wextra -Wall -pedantic
LDFLAGS+= -pthread
diff --git a/devel/compiler-rt/Makefile b/devel/compiler-rt/Makefile
index 1696d265bd00..d606b2ecf52e 100644
--- a/devel/compiler-rt/Makefile
+++ b/devel/compiler-rt/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= LOCAL/brooks
MAINTAINER= brooks@FreeBSD.org
COMMENT= Compiler runtime library with Blocks support
-BROKEN_powerpc64= Does not build
-
BUILD_DEPENDS= cmake:devel/cmake
+BROKEN_powerpc64= does not build: undefined reference to fmax
+
CONFIGURE_WRKSRC= ${WRKDIR}/build
BUILD_WRKSRC= ${WRKDIR}/build
INSTALL_WRKSRC= ${WRKDIR}/build
diff --git a/devel/cssc/Makefile b/devel/cssc/Makefile
index 85ff6929f294..f55d6cd8fc90 100644
--- a/devel/cssc/Makefile
+++ b/devel/cssc/Makefile
@@ -13,7 +13,7 @@ COMMENT= Workalike for the source code control system SCCS
LICENSE= GPLv3
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= does not build: undefined reference to fmax
GNU_CONFIGURE= yes
INFO= cssc
diff --git a/devel/e2fsprogs-libss/Makefile b/devel/e2fsprogs-libss/Makefile
index e50ccfd51d4b..062ab0235dac 100644
--- a/devel/e2fsprogs-libss/Makefile
+++ b/devel/e2fsprogs-libss/Makefile
@@ -13,7 +13,7 @@ CONFLICTS+= krb4-[0-9]*
BROKEN_mips= Does not build: expected declaration specifiers before size_t
BROKEN_mips64= Does not build: expected declaration specifiers before size_t
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: expected declaration specifiers before size_t
BROKEN_sparc64= Does not build: expected declaration specifiers before size_t
OPTIONS_EXCLUDE= DOCS EXAMPLES IPV6 NLS
diff --git a/devel/ffcall/Makefile b/devel/ffcall/Makefile
index 5ba129df6878..5f28517bbbbd 100644
--- a/devel/ffcall/Makefile
+++ b/devel/ffcall/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
BROKEN_aarch64= Does not build: No rule to make target avcall-aarch64.lo
BROKEN_armv6= Does not build: error: invalid instruction
BROKEN_mips64== Does not build: error: duplicate member anum
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: No rule to make target avcall-powerpc64.lo
GNU_CONFIGURE= yes
USES= gmake libtool
diff --git a/devel/kBuild/Makefile b/devel/kBuild/Makefile
index b6c563784a29..ece5437242d8 100644
--- a/devel/kBuild/Makefile
+++ b/devel/kBuild/Makefile
@@ -13,10 +13,10 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}r2695-src
MAINTAINER= vbox@FreeBSD.org
COMMENT= Makefile framework
-BROKEN_powerpc64= Does not build
-
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
+BROKEN_powerpc64= does not build: fatal error: xmmintrin.h: No such file or directory
+
USE_GCC= any
USES= autoreconf:build gmake makeinfo
diff --git a/devel/libhoard/Makefile b/devel/libhoard/Makefile
index 71074fdeccd7..62c97b975422 100644
--- a/devel/libhoard/Makefile
+++ b/devel/libhoard/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/../COPYING
BROKEN_aarch64= no spin lock implementation is available for this platform
BROKEN_mips= no spin lock implementation is available for this platform
BROKEN_mips64= no spin lock implementation is available for this platform
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: Error: instruction address is not a multiple of 4
BROKEN_sparc64= Does not build
USE_LDCONFIG= yes
diff --git a/devel/libosmo-netif/Makefile b/devel/libosmo-netif/Makefile
index 1681aa94681a..ff541773f4c4 100644
--- a/devel/libosmo-netif/Makefile
+++ b/devel/libosmo-netif/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libosmocore.so:devel/libosmocore \
BROKEN_mips= Does not build: undefined reference to __bswap_16
BROKEN_mips64= Does not build: undefined reference to __bswap_16
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: undefined reference to __bswap_16
BROKEN_sparc64= Does not build: undefined reference to __bswap_16
USES= autoreconf libtool pathfix pkgconfig
diff --git a/devel/libpru/Makefile b/devel/libpru/Makefile
index 3b4a9079dc90..5b288a245c40 100644
--- a/devel/libpru/Makefile
+++ b/devel/libpru/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD2CLAUSE
IGNORE_DragonFly= only supported on FreeBSD
BROKEN_mips= Does not build: unrecognized command line option -Weverything
BROKEN_mips64= Does not build: unrecognized command line option -Weverything
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: unrecognized command line option -Weverything
BROKEN_sparc64= Does not build: unrecognized command line option -Weverything
USES= cmake
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index b5398f569275..244bbf4e0f32 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -10,7 +10,7 @@ PKGNAMESUFFIX= -devel
MAINTAINER= brooks@FreeBSD.org
COMMENT= LLVM and Clang
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: error: vsnprintf was not declared in this scope
LLVM_SUFFIX= -devel
LLVM_PREFIX= ${PREFIX}/llvm${LLVM_SUFFIX}
diff --git a/devel/llvm33/Makefile b/devel/llvm33/Makefile
index a88243293b21..a14725a8cfcf 100644
--- a/devel/llvm33/Makefile
+++ b/devel/llvm33/Makefile
@@ -11,7 +11,7 @@ PKGNAMESUFFIX= ${LLVM_SUFFIX}
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: c++: Internal error: Killed (program cc1plus)
LLVM_SUFFIX= ${PORTVERSION:S/.//g}
LLVM_PREFIX= ${PREFIX}/llvm${LLVM_SUFFIX}
diff --git a/devel/llvm38/Makefile b/devel/llvm38/Makefile
index 326de8571383..3b6386ef968e 100644
--- a/devel/llvm38/Makefile
+++ b/devel/llvm38/Makefile
@@ -12,7 +12,7 @@ PKGNAMESUFFIX= ${LLVM_SUFFIX}
MAINTAINER= brooks@FreeBSD.org
COMMENT= LLVM and Clang
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: internal compiler error: Killed (program cc1plus)
LLVM_RELEASE= ${DISTVERSION:C/rc.*//}
RCDIR= ${DISTVERSION:S/${LLVM_RELEASE}//:C|(rc.*)|\1/|}
diff --git a/devel/objecthash/Makefile b/devel/objecthash/Makefile
index 551688f60675..051991cd4ed2 100644
--- a/devel/objecthash/Makefile
+++ b/devel/objecthash/Makefile
@@ -11,11 +11,11 @@ COMMENT= Cross-language way to cryptographically hash JSON objects
LICENSE= APACHE20
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libicudata.so:devel/icu \
libjson-c.so:devel/json-c
+BROKEN_powerpc64= Does not build: error: variably modified hash at file scope
+
USES= pkgconfig ssl
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/devel/php-uprofiler/Makefile b/devel/php-uprofiler/Makefile
index fe336d45b59e..772099137d80 100644
--- a/devel/php-uprofiler/Makefile
+++ b/devel/php-uprofiler/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE
BROKEN_aarch64= Does not build: invokes x86 asm
BROKEN_armv6= Does not build: invokes x86 asm
BROKEN_mips64= Does not build: invokes x86 asm
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: invokes x86 asm
BROKEN_sparc64= Does not build: invokes x86 asm
USE_GITHUB= yes
diff --git a/devel/py-llfuse/Makefile b/devel/py-llfuse/Makefile
index 2531d24f3bc2..150711dc3f5c 100644
--- a/devel/py-llfuse/Makefile
+++ b/devel/py-llfuse/Makefile
@@ -11,7 +11,7 @@ COMMENT= Python bindings for low-level FUSE API
LICENSE= LGPL20+
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: error: conversion to mode_t from int may alter its value
USES?= compiler:c++11-lang fuse pkgconfig python tar:bz2
USE_PYTHON= autoplist distutils
diff --git a/devel/py-pyinstaller/Makefile b/devel/py-pyinstaller/Makefile
index 1fafe0b43270..19517332b42d 100644
--- a/devel/py-pyinstaller/Makefile
+++ b/devel/py-pyinstaller/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
BROKEN_aarch64= Does not compile: error: stb__testsize2_uinta declared as an array with a negative size
BROKEN_mips64= Does not compile: cc1: error: unrecognized command line option "-m64
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not compile: error: size of array stb__testsize2_uinta is negative
BROKEN_sparc64= Does not compile: error: size of array stb__testsize2_uinta is negative
OPTIONS_DEFINE= DOCS
diff --git a/devel/tex-libtexluajit/Makefile b/devel/tex-libtexluajit/Makefile
index 360abb763a45..63a691d51f9c 100644
--- a/devel/tex-libtexluajit/Makefile
+++ b/devel/tex-libtexluajit/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LuaJIT-2.0.3/COPYRIGHT
BROKEN_aarch64= Does not configure: error: Sorry, can not preprocess lj_arch.h
BROKEN_mips= Does not configure: error: Sorry, can not preprocess lj_arch.h
BROKEN_mips64= Does not configure: error: Sorry, can not preprocess lj_arch.h
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: uninitialized constant Config (NameError)
BROKEN_sparc64= Does not configure: error: Sorry, can not preprocess lj_arch.h
USES= tar:xz libtool pathfix pkgconfig
diff --git a/devel/zpu-gcc/Makefile b/devel/zpu-gcc/Makefile
index 632e59f42dca..8976b444e0a5 100644
--- a/devel/zpu-gcc/Makefile
+++ b/devel/zpu-gcc/Makefile
@@ -12,11 +12,11 @@ COMMENT= ZPU gcc compiler
LICENSE= GPLv2
-BROKEN_powerpc64= Does not build
-
BUILD_DEPENDS= ${LOCALBASE}/zpu/bin/zpu-elf-as:devel/zpu-binutils
RUN_DEPENDS:= ${BUILD_DEPENDS}
+BROKEN_powerpc64= Does not build
+
WRKSRC= ${WRKDIR}/${DISTNAME}/toolchain
USES= gettext gmake makeinfo
MANDIRS= ${PREFIX}/zpu/man