aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-30 14:07:27 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-30 14:07:27 +0000
commite13515f304b4eb05767a6453990dce8a1cc95234 (patch)
tree5af52ac5bc3c3ee69de6c955c53219549a3d434b /devel
parent4641b63dd110dfe3a5eb439a464a3b08b0a4075d (diff)
downloadports-e13515f304b4eb05767a6453990dce8a1cc95234.tar.gz
ports-e13515f304b4eb05767a6453990dce8a1cc95234.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/arduino-mk/Makefile2
-rw-r--r--devel/cvs2darcs/Makefile2
-rw-r--r--devel/cvsplot/Makefile4
-rw-r--r--devel/cvsweb3/Makefile8
-rw-r--r--devel/lxr/Makefile6
-rw-r--r--devel/p5-Algorithm-Accounting/Makefile18
-rw-r--r--devel/p5-CPAN-SQLite/Makefile14
-rw-r--r--devel/p5-Class-Declare/Makefile2
-rw-r--r--devel/p5-Class-Observable/Makefile2
-rw-r--r--devel/p5-Config-IniRegEx/Makefile2
-rw-r--r--devel/p5-Config-Objective/Makefile4
-rw-r--r--devel/p5-Data-ClearSilver-HDF/Makefile8
-rw-r--r--devel/p5-Data-Dumper-Perltidy/Makefile2
-rw-r--r--devel/p5-Data-Structure-Util/Makefile4
-rw-r--r--devel/p5-Data-TreeDumper/Makefile10
-rw-r--r--devel/p5-Date-Roman/Makefile2
-rw-r--r--devel/p5-DateTime-Calendar-Discordian/Makefile4
-rw-r--r--devel/p5-DateTime-Format-XSD/Makefile4
-rw-r--r--devel/p5-Log-Accounting-SVK/Makefile10
-rw-r--r--devel/p5-Log-Accounting-SVN/Makefile2
-rw-r--r--devel/p5-Mac-PropertyList/Makefile2
-rw-r--r--devel/p5-Module-List/Makefile2
-rw-r--r--devel/p5-POE-Component-Schedule/Makefile10
-rw-r--r--devel/p5-POE-Component-Server-XMLRPC/Makefile6
-rw-r--r--devel/p5-Perl6-Form/Makefile4
-rw-r--r--devel/p5-Pipeline/Makefile12
-rw-r--r--devel/p5-RRDTool-OO/Makefile2
-rw-r--r--devel/p5-SVN-Agent/Makefile2
-rw-r--r--devel/p5-SVN-Log/Makefile2
-rw-r--r--devel/p5-SVN-Statistics/Makefile2
-rw-r--r--devel/p5-Shell-EnvImporter/Makefile2
-rw-r--r--devel/p5-Sub-WrapPackages/Makefile2
-rw-r--r--devel/p5-Template-Provider-Encode/Makefile2
-rw-r--r--devel/p5-Term-Animation/Makefile2
-rw-r--r--devel/p5-Thrift/Makefile4
-rw-r--r--devel/p5-Tie-File-AsHash/Makefile4
-rw-r--r--devel/p5-Tie-ShareLite/Makefile2
-rw-r--r--devel/p5-User-Identity/Makefile2
-rw-r--r--devel/p5-VCS-CVS/Makefile2
-rw-r--r--devel/svn2git/Makefile4
-rw-r--r--devel/svn_load_dirs/Makefile2
41 files changed, 91 insertions, 91 deletions
diff --git a/devel/arduino-mk/Makefile b/devel/arduino-mk/Makefile
index 96d8af455e87..9d47a209b3c0 100644
--- a/devel/arduino-mk/Makefile
+++ b/devel/arduino-mk/Makefile
@@ -18,7 +18,7 @@ LICENSE= LGPL21
# gmake is needed to use the port, not to build it
RUN_DEPENDS= gmake:${PORTSDIR}/devel/gmake \
- ${SITE_PERL}/YAML/Any.pm:${PORTSDIR}/textproc/p5-YAML \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
arduino:${PORTSDIR}/devel/arduino
PATCH_DEPENDS= ${LOCALBASE}/arduino/lib/version.txt:${PORTSDIR}/devel/arduino
diff --git a/devel/cvs2darcs/Makefile b/devel/cvs2darcs/Makefile
index f9617b647f0e..690b89e0ee71 100644
--- a/devel/cvs2darcs/Makefile
+++ b/devel/cvs2darcs/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= darcs:${PORTSDIR}/devel/hs-darcs \
cvsps:${PORTSDIR}/devel/cvsps \
- ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
diff --git a/devel/cvsplot/Makefile b/devel/cvsplot/Makefile
index b9e7e7f242f4..d058cc181437 100644
--- a/devel/cvsplot/Makefile
+++ b/devel/cvsplot/Makefile
@@ -15,8 +15,8 @@ MASTER_SITES= SF
MAINTAINER= erik@bz.bzflag.bz
COMMENT= A perl script which analyses the history of a CVS-managed project
-RUN_DEPENDS= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/String/ShellQuote.pm:${PORTSDIR}/textproc/p5-String-ShellQuote \
+RUN_DEPENDS= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-String-ShellQuote>=0:${PORTSDIR}/textproc/p5-String-ShellQuote \
gnuplot:${PORTSDIR}/math/gnuplot
USE_PERL5= yes
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
index 89af5159c10a..41f1bd03770b 100644
--- a/devel/cvsweb3/Makefile
+++ b/devel/cvsweb3/Makefile
@@ -18,13 +18,13 @@ MASTER_SITE_SUBDIR= scop
MAINTAINER= noackjr@alumni.rice.edu
COMMENT= WWW CGI script to browse CVS repository trees version 3
-RUN_DEPENDS= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
# The following extra dependencies are optional, but CVSweb works the
# best with them.
-RUN_DEPENDS+= ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
- ${SITE_PERL}/${PERL_ARCH}/String/Ediff.pm:${PORTSDIR}/devel/p5-String-Ediff \
+RUN_DEPENDS+= p5-MIME-Types>=0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-String-Ediff>=0:${PORTSDIR}/devel/p5-String-Ediff \
cvsgraph:${PORTSDIR}/devel/cvsgraph
# Use PAPERSIZE to avoid a stale dependency on Enscript.
diff --git a/devel/lxr/Makefile b/devel/lxr/Makefile
index 31d91a7f7834..f1529ff9a86c 100644
--- a/devel/lxr/Makefile
+++ b/devel/lxr/Makefile
@@ -16,7 +16,7 @@ COMMENT= Source code indexer and cross-referencer
BUILD_DEPENDS= exctags:${PORTSDIR}/devel/ctags \
swish-e:${PORTSDIR}/www/swish-e \
- ${SITE_PERL}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic
+ p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic
PATCH_STRIP= -p1
@@ -51,13 +51,13 @@ IGNORE= you must choose only one database backend
.endif
.if defined(WITH_POSTGRESQL)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+BUILD_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
MSG_FILES+= pkg_message.postgresql
DB_DRIVER= Pg
.endif # defined(WITH_POSTGRESQL)
.if defined(WITH_MYSQL)
-BUILD_DEPENDS+= ${SITE_PERL}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+BUILD_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
MSG_FILES+= pkg_message.mysql
DB_DRIVER= mysql
.endif # defined(WITH_MYSQL)
diff --git a/devel/p5-Algorithm-Accounting/Makefile b/devel/p5-Algorithm-Accounting/Makefile
index 9724ce71a491..efe360a62bd6 100644
--- a/devel/p5-Algorithm-Accounting/Makefile
+++ b/devel/p5-Algorithm-Accounting/Makefile
@@ -15,15 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Generate accounting statistic for general logs
-BUILD_DEPENDS= ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy \
- ${SITE_PERL}/Perl6/Form.pm:${PORTSDIR}/devel/p5-Perl6-Form \
- ${SITE_PERL}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw \
- ${SITE_PERL}/Array/Compare.pm:${PORTSDIR}/misc/p5-Array-Compare \
- ${SITE_PERL}/Array/Iterator/Reusable.pm:${PORTSDIR}/devel/p5-Array-Iterator \
- ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
- ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
- ${SITE_PERL}/Imager/Graph/Pie.pm:${PORTSDIR}/graphics/p5-Imager-Graph \
- ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= p5-Spiffy>=0:${PORTSDIR}/devel/p5-Spiffy \
+ p5-Perl6-Form>=0:${PORTSDIR}/devel/p5-Perl6-Form \
+ p5-FreezeThaw>=0:${PORTSDIR}/devel/p5-FreezeThaw \
+ p5-Array-Compare>=0:${PORTSDIR}/misc/p5-Array-Compare \
+ p5-Array-Iterator>=0:${PORTSDIR}/devel/p5-Array-Iterator \
+ p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
+ p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph \
+ p5-Imager-Graph>=0:${PORTSDIR}/graphics/p5-Imager-Graph \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-CPAN-SQLite/Makefile b/devel/p5-CPAN-SQLite/Makefile
index fc8658a843c1..000435d9a780 100644
--- a/devel/p5-CPAN-SQLite/Makefile
+++ b/devel/p5-CPAN-SQLite/Makefile
@@ -15,13 +15,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= eg@fbsd.lt
COMMENT= Search CPAN using a SQLite database
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
- ${SITE_PERL}/File/HomeDir.pm:${PORTSDIR}/devel/p5-File-HomeDir \
- ${SITE_PERL}/CPAN/DistnameInfo.pm:${PORTSDIR}/devel/p5-CPAN-DistnameInfo \
- ${SITE_PERL}/IO/Zlib.pm:${PORTSDIR}/archivers/p5-IO-Zlib \
- ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
- ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
+BUILD_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-File-HomeDir>=0:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-CPAN-DistnameInfo>=0:${PORTSDIR}/devel/p5-CPAN-DistnameInfo \
+ p5-IO-Zlib>=0:${PORTSDIR}/archivers/p5-IO-Zlib \
+ p5-Archive-Tar>=0:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Class-Declare/Makefile b/devel/p5-Class-Declare/Makefile
index 488d70b758c1..9beed8cc721d 100644
--- a/devel/p5-Class-Declare/Makefile
+++ b/devel/p5-Class-Declare/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= simarg@gmail.com
COMMENT= Perl module for declare classes
-BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+BUILD_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Class-Observable/Makefile b/devel/p5-Class-Observable/Makefile
index 8cf77d9c82a0..6ccc5f241fcf 100644
--- a/devel/p5-Class-Observable/Makefile
+++ b/devel/p5-Class-Observable/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= hcoyote@ghostar.org
COMMENT= Allow other classes and objects to respond to events in yours
-BUILD_DEPENDS= ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA
+BUILD_DEPENDS= p5-Class-ISA>=0:${PORTSDIR}/devel/p5-Class-ISA
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Config-IniRegEx/Makefile b/devel/p5-Config-IniRegEx/Makefile
index dc812acf7722..eefcca64b026 100644
--- a/devel/p5-Config-IniRegEx/Makefile
+++ b/devel/p5-Config-IniRegEx/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mopsfelder@gmail.com
COMMENT= Ini workaround, regex search for parameters and sections
-RUN_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles
+RUN_DEPENDS= p5-Config-IniFiles>=0:${PORTSDIR}/devel/p5-Config-IniFiles
PERL_CONFIGURE= yes
diff --git a/devel/p5-Config-Objective/Makefile b/devel/p5-Config-Objective/Makefile
index 64194b4e8966..ccbb15d53c13 100644
--- a/devel/p5-Config-Objective/Makefile
+++ b/devel/p5-Config-Objective/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pirzyk@FreeBSD.org
COMMENT= Configuration data as perl objects
-BUILD_DEPENDS= ${SITE_PERL}/Parse/Yapp.pm:${PORTSDIR}/devel/p5-Parse-Yapp \
- ${SITE_PERL}/Parse/Lex.pm:${PORTSDIR}/devel/p5-ParseLex
+BUILD_DEPENDS= p5-Parse-Yapp>=0:${PORTSDIR}/devel/p5-Parse-Yapp \
+ p5-ParseLex>=0:${PORTSDIR}/devel/p5-ParseLex
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-Data-ClearSilver-HDF/Makefile b/devel/p5-Data-ClearSilver-HDF/Makefile
index 7db711129e67..bc19a75b82af 100644
--- a/devel/p5-Data-ClearSilver-HDF/Makefile
+++ b/devel/p5-Data-ClearSilver-HDF/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= catone@cpan.org
COMMENT= Convert from Perl Data Structure to ClearSilver HDF
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/ClearSilver.pm:${PORTSDIR}/www/p5-ClearSilver \
- ${SITE_PERL}/${PERL_ARCH}/Data/Structure/Util.pm:${PORTSDIR}/devel/p5-Data-Structure-Util \
- ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
- ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+BUILD_DEPENDS= p5-ClearSilver>=0:${PORTSDIR}/www/p5-ClearSilver \
+ p5-Data-Structure-Util>=0:${PORTSDIR}/devel/p5-Data-Structure-Util \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Data-Dumper-Perltidy/Makefile b/devel/p5-Data-Dumper-Perltidy/Makefile
index de4bdd999cc7..a0912643ba6d 100644
--- a/devel/p5-Data-Dumper-Perltidy/Makefile
+++ b/devel/p5-Data-Dumper-Perltidy/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mopsfelder@gmail.com
COMMENT= Stringify and pretty print Perl data structures
-RUN_DEPENDS= ${SITE_PERL}/Perl/Tidy.pm:${PORTSDIR}/devel/perltidy
+RUN_DEPENDS= perltidy>=0:${PORTSDIR}/devel/perltidy
PERL_CONFIGURE= yes
diff --git a/devel/p5-Data-Structure-Util/Makefile b/devel/p5-Data-Structure-Util/Makefile
index e4f706748d28..04464d77d487 100644
--- a/devel/p5-Data-Structure-Util/Makefile
+++ b/devel/p5-Data-Structure-Util/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= nistor@snickers.org
COMMENT= Perl5 module to change the nature of data within a structure
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
- ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod
+BUILD_DEPENDS= p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
PERL_CONFIGURE= yes
diff --git a/devel/p5-Data-TreeDumper/Makefile b/devel/p5-Data-TreeDumper/Makefile
index eaaa8480059a..7e2a2d52b007 100644
--- a/devel/p5-Data-TreeDumper/Makefile
+++ b/devel/p5-Data-TreeDumper/Makefile
@@ -14,11 +14,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dhn@FreeBSD.org
COMMENT= Dumps a data structure in a tree fashion
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/Size.pm:${PORTSDIR}/devel/p5-Term-Size \
- ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap \
- ${SITE_PERL}/Check/ISA.pm:${PORTSDIR}/devel/p5-Check-ISA \
- ${SITE_PERL}/${PERL_ARCH}/Devel/Size.pm:${PORTSDIR}/devel/p5-Devel-Size \
- ${SITE_PERL}/Sort/Naturally.pm:${PORTSDIR}/textproc/p5-Sort-Naturally
+BUILD_DEPENDS= p5-Term-Size>=0:${PORTSDIR}/devel/p5-Term-Size \
+ p5-Text-Tabs+Wrap>=0:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap \
+ p5-Check-ISA>=0:${PORTSDIR}/devel/p5-Check-ISA \
+ p5-Devel-Size>=0:${PORTSDIR}/devel/p5-Devel-Size \
+ p5-Sort-Naturally>=0:${PORTSDIR}/textproc/p5-Sort-Naturally
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Data::TreeDumper.3
diff --git a/devel/p5-Date-Roman/Makefile b/devel/p5-Date-Roman/Makefile
index 5d83280bf2bd..3823e9dfe0e8 100644
--- a/devel/p5-Date-Roman/Makefile
+++ b/devel/p5-Date-Roman/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= philip@FreeBSD.org
COMMENT= Perl module to play with Roman dates
-BUILD_DEPENDS= ${SITE_PERL}/Roman.pm:${PORTSDIR}/math/p5-Roman
+BUILD_DEPENDS= p5-Roman>=0:${PORTSDIR}/math/p5-Roman
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Calendar-Discordian/Makefile b/devel/p5-DateTime-Calendar-Discordian/Makefile
index e108bf075324..11295914ff95 100644
--- a/devel/p5-DateTime-Calendar-Discordian/Makefile
+++ b/devel/p5-DateTime-Calendar-Discordian/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= philip@FreeBSD.org
COMMENT= Perl extension for the Discordian Calendar
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/DateTime/Locale.pm:${PORTSDIR}/devel/p5-DateTime-Locale \
+RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Locale>=0:${PORTSDIR}/devel/p5-DateTime-Locale \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Format-XSD/Makefile b/devel/p5-DateTime-Format-XSD/Makefile
index a0d6c94cb770..898e2f7c3df2 100644
--- a/devel/p5-DateTime-Format-XSD/Makefile
+++ b/devel/p5-DateTime-Format-XSD/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sergey.dyatko@gmail.com
COMMENT= Format DateTime according to xsd:dateTime
-BUILD_DEPENDS= ${SITE_PERL}/DateTime/Format/ISO8601.pm:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601
-RUN_DEPENDS= ${SITE_PERL}/DateTime/Format/ISO8601.pm:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601
+BUILD_DEPENDS= p5-DateTime-Format-ISO8601>=0:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601
+RUN_DEPENDS= p5-DateTime-Format-ISO8601>=0:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601
PERL_CONFIGURE= yes
diff --git a/devel/p5-Log-Accounting-SVK/Makefile b/devel/p5-Log-Accounting-SVK/Makefile
index a46fd0674995..7e19c5db49ed 100644
--- a/devel/p5-Log-Accounting-SVK/Makefile
+++ b/devel/p5-Log-Accounting-SVK/Makefile
@@ -15,11 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Perl module for accounting SVK repository
-BUILD_DEPENDS= ${SITE_PERL}/SVK.pm:${PORTSDIR}/devel/svk \
- ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy \
- ${SITE_PERL}/Graph/SocialMap.pm:${PORTSDIR}/graphics/p5-Graph-SocialMap \
- ${SITE_PERL}/Graph/Writer/GraphViz.pm:${PORTSDIR}/graphics/p5-Graph-Writer-GraphViz \
- ${SITE_PERL}/Algorithm/Accounting.pm:${PORTSDIR}/devel/p5-Algorithm-Accounting
+BUILD_DEPENDS= svk>=0:${PORTSDIR}/devel/svk \
+ p5-Spiffy>=0:${PORTSDIR}/devel/p5-Spiffy \
+ p5-Graph-SocialMap>=0:${PORTSDIR}/graphics/p5-Graph-SocialMap \
+ p5-Graph-Writer-GraphViz>=0:${PORTSDIR}/graphics/p5-Graph-Writer-GraphViz \
+ p5-Algorithm-Accounting>=0:${PORTSDIR}/devel/p5-Algorithm-Accounting
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Log-Accounting-SVN/Makefile b/devel/p5-Log-Accounting-SVN/Makefile
index de6efab82a31..cd8c57b71c39 100644
--- a/devel/p5-Log-Accounting-SVN/Makefile
+++ b/devel/p5-Log-Accounting-SVN/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Perl module for accounting SVN repository
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
+BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-SVN-Log>=0:${PORTSDIR}/devel/p5-SVN-Log \
p5-Algorithm-Accounting>=0:${PORTSDIR}/devel/p5-Algorithm-Accounting \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
diff --git a/devel/p5-Mac-PropertyList/Makefile b/devel/p5-Mac-PropertyList/Makefile
index 8bb55fb68300..cb2e2662f7e5 100644
--- a/devel/p5-Mac-PropertyList/Makefile
+++ b/devel/p5-Mac-PropertyList/Makefile
@@ -17,7 +17,7 @@ COMMENT= A Perl extension for parsing Mac OS X property lists
LICENSE_COMB= dual
LICENSE= ART10 GPLv1
-BUILD_DEPENDS= ${SITE_PERL}/XML/Entities.pm:${PORTSDIR}/textproc/p5-XML-Entities
+BUILD_DEPENDS= p5-XML-Entities>=0:${PORTSDIR}/textproc/p5-XML-Entities
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Module-List/Makefile b/devel/p5-Module-List/Makefile
index 0de690f196f9..fd5e9d52a2f7 100644
--- a/devel/p5-Module-List/Makefile
+++ b/devel/p5-Module-List/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= oleg@mamontov.net
COMMENT= Module 'directory' listing
-RUN_DEPENDS= ${SITE_PERL}/parent.pm:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS= p5-parent>=0:${PORTSDIR}/devel/p5-parent
PERL_MODBUILD= yes
diff --git a/devel/p5-POE-Component-Schedule/Makefile b/devel/p5-POE-Component-Schedule/Makefile
index e48b30e96263..81d63ffc593a 100644
--- a/devel/p5-POE-Component-Schedule/Makefile
+++ b/devel/p5-POE-Component-Schedule/Makefile
@@ -14,11 +14,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mat@FreeBSD.org
COMMENT= Schedule POE Events using a cron spec
-BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set
-RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-DateTime-Set>=0:${PORTSDIR}/devel/p5-DateTime-Set
+RUN_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-DateTime-Set>=0:${PORTSDIR}/devel/p5-DateTime-Set
PERL_MODBUILD= yes
diff --git a/devel/p5-POE-Component-Server-XMLRPC/Makefile b/devel/p5-POE-Component-Server-XMLRPC/Makefile
index 32eecd93eeee..83e6720e03be 100644
--- a/devel/p5-POE-Component-Server-XMLRPC/Makefile
+++ b/devel/p5-POE-Component-Server-XMLRPC/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jesper@jdn.dk
COMMENT= POE Component to create XMLRPC Servers
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/Component/Server/HTTP.pm:${PORTSDIR}/www/p5-POE-Component-Server-HTTP \
- ${SITE_PERL}/XMLRPC/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Component-Server-HTTP>=0:${PORTSDIR}/www/p5-POE-Component-Server-HTTP \
+ p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Perl6-Form/Makefile b/devel/p5-Perl6-Form/Makefile
index 48bca359b8ba..80069358e0d6 100644
--- a/devel/p5-Perl6-Form/Makefile
+++ b/devel/p5-Perl6-Form/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Implements the Perl 6 'form' built-in
-BUILD_DEPENDS= ${SITE_PERL}/Perl6/Export.pm:${PORTSDIR}/devel/p5-Perl6-Export \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= p5-Perl6-Export>=0:${PORTSDIR}/devel/p5-Perl6-Export \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Pipeline/Makefile b/devel/p5-Pipeline/Makefile
index 5b4af3d383a6..ace2201e5534 100644
--- a/devel/p5-Pipeline/Makefile
+++ b/devel/p5-Pipeline/Makefile
@@ -16,12 +16,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rouslan@rshell.net
COMMENT= Pipeline - Generic pipeline interface
-BUILD_DEPENDS= ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
- ${SITE_PERL}/IO/Null.pm:${PORTSDIR}/devel/p5-IO-Null \
- ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
- ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
- ${SITE_PERL}/${PERL_ARCH}/Data/Structure/Util.pm:${PORTSDIR}/devel/p5-Data-Structure-Util
+BUILD_DEPENDS= p5-Class-ISA>=0:${PORTSDIR}/devel/p5-Class-ISA \
+ p5-Error>=0:${PORTSDIR}/lang/p5-Error \
+ p5-IO-Null>=0:${PORTSDIR}/devel/p5-IO-Null \
+ p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
+ p5-Data-UUID>=0:${PORTSDIR}/devel/p5-Data-UUID \
+ p5-Data-Structure-Util>=0:${PORTSDIR}/devel/p5-Data-Structure-Util
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-RRDTool-OO/Makefile b/devel/p5-RRDTool-OO/Makefile
index 8315fd739468..cd9cb3d2db3a 100644
--- a/devel/p5-RRDTool-OO/Makefile
+++ b/devel/p5-RRDTool-OO/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= stefan@fh-mainz.de
COMMENT= RRDTool::OO - Object-oriented interface to RRDTool
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
+BUILD_DEPENDS= rrdtool>=0:${PORTSDIR}/databases/rrdtool \
p5-Log-Log4perl>=0.40:${PORTSDIR}/devel/p5-Log-Log4perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/p5-SVN-Agent/Makefile b/devel/p5-SVN-Agent/Makefile
index 79e4d585a140..fcedf4ff85a8 100644
--- a/devel/p5-SVN-Agent/Makefile
+++ b/devel/p5-SVN-Agent/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Simple svn manipulation
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
+BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/p5-SVN-Log/Makefile b/devel/p5-SVN-Log/Makefile
index 54c93e2a8a7a..e6fa0b2dfbac 100644
--- a/devel/p5-SVN-Log/Makefile
+++ b/devel/p5-SVN-Log/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= SVN::Log - Extract change logs from a Subversion server
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
+BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/p5-SVN-Statistics/Makefile b/devel/p5-SVN-Statistics/Makefile
index e73cef04c43b..e501b32b03b8 100644
--- a/devel/p5-SVN-Statistics/Makefile
+++ b/devel/p5-SVN-Statistics/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= SVN::Statistics - perl module to create subversion statistics
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
+BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-RRDTool-OO>=0:${PORTSDIR}/devel/p5-RRDTool-OO \
p5-Data-Dumper-Simple>=0:${PORTSDIR}/devel/p5-Data-Dumper-Simple \
p5-IO-Toolkit>=0:${PORTSDIR}/devel/p5-IO-Toolkit
diff --git a/devel/p5-Shell-EnvImporter/Makefile b/devel/p5-Shell-EnvImporter/Makefile
index c759e446ed21..bfe2dc7995c2 100644
--- a/devel/p5-Shell-EnvImporter/Makefile
+++ b/devel/p5-Shell-EnvImporter/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mhjacks@swbell.net
COMMENT= Inherit different shell environments, and restore previous
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
+RUN_DEPENDS= p5-Class-MethodMaker>=0:${PORTSDIR}/devel/p5-Class-MethodMaker
PERL_CONFIGURE= yes
diff --git a/devel/p5-Sub-WrapPackages/Makefile b/devel/p5-Sub-WrapPackages/Makefile
index bce395fedffd..8adc5926fc94 100644
--- a/devel/p5-Sub-WrapPackages/Makefile
+++ b/devel/p5-Sub-WrapPackages/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= hartzell@alerce.com
COMMENT= Add pre- and post-execution wrappers
-RUN_DEPENDS= ${SITE_PERL}/Hook/LexWrap.pm:${PORTSDIR}/devel/p5-Hook-LexWrap
+RUN_DEPENDS= p5-Hook-LexWrap>=0:${PORTSDIR}/devel/p5-Hook-LexWrap
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Template-Provider-Encode/Makefile b/devel/p5-Template-Provider-Encode/Makefile
index 35ec9837c3fc..4df56e7aad55 100644
--- a/devel/p5-Template-Provider-Encode/Makefile
+++ b/devel/p5-Template-Provider-Encode/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mopsfelder@gmail.com
COMMENT= Encode templates for Template Toolkit
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template/Provider.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
PERL_CONFIGURE= yes
diff --git a/devel/p5-Term-Animation/Makefile b/devel/p5-Term-Animation/Makefile
index b29bcfbd7942..88075ad5c469 100644
--- a/devel/p5-Term-Animation/Makefile
+++ b/devel/p5-Term-Animation/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fjoe@FreeBSD.org
COMMENT= ASCII sprite animation framework
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Curses.pm:${PORTSDIR}/devel/p5-Curses
+BUILD_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Thrift/Makefile b/devel/p5-Thrift/Makefile
index aea4fca0f16d..5afda100bd01 100644
--- a/devel/p5-Thrift/Makefile
+++ b/devel/p5-Thrift/Makefile
@@ -15,8 +15,8 @@ DISTFILES=
MAINTAINER= komarov@valerka.net
COMMENT= Perl interface to Thrift
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Bit/Vector.pm:${PORTSDIR}/math/p5-Bit-Vector
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Bit/Vector.pm:${PORTSDIR}/math/p5-Bit-Vector
+BUILD_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector
+RUN_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector
FETCH_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/devel/thrift:extract
PERL_CONFIGURE= YES
diff --git a/devel/p5-Tie-File-AsHash/Makefile b/devel/p5-Tie-File-AsHash/Makefile
index 8aa60486c975..fd65c839a360 100644
--- a/devel/p5-Tie-File-AsHash/Makefile
+++ b/devel/p5-Tie-File-AsHash/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rdg@bzerk.org
COMMENT= Access the lines of a disk file via a Perl hash
-BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${SITE_PERL}/Tie/File.pm:${PORTSDIR}/devel/p5-Tie-File
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= p5-Tie-File>=0:${PORTSDIR}/devel/p5-Tie-File
PERL_CONFIGURE= yes
diff --git a/devel/p5-Tie-ShareLite/Makefile b/devel/p5-Tie-ShareLite/Makefile
index 64bcf9f5c58c..95b57b78a133 100644
--- a/devel/p5-Tie-ShareLite/Makefile
+++ b/devel/p5-Tie-ShareLite/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= Tied hash interface to IPC::ShareLite
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite
+RUN_DEPENDS= p5-IPC-ShareLite>=0:${PORTSDIR}/devel/p5-IPC-ShareLite
PERL_CONFIGURE= yes
diff --git a/devel/p5-User-Identity/Makefile b/devel/p5-User-Identity/Makefile
index 589297fe6e19..66f011e23eb9 100644
--- a/devel/p5-User-Identity/Makefile
+++ b/devel/p5-User-Identity/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mcampos@bpsw.biz
COMMENT= Perl module for abstracting information about a physical person
-RUN_DEPENDS= ${SITE_PERL}/Geography/Countries.pm:${PORTSDIR}/misc/p5-Geography-Countries
+RUN_DEPENDS= p5-Geography-Countries>=0:${PORTSDIR}/misc/p5-Geography-Countries
PERL_CONFIGURE= yes
diff --git a/devel/p5-VCS-CVS/Makefile b/devel/p5-VCS-CVS/Makefile
index 0b24727a4620..8cb75dd1dca4 100644
--- a/devel/p5-VCS-CVS/Makefile
+++ b/devel/p5-VCS-CVS/Makefile
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= tolid@plab.ku.dk
COMMENT= Perl module that provides a simple interface to CVS
-BUILD_DEPENDS= ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod
+BUILD_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
PERL_MODBUILD= yes
MAN3= VCS::CVS.3
diff --git a/devel/svn2git/Makefile b/devel/svn2git/Makefile
index daf9f3ac8f6f..0464e25fbcf0 100644
--- a/devel/svn2git/Makefile
+++ b/devel/svn2git/Makefile
@@ -14,8 +14,8 @@ COMMENT= Imports svn repositories into git
LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion
RUN_DEPENDS+= git:${PORTSDIR}/devel/git \
- ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-subversion>=0:${PORTSDIR}/devel/p5-subversion
LICENSES= GPLv1 GPLv2 GPLv3
diff --git a/devel/svn_load_dirs/Makefile b/devel/svn_load_dirs/Makefile
index dbfe400eea10..2178158097ff 100644
--- a/devel/svn_load_dirs/Makefile
+++ b/devel/svn_load_dirs/Makefile
@@ -14,7 +14,7 @@ DISTFILES= # none
MAINTAINER= knu@FreeBSD.org
COMMENT= A Perl script to load directories into a Subversion repository
-RUN_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion16
USE_BZIP2= yes