aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-11-15 16:28:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-11-15 16:28:54 +0000
commit9e4994d09c46e71664a19132ee9bfc08c65683ae (patch)
treeba33f43e927628812f1c6267f60ce2957b255ac9 /devel
parent023e999230294f676f4a21c7d5993f272ed599ad (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-CPAN-Site/Makefile34
-rw-r--r--devel/p5-CPAN-Site/distinfo2
-rw-r--r--devel/p5-CPAN-Site/pkg-descr7
-rw-r--r--devel/p5-CPAN-Site/pkg-plist9
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 60a390c1875d..def388097575 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1489,6 +1489,7 @@
SUBDIR += p5-CPAN-Reporter
SUBDIR += p5-CPAN-Reporter-Smoker
SUBDIR += p5-CPAN-SQLite
+ SUBDIR += p5-CPAN-Site
SUBDIR += p5-CPAN-Testers-Report
SUBDIR += p5-CPAN-Uploader
SUBDIR += p5-CPAN-YACSmoke
diff --git a/devel/p5-CPAN-Site/Makefile b/devel/p5-CPAN-Site/Makefile
new file mode 100644
index 000000000000..b9769919fc42
--- /dev/null
+++ b/devel/p5-CPAN-Site/Makefile
@@ -0,0 +1,34 @@
+# Created by: Anes Mukhametov <anes@anes.su>
+# $FreeBSD$
+
+PORTNAME= CPAN-Site
+PORTVERSION= 1.11
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anes@anes.su
+COMMENT= Extend CPAN with private packages
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Archive-Tar>=1.00:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
+ p5-CPAN-Checksums>=0:${PORTSDIR}/devel/p5-CPAN-Checksums \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-IO-Zlib>=0:${PORTSDIR}/archivers/p5-IO-Zlib \
+ p5-Log-Report>=0.25:${PORTSDIR}/devel/p5-Log-Report \
+ p5-version>=0.76:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= p5-Archive-Tar>=1.00:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
+ p5-CPAN-Checksums>=0:${PORTSDIR}/devel/p5-CPAN-Checksums \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-IO-Zlib>=0:${PORTSDIR}/archivers/p5-IO-Zlib \
+ p5-Log-Report>=0.25:${PORTSDIR}/devel/p5-Log-Report \
+ p5-version>=0.76:${PORTSDIR}/devel/p5-version
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-CPAN-Site/distinfo b/devel/p5-CPAN-Site/distinfo
new file mode 100644
index 000000000000..f85a1cb1422c
--- /dev/null
+++ b/devel/p5-CPAN-Site/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CPAN-Site-1.11.tar.gz) = 2d00aaac94d323a3041eeac691e8c6aa3140b8203afbf7b3a775c580cbe5ad7d
+SIZE (CPAN-Site-1.11.tar.gz) = 71907
diff --git a/devel/p5-CPAN-Site/pkg-descr b/devel/p5-CPAN-Site/pkg-descr
new file mode 100644
index 000000000000..b6a2ab6bd8cb
--- /dev/null
+++ b/devel/p5-CPAN-Site/pkg-descr
@@ -0,0 +1,7 @@
+The cpansite script is used to create your own CPAN server.
+The logic is implemented in CPAN::Site::Index which you may
+use directly.
+
+You only need to install this module on one server in your network.
+
+WWW: http://search.cpan.org/dist/CPAN-Site/
diff --git a/devel/p5-CPAN-Site/pkg-plist b/devel/p5-CPAN-Site/pkg-plist
new file mode 100644
index 000000000000..b2bf7ebeff77
--- /dev/null
+++ b/devel/p5-CPAN-Site/pkg-plist
@@ -0,0 +1,9 @@
+bin/cpansite
+man/man1/cpansite.1.gz
+%%SITE_PERL%%/CPAN/Site.pm
+%%SITE_PERL%%/CPAN/Site/Index.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Site/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Site
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN
+@dirrm %%SITE_PERL%%/CPAN/Site
+@dirrmtry %%SITE_PERL%%/CPAN