aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-31 14:26:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-31 14:26:16 +0000
commitb99eaa71055452fc86a767ddb4c5031d89f1ac21 (patch)
treeafc7f40a0537283a4270b7051c80dcc78427b64e /devel
parent83ac50cae7da36624311b8ad19c70045039c5f4f (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/bsdowl/Makefile25
-rw-r--r--devel/bsdowl/distinfo2
-rw-r--r--devel/bsdowl/pkg-descr15
-rw-r--r--devel/bsdowl/pkg-plist61
5 files changed, 104 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d257839ecd3e..ac85006f4fa9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -144,6 +144,7 @@
SUBDIR += bpython
SUBDIR += bsdbuild
SUBDIR += bsdcflow
+ SUBDIR += bsdowl
SUBDIR += bufferpool
SUBDIR += bug-buddy
SUBDIR += bugzilla44
diff --git a/devel/bsdowl/Makefile b/devel/bsdowl/Makefile
new file mode 100644
index 000000000000..40c401acee2d
--- /dev/null
+++ b/devel/bsdowl/Makefile
@@ -0,0 +1,25 @@
+# Created by: Michael Le Barbier Grünewald <michipili@gmail.com>
+# $FreeBSD$
+
+PORTNAME= bsdowl
+PORTVERSION= 2.2.1
+CATEGORIES= devel
+MASTER_SITES= http://github.com/michipili/bsdowl/releases/download/v${PORTVERSION}/
+
+MAINTAINER= michipili@gmail.com
+COMMENT= BSD Make macros for TeX, OCaml, noweb and more
+
+LICENSE= CeCILL-Bv1
+LICENSE_NAME= CeCILL B, Version 1.0
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= gm:${PORTSDIR}/graphics/GraphicsMagick
+BUILD_DEPENDS= gm:${PORTSDIR}/graphics/GraphicsMagick
+
+USES= tar:xz
+
+HAS_CONFIGURE= yes
+MAKE_ENV+= MAKEFLAGS=-r
+
+.include <bsd.port.mk>
diff --git a/devel/bsdowl/distinfo b/devel/bsdowl/distinfo
new file mode 100644
index 000000000000..fba2605558f2
--- /dev/null
+++ b/devel/bsdowl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bsdowl-2.2.1.tar.xz) = 269030428efec1a554f7ce038820f218e09523d771875c2ed6b6e7cd0288f4fd
+SIZE (bsdowl-2.2.1.tar.xz) = 137432
diff --git a/devel/bsdowl/pkg-descr b/devel/bsdowl/pkg-descr
new file mode 100644
index 000000000000..75634099d3ce
--- /dev/null
+++ b/devel/bsdowl/pkg-descr
@@ -0,0 +1,15 @@
+BSD Owl Scripts
+
+This collection of BSD Make directives aims at providing a highly
+portable build system targetting modern UNIX systems and supporting
+common or less command languages.
+
+It can already be used to:
+
+* Preparation and publication of TeX documents;
+* Development of TeX macros with NOWEB;
+* Development of OCaml software;
+* Maintainance of a FreeBSD workstation configuration files;
+* Preparation of a static website with ONSGMLS.
+
+WWW: https://github.com/michipili/bsdowl
diff --git a/devel/bsdowl/pkg-plist b/devel/bsdowl/pkg-plist
new file mode 100644
index 000000000000..f59daa87e445
--- /dev/null
+++ b/devel/bsdowl/pkg-plist
@@ -0,0 +1,61 @@
+bin/mp2eps
+bin/mp2pdf
+bin/mp2png
+share/bps/nwlatex.css
+share/mk/bps.autoconf.mk
+share/mk/bps.clean.mk
+share/mk/bps.credentials.mk
+share/mk/bps.files.mk
+share/mk/bps.init.mk
+share/mk/bps.objdir.mk
+share/mk/bps.own.mk
+share/mk/bps.project.mk
+share/mk/bps.subdir.mk
+share/mk/bps.usertarget.mk
+share/mk/conf.freebsd.mk
+share/mk/latex.bibtex.mk
+share/mk/latex.doc.mk
+share/mk/latex.doc.post.mk
+share/mk/latex.doc.pre.mk
+share/mk/misc.dotfile.mk
+share/mk/misc.elisp.mk
+share/mk/misc.script.mk
+share/mk/noweb.latex.mk
+share/mk/noweb.main.mk
+share/mk/ocaml.build.mk
+share/mk/ocaml.compile.mk
+share/mk/ocaml.depend.mk
+share/mk/ocaml.dirs.mk
+share/mk/ocaml.find.mk
+share/mk/ocaml.init.mk
+share/mk/ocaml.lex.mk
+share/mk/ocaml.lib.mk
+share/mk/ocaml.main.mk
+share/mk/ocaml.manual.mk
+share/mk/ocaml.meta.mk
+share/mk/ocaml.object.mk
+share/mk/ocaml.odoc.mk
+share/mk/ocaml.pack.mk
+share/mk/ocaml.prog.mk
+share/mk/ocaml.source.mk
+share/mk/ocaml.tools.mk
+share/mk/ocaml.toplevel.mk
+share/mk/ocaml.yacc.mk
+share/mk/tex.device.dvi.mk
+share/mk/tex.device.pdf.mk
+share/mk/tex.device.ps.mk
+share/mk/tex.doc.main.mk
+share/mk/tex.doc.mk
+share/mk/tex.doc.post.mk
+share/mk/tex.doc.pre.mk
+share/mk/tex.driver.dvi.mk
+share/mk/tex.driver.dvips.mk
+share/mk/tex.driver.pdftex.mk
+share/mk/tex.files.main.mk
+share/mk/tex.files.mk
+share/mk/tex.init.mk
+share/mk/tex.mpost.mk
+share/mk/texmf.init.mk
+share/mk/www.files.mk
+share/mk/www.sgml.mk
+share/texmf/tex/latex/bps/nwlatex.tex