aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-19 14:40:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-19 14:40:19 +0000
commit354c22cb82e98987bbb02a6a23f806345940722b (patch)
tree0bf3f49c27996c14066177a2d935d94846fa6bbd /devel
parent6b75e7b170aad7553719f5762b70bd9c9a254b10 (diff)
downloadports-354c22cb82e98987bbb02a6a23f806345940722b.tar.gz
ports-354c22cb82e98987bbb02a6a23f806345940722b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Devel-Cover/Makefile2
-rw-r--r--devel/p5-Devel-Cover/distinfo5
-rw-r--r--devel/p5-Devel-Cover/files/patch-Cover.xs84
3 files changed, 4 insertions, 87 deletions
diff --git a/devel/p5-Devel-Cover/Makefile b/devel/p5-Devel-Cover/Makefile
index b1fbca9a3de6..3875f18673d9 100644
--- a/devel/p5-Devel-Cover/Makefile
+++ b/devel/p5-Devel-Cover/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Devel-Cover
-PORTVERSION= 1.23
+PORTVERSION= 1.24
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/devel/p5-Devel-Cover/distinfo b/devel/p5-Devel-Cover/distinfo
index 93ea6f2b44af..2251dce09f04 100644
--- a/devel/p5-Devel-Cover/distinfo
+++ b/devel/p5-Devel-Cover/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Devel-Cover-1.23.tar.gz) = fb2d9efdbb73b4b7f6f3091279dbcc6f494e6061ff27572758a410c080084054
-SIZE (Devel-Cover-1.23.tar.gz) = 198522
+TIMESTAMP = 1492606869
+SHA256 (Devel-Cover-1.24.tar.gz) = 0ce2470e0e36e1eae5d5141da5eaca32bb9f2db7d871a2cac85c8e8cd9f67f74
+SIZE (Devel-Cover-1.24.tar.gz) = 202584
diff --git a/devel/p5-Devel-Cover/files/patch-Cover.xs b/devel/p5-Devel-Cover/files/patch-Cover.xs
deleted file mode 100644
index b0c7c6d4cf6e..000000000000
--- a/devel/p5-Devel-Cover/files/patch-Cover.xs
+++ /dev/null
@@ -1,84 +0,0 @@
-From 712aa6bdaac2d717f08dfcc7481a3aa45b815cb8 Mon Sep 17 00:00:00 2001
-From: Dan Collins <dcollinsn@gmail.com>
-Date: Tue, 7 Jun 2016 12:43:16 -0400
-Subject: [PATCH 1/2] The Perl core, since 586d4abb8, has had a build mode
- called PERL_OP_PARENT, which causes the last sibling in a sibling chain to
- use op_sibling to point to the parent, rather than being null. Under this
- build mode, op_sibling is now called op_sibparent. This causes errors of the
- type:
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-error: ‘OP {aka const struct op}’ has no member named ‘op_sibling’; did
-you mean ‘op_sibparent’?
-
-The name of the field was changed to force programs using op_sibling to
-revisit their code in light of this change - now, the last sibling in
-a chain will have a non-NULL op_sibparent, and the caller must use
-op_moresib to know whether the pointer is to another sibling or to
-the parent.
-
-This breakage is now visible in bleadperl, since PERL_OP_PARENT was
-made default, and will be default in 5.26.0.
-
-op.h provides a macro, OpSIBLING(o), which behaves correctly, checking
-op->moresib under PERL_OP_PARENT, and returning either op_sibparent or
-NULL. This patch replaces op_sibling with use that macro.
---- Cover.xs.orig 2016-04-24 14:42:56 UTC
-+++ Cover.xs
-@@ -126,6 +126,14 @@ extern "C" {
- }
- #endif
-
-+/* op->op_sibling is deprecated on new perls, but the OpSIBLING macro doesn't
-+ exist on older perls. We don't need to check for PERL_OP_PARENT here
-+ because if PERL_OP_PARENT was set, and we needed to check op_moresib,
-+ we would already have this macro. */
-+#ifndef OpSIBLING
-+#define OpSIBLING(o) (0 + (o)->op_sibling)
-+#endif
-+
- static double get_elapsed() {
- #ifdef WIN32
- dTHX;
-@@ -614,9 +622,9 @@ static OP *find_skipped_conditional(pTHX
- return NULL;
-
- /* Get to the end of the "a || b || c" block */
-- OP *right = cLOGOP->op_first->op_sibling;
-- while (right && cLOGOPx(right)->op_sibling)
-- right = cLOGOPx(right)->op_sibling;
-+ OP *right = OpSIBLING(cLOGOP->op_first);
-+ while (right && OpSIBLING(cLOGOPx(right)))
-+ right = OpSIBLING(cLOGOPx(right));
-
- if (!right)
- return NULL;
-@@ -784,7 +792,7 @@ static void cover_logop(pTHX) {
- (PL_op->op_type == OP_XOR)) {
- /* no short circuit */
-
-- OP *right = cLOGOP->op_first->op_sibling;
-+ OP *right = OpSIBLING(cLOGOP->op_first);
-
- NDEB(op_dump(right));
-
-@@ -874,7 +882,7 @@ static void cover_logop(pTHX) {
- } else {
- /* short circuit */
- #if PERL_VERSION > 14
-- OP *up = cLOGOP->op_first->op_sibling->op_next;
-+ OP *up = OpSIBLING(cLOGOP->op_first)->op_next;
- #if PERL_VERSION > 18
- OP *skipped;
- #endif
-@@ -887,7 +895,7 @@ static void cover_logop(pTHX) {
- add_conditional(aTHX_ up, 3);
- if (up->op_next == PL_op->op_next)
- break;
-- up = cLOGOPx(up)->op_first->op_sibling->op_next;
-+ up = OpSIBLING(cLOGOPx(up)->op_first)->op_next;
- }
- #endif
- add_conditional(aTHX_ PL_op, 3);