aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-09-22 14:15:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-09-22 14:15:17 +0000
commit61f372f625abb18a20eab953ba5480f3a11431e8 (patch)
treee7fb367c1f43973697ff438db06604c3c133a818 /devel
parentba7b808f5caddd320cefdc1a89306c711865c2c2 (diff)
downloadports-61f372f625abb18a20eab953ba5480f3a11431e8.tar.gz
ports-61f372f625abb18a20eab953ba5480f3a11431e8.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-crcmod/Makefile31
-rw-r--r--devel/py-crcmod/distinfo3
-rw-r--r--devel/py-crcmod/pkg-descr6
-rw-r--r--devel/py-crcmod/pkg-plist46
5 files changed, 87 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ca60c14cfccc..33de9471a785 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2673,6 +2673,7 @@
SUBDIR += py-configobj
SUBDIR += py-construct
SUBDIR += py-coverage
+ SUBDIR += py-crcmod
SUBDIR += py-ctags
SUBDIR += py-ctypes
SUBDIR += py-cxx
diff --git a/devel/py-crcmod/Makefile b/devel/py-crcmod/Makefile
new file mode 100644
index 000000000000..c83894c2e463
--- /dev/null
+++ b/devel/py-crcmod/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: crcmod
+# Date created: 19 Sep 2010
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crcmod
+PORTVERSION= 1.7
+CATEGORIES= devel python
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Module for Cyclic Redundancy Check (CRC) calculations
+
+LICENSE= MIT
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/changelog ${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-crcmod/distinfo b/devel/py-crcmod/distinfo
new file mode 100644
index 000000000000..ce8e3cb3e8de
--- /dev/null
+++ b/devel/py-crcmod/distinfo
@@ -0,0 +1,3 @@
+MD5 (crcmod-1.7.tar.gz) = 2d5b92117d958dcead94f9e17f54cd32
+SHA256 (crcmod-1.7.tar.gz) = dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e
+SIZE (crcmod-1.7.tar.gz) = 89670
diff --git a/devel/py-crcmod/pkg-descr b/devel/py-crcmod/pkg-descr
new file mode 100644
index 000000000000..280c75e1ac62
--- /dev/null
+++ b/devel/py-crcmod/pkg-descr
@@ -0,0 +1,6 @@
+This is a Python module for generating objects that compute the Cyclic
+Redundancy Check (CRC). It includes a (optional) C extension for fast
+calculation, as well as a pure Python implementation. 8, 16, 24, 32,
+and 64 bit CRC are supported.
+
+WWW: http://crcmod.sourceforge.net/
diff --git a/devel/py-crcmod/pkg-plist b/devel/py-crcmod/pkg-plist
new file mode 100644
index 000000000000..b87195b7b0de
--- /dev/null
+++ b/devel/py-crcmod/pkg-plist
@@ -0,0 +1,46 @@
+%%PYTHON_SITELIBDIR%%/crcmod/__init__.py
+%%PYTHON_SITELIBDIR%%/crcmod/__init__.pyc
+%%PYTHON_SITELIBDIR%%/crcmod/__init__.pyo
+%%PYTHON_SITELIBDIR%%/crcmod/_crcfunext.so
+%%PYTHON_SITELIBDIR%%/crcmod/_crcfunpy.py
+%%PYTHON_SITELIBDIR%%/crcmod/_crcfunpy.pyc
+%%PYTHON_SITELIBDIR%%/crcmod/_crcfunpy.pyo
+%%PYTHON_SITELIBDIR%%/crcmod/crcmod.py
+%%PYTHON_SITELIBDIR%%/crcmod/crcmod.pyc
+%%PYTHON_SITELIBDIR%%/crcmod/crcmod.pyo
+%%PYTHON_SITELIBDIR%%/crcmod/predefined.py
+%%PYTHON_SITELIBDIR%%/crcmod/predefined.pyc
+%%PYTHON_SITELIBDIR%%/crcmod/predefined.pyo
+%%PYTHON_SITELIBDIR%%/crcmod/test.py
+%%PYTHON_SITELIBDIR%%/crcmod/test.pyc
+%%PYTHON_SITELIBDIR%%/crcmod/test.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/crcmod
+%%PORTDOCS%%%%DOCSDIR%%/html/_sources/crcmod.predefined.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/_sources/crcmod.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/_sources/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/_sources/intro.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/default.css
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/doctools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/file.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/minus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/plus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/pygments.css
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/.buildinfo
+%%PORTDOCS%%%%DOCSDIR%%/html/crcmod.html
+%%PORTDOCS%%%%DOCSDIR%%/html/crcmod.predefined.html
+%%PORTDOCS%%%%DOCSDIR%%/html/genindex.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/html/modindex.html
+%%PORTDOCS%%%%DOCSDIR%%/html/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/html/search.html
+%%PORTDOCS%%%%DOCSDIR%%/html/searchindex.js
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/changelog
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/_static
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/_sources
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%