aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-17 18:28:30 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-17 18:28:30 +0000
commit884199b6e1ab425945206cb7f5210b4598b3df18 (patch)
treef80b215f616c7711cea9066d29d516ad8874d685 /devel
parent2be311c6dd113ec242e9edeb1cd59e5c45f5dbd3 (diff)
downloadports-884199b6e1ab425945206cb7f5210b4598b3df18.tar.gz
ports-884199b6e1ab425945206cb7f5210b4598b3df18.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/sdl_ldbad/Makefile34
-rw-r--r--devel/sdl_ldbad/pkg-comment1
-rw-r--r--devel/sdl_ldbad/pkg-descr8
-rw-r--r--devel/sdl_ldbad/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8ac7edf43383..fe595afa8456 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -625,6 +625,7 @@
SUBDIR += scons
SUBDIR += sdcc
SUBDIR += sdl12
+ SUBDIR += sdl_ldbad
SUBDIR += sdlmm
SUBDIR += sdts++
SUBDIR += semantic
diff --git a/devel/sdl_ldbad/Makefile b/devel/sdl_ldbad/Makefile
new file mode 100644
index 000000000000..79b4dc2e9315
--- /dev/null
+++ b/devel/sdl_ldbad/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: sdl_ldbad
+# Date created: 17 April 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_ldbad
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-fetch:
+ @${DO_NADA}
+
+do-install:
+ ${LN} -shf ${LOCALBASE}/bin/sdl11-config ${PREFIX}/bin/sdl-config
+ ${LN} -shf ${LOCALBASE}/include/SDL11 ${PREFIX}/include/SDL
+.for lib in SDL-1.1.a SDL-1.1.so SDL-1.1.so.4 SDLmain-1.1.a
+ ${LN} -shf ${LOCALBASE}/lib/${lib} ${PREFIX}/lib/${lib:S/-1.1//}
+.endfor
+ ${LN} -shf ${LOCALBASE}/share/aclocal/sdl11.m4 ${PREFIX}/share/aclocal/sdl.m4
+
+.include <bsd.port.mk>
diff --git a/devel/sdl_ldbad/pkg-comment b/devel/sdl_ldbad/pkg-comment
new file mode 100644
index 000000000000..cc9062fccfe8
--- /dev/null
+++ b/devel/sdl_ldbad/pkg-comment
@@ -0,0 +1 @@
+A SDL Linux Developer's BandAiD
diff --git a/devel/sdl_ldbad/pkg-descr b/devel/sdl_ldbad/pkg-descr
new file mode 100644
index 000000000000..8a3ae91f3360
--- /dev/null
+++ b/devel/sdl_ldbad/pkg-descr
@@ -0,0 +1,8 @@
+This is a SDL Linux Developer's BandAiD - a package, which when combined
+with a FreeBSD SDL package creates development environment more similar to
+SDL development environment on other platforms (mostly Linux).
+
+Please note that this package is only for developer's use - no package should
+use it as a dependency!
+
+WWW: http://www.libsdl.org/
diff --git a/devel/sdl_ldbad/pkg-plist b/devel/sdl_ldbad/pkg-plist
new file mode 100644
index 000000000000..ab96beb96aa5
--- /dev/null
+++ b/devel/sdl_ldbad/pkg-plist
@@ -0,0 +1,7 @@
+bin/sdl-config
+include/SDL
+lib/SDL.a
+lib/SDL.so
+lib/SDL.so.4
+lib/SDLmain.a
+share/aclocal/sdl.m4