aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-02 10:32:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-02 10:32:38 +0000
commitbafc92f0595aff2a31e99b366ff140e8d2c23bc4 (patch)
treec005108e02753a44ba8d58eaa4258c76281b2fa3 /devel
parentb9f823ab2b6365b94ff160496d98f76686c196fd (diff)
downloadports-bafc92f0595aff2a31e99b366ff140e8d2c23bc4.tar.gz
ports-bafc92f0595aff2a31e99b366ff140e8d2c23bc4.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-dialogs/Makefile34
-rw-r--r--devel/ruby-dialogs/distinfo2
-rw-r--r--devel/ruby-dialogs/files/patch-dialogs.rb11
-rw-r--r--devel/ruby-dialogs/pkg-comment1
-rw-r--r--devel/ruby-dialogs/pkg-descr7
-rw-r--r--devel/ruby-dialogs/pkg-plist3
7 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 409241584c69..b6f27c915742 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -351,6 +351,7 @@
SUBDIR += ruby-amstd
SUBDIR += ruby-byaccr
SUBDIR += ruby-date2
+ SUBDIR += ruby-dialogs
SUBDIR += ruby-filelock
SUBDIR += ruby-gemfinder
SUBDIR += ruby-intl
diff --git a/devel/ruby-dialogs/Makefile b/devel/ruby-dialogs/Makefile
new file mode 100644
index 000000000000..81b5afd76445
--- /dev/null
+++ b/devel/ruby-dialogs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: rubyDialogs
+# Date created: 2 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dialogs
+PORTVERSION= 1.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://bluesine.com/archives/software/ruby/rubyDialogs/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}.rb ${PORTNAME}.html
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # none
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKDIR}/dialogs.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/dialogs
+ ${INSTALL_DATA} ${WRKDIR}/dialogs.html ${RUBY_DOCDIR}/dialogs/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-dialogs/distinfo b/devel/ruby-dialogs/distinfo
new file mode 100644
index 000000000000..16338a0b6018
--- /dev/null
+++ b/devel/ruby-dialogs/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/dialogs.rb) = 7349d8acf4ea0852e33226f6bd692d72
+MD5 (ruby/dialogs.html) = 03fa5b05028ac9a3f7893295d896a6a2
diff --git a/devel/ruby-dialogs/files/patch-dialogs.rb b/devel/ruby-dialogs/files/patch-dialogs.rb
new file mode 100644
index 000000000000..9fd6bfcdb7fe
--- /dev/null
+++ b/devel/ruby-dialogs/files/patch-dialogs.rb
@@ -0,0 +1,11 @@
+--- dialogs.rb.orig Fri Mar 2 18:19:37 2001
++++ dialogs.rb Fri Mar 2 19:15:11 2001
+@@ -73,7 +73,7 @@
+ class Dialog
+
+ def perform(cmd)
+- options = "--backtitle '#{@title}'"
++ options = if /^--title / =~ cmd then "" else "--title '#{@title}'" end
+ tf=Tempfile.new("dialog")
+ torun=@DIALOG+' '+options+' '+cmd+" 2> #{tf.path}"
+ system(torun)
diff --git a/devel/ruby-dialogs/pkg-comment b/devel/ruby-dialogs/pkg-comment
new file mode 100644
index 000000000000..842a71b3ba49
--- /dev/null
+++ b/devel/ruby-dialogs/pkg-comment
@@ -0,0 +1 @@
+A simple Ruby interface to dialog(1)
diff --git a/devel/ruby-dialogs/pkg-descr b/devel/ruby-dialogs/pkg-descr
new file mode 100644
index 000000000000..ede325d37c88
--- /dev/null
+++ b/devel/ruby-dialogs/pkg-descr
@@ -0,0 +1,7 @@
+rubyDialogs is a simple interface to dialog(1).
+
+This software is distributed under the Bluesine public license, which
+is a variant of the BSD license. (See: http://bluesine.com/license/)
+
+Author: Jeff Clement <jeff@bluesine.com>
+WWW: http://bluesine.com/archives/software/ruby/rubyDialogs/
diff --git a/devel/ruby-dialogs/pkg-plist b/devel/ruby-dialogs/pkg-plist
new file mode 100644
index 000000000000..f9b17ced665f
--- /dev/null
+++ b/devel/ruby-dialogs/pkg-plist
@@ -0,0 +1,3 @@
+%%RUBY_SITELIBDIR%%/dialogs.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/dialogs/dialogs.html
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/dialogs