aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-12-11 10:10:02 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-12-11 10:10:02 +0000
commitc06409c76b6e5831ff06d3cd251af01b8228e4bb (patch)
tree7d1d225f29646e0422140858244af3016287d2f2 /devel
parentda9bce2d6f29be401630ac745a58c4dae8648b77 (diff)
downloadports-c06409c76b6e5831ff06d3cd251af01b8228e4bb.tar.gz
ports-c06409c76b6e5831ff06d3cd251af01b8228e4bb.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/astyle/Makefile2
-rw-r--r--devel/gdb/Makefile4
-rw-r--r--devel/libastylej/Makefile2
-rw-r--r--devel/llvm-cheri/Makefile4
-rw-r--r--devel/rapidjson/Makefile2
-rw-r--r--devel/thrift-cpp/Makefile2
6 files changed, 8 insertions, 8 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index e6c951f365a4..03e6a845cfa0 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -22,7 +22,7 @@ USES= compiler:c++11-lang dos2unix gmake
ALL_TARGET= astyle
DOS2UNIX_GLOB= *.ini
-WRKSRC= ${WRKDIR}/astyle/build/${COMPILER_TYPE}
+WRKSRC= ${WRKDIR}/astyle/build/${CHOSEN_COMPILER_TYPE}
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 66ae0aafe799..058b8310b8db 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -92,11 +92,11 @@ EXCLUDE+= readline
EXCLUDE+= zlib
.endif
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
-.if ${COMPILER_TYPE} == "clang"
+.if ${CHOSEN_COMPILER_TYPE} == clang
CFLAGS+= -Wno-extended-offsetof
.endif
diff --git a/devel/libastylej/Makefile b/devel/libastylej/Makefile
index 3b60317f7df0..4868cda3d897 100644
--- a/devel/libastylej/Makefile
+++ b/devel/libastylej/Makefile
@@ -20,7 +20,7 @@ USE_JAVA= yes
USE_LDCONFIG= yes
MAKE_ARGS+= JAVA_HOME=${JAVA_HOME}
-WRKSRC= ${WRKDIR}/astyle/build/${COMPILER_TYPE}
+WRKSRC= ${WRKDIR}/astyle/build/${CHOSEN_COMPILER_TYPE}
PLIST_FILES= lib/jni/libastylej${PKGNAMESUFFIX}.so lib/jni/libastylej${PKGNAMESUFFIX}.so.${PORTVERSION}
diff --git a/devel/llvm-cheri/Makefile b/devel/llvm-cheri/Makefile
index 87fd2db6c589..a04a331ceccc 100644
--- a/devel/llvm-cheri/Makefile
+++ b/devel/llvm-cheri/Makefile
@@ -195,13 +195,13 @@ MAN1SRCS+= bugpoint.1 dsymutil.1 llc.1 lli.1 llvm-ar.1 llvm-as.1 \
.include <bsd.port.pre.mk>
-.if ${OPSYS} == "FreeBSD" && ${COMPILER_TYPE} != clang
+.if ${OPSYS} == FreeBSD && ${CHOSEN_COMPILER_TYPE} != clang
# Evil hack around gcc48 not providing a usable c++11 environment on 9.x
PLIST_SUB:= ${PLIST_SUB:NLLDB=*} LLDB="@comment "
.endif
post-extract-LLDB-on:
-.if ${OPSYS} != "FreeBSD" || ${COMPILER_TYPE} == clang
+.if ${OPSYS} != FreeBSD || ${CHOSEN_COMPILER_TYPE} == clang
${MV} ${WRKSRC_lldb} ${PATCH_WRKSRC}/tools/lldb
.endif
diff --git a/devel/rapidjson/Makefile b/devel/rapidjson/Makefile
index cb3f043dd8b5..2e7db4608ab1 100644
--- a/devel/rapidjson/Makefile
+++ b/devel/rapidjson/Makefile
@@ -41,7 +41,7 @@ CXXFLAGS_powerpc= -Wno-error
CXXFLAGS_powerpcspe= -Wno-error
CXXFLAGS_powerpc64= -Wno-error
CXXFLAGS_sparc64= -Wno-error
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 50
+.if ${CHOSEN_COMPILER_TYPE} == clang
CXXFLAGS+= -Wno-zero-as-null-pointer-constant
.endif
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 1781f42599b9..652d67fe2808 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -63,7 +63,7 @@ EXPIRATION_DATE= 2019-03-15
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == clang
+.if ${CHOSEN_COMPILER_TYPE} == clang
USE_CXXSTD= c++11
.endif