aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2013-11-21 19:01:51 +0000
committerLars Thegler <lth@FreeBSD.org>2013-11-21 19:01:51 +0000
commit280f584d8670b3858b6961cd808e71b8a0afcfec (patch)
tree7177ab38a26892bb868cab2c312ab3dcf459a626 /devel
parentfa4a384f688efdbab5b81ecec70d5a8fe1575dbd (diff)
downloadports-280f584d8670b3858b6961cd808e71b8a0afcfec.tar.gz
ports-280f584d8670b3858b6961cd808e71b8a0afcfec.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Git-Sub/Makefile22
-rw-r--r--devel/p5-Git-Sub/distinfo2
-rw-r--r--devel/p5-Git-Sub/pkg-descr4
-rw-r--r--devel/p5-Git-Sub/pkg-plist6
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 28d266617e21..8c35eab6a3bc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2053,6 +2053,7 @@
SUBDIR += p5-Git-PurePerl
SUBDIR += p5-Git-Repository
SUBDIR += p5-Git-Repository-Plugin-Log
+ SUBDIR += p5-Git-Sub
SUBDIR += p5-Git-Wrapper
SUBDIR += p5-Glib-Object-Introspection
SUBDIR += p5-Glib2
diff --git a/devel/p5-Git-Sub/Makefile b/devel/p5-Git-Sub/Makefile
new file mode 100644
index 000000000000..4f147f724ceb
--- /dev/null
+++ b/devel/p5-Git-Sub/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= Git-Sub
+PORTVERSION= 0.130270
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Git commands imported into the git:: namespace
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS:= p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-System-Sub>=0:${PORTSDIR}/devel/p5-System-Sub
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Git-Sub/distinfo b/devel/p5-Git-Sub/distinfo
new file mode 100644
index 000000000000..17dd67ec5795
--- /dev/null
+++ b/devel/p5-Git-Sub/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Git-Sub-0.130270.tar.gz) = c766d1877b0dcecd950a75133010ff7b359254e8e8a46bfc2418086148e9a719
+SIZE (Git-Sub-0.130270.tar.gz) = 12261
diff --git a/devel/p5-Git-Sub/pkg-descr b/devel/p5-Git-Sub/pkg-descr
new file mode 100644
index 000000000000..f1e6a002e18c
--- /dev/null
+++ b/devel/p5-Git-Sub/pkg-descr
@@ -0,0 +1,4 @@
+Use git commands easily from your Perl program. Each git command
+is imported as a System::Sub DWIM sub.
+
+WWW: http://metacpan.org/release/Git-Sub
diff --git a/devel/p5-Git-Sub/pkg-plist b/devel/p5-Git-Sub/pkg-plist
new file mode 100644
index 000000000000..9ff65b19c503
--- /dev/null
+++ b/devel/p5-Git-Sub/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Git/Sub.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Git/Sub/.packlist
+%%PERL5_MAN3%%/Git::Sub.3.gz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Git/Sub
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Git
+@dirrmtry %%SITE_PERL%%/Git