aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2013-03-17 20:26:29 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2013-03-17 20:26:29 +0000
commit5dbe382736aa1fe65c2f8fc560fa5a8151a2e607 (patch)
tree233f239397a7de23191a6f0071c87714756d3938 /devel
parent42d283569c4ae929856da247168434e06cc67b67 (diff)
downloadports-5dbe382736aa1fe65c2f8fc560fa5a8151a2e607.tar.gz
ports-5dbe382736aa1fe65c2f8fc560fa5a8151a2e607.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-celluloid/Makefile20
-rw-r--r--devel/rubygem-celluloid/distinfo2
-rw-r--r--devel/rubygem-celluloid/pkg-descr5
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2edcb47e39b9..7b66b6320f82 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3956,6 +3956,7 @@
SUBDIR += rubygem-bugspots
SUBDIR += rubygem-builder
SUBDIR += rubygem-caesars
+ SUBDIR += rubygem-celluloid
SUBDIR += rubygem-childprocess
SUBDIR += rubygem-chronic
SUBDIR += rubygem-classifier
diff --git a/devel/rubygem-celluloid/Makefile b/devel/rubygem-celluloid/Makefile
new file mode 100644
index 000000000000..ea43eace5bac
--- /dev/null
+++ b/devel/rubygem-celluloid/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= celluloid
+PORTVERSION= 0.12.4
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Build concurrent programs out of concurrent objects
+
+RUN_DEPENDS= rubygem-timers>=1.0.0:${PORTSDIR}/devel/rubygem-timers \
+ rubygem-facter>=1.6.12:${PORTSDIR}/sysutils/rubygem-facter
+
+USE_RUBY= yes
+RUBY_VER= 1.9
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-celluloid/distinfo b/devel/rubygem-celluloid/distinfo
new file mode 100644
index 000000000000..6297eedcb9cc
--- /dev/null
+++ b/devel/rubygem-celluloid/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/celluloid-0.12.4.gem) = 2992c246a31937fff73892ddb6d30cd931df07d3b48d443e9d488db8ed84ad56
+SIZE (rubygem/celluloid-0.12.4.gem) = 33280
diff --git a/devel/rubygem-celluloid/pkg-descr b/devel/rubygem-celluloid/pkg-descr
new file mode 100644
index 000000000000..ee05c726bac8
--- /dev/null
+++ b/devel/rubygem-celluloid/pkg-descr
@@ -0,0 +1,5 @@
+Celluloid enables people to build concurrent programs out of concurrent
+objects just as easily as they build sequential programs out of
+sequential objects.
+
+WWW: https://rubygems.org/gems/celluloid