aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-21 10:30:25 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-21 10:30:25 +0000
commit77d4bbd37c0f0320a6c643b4bce52ad611c68d5d (patch)
tree11090c030b8c1cc1f49f6d7c15007164025f9573 /devel
parent28145c5d613eacc7411f3d221c3aff5c8f896f99 (diff)
downloadports-77d4bbd37c0f0320a6c643b4bce52ad611c68d5d.tar.gz
ports-77d4bbd37c0f0320a6c643b4bce52ad611c68d5d.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Tail/Makefile26
-rw-r--r--devel/p5-File-Tail/distinfo1
-rw-r--r--devel/p5-File-Tail/pkg-comment1
-rw-r--r--devel/p5-File-Tail/pkg-descr3
-rw-r--r--devel/p5-File-Tail/pkg-plist5
6 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 02c23d555ffe..b64c4a9ddc34 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -220,6 +220,7 @@
SUBDIR += p5-File-Slurp
SUBDIR += p5-File-Spec
SUBDIR += p5-File-Sync
+ SUBDIR += p5-File-Tail
SUBDIR += p5-File-Tools
SUBDIR += p5-Filter
SUBDIR += p5-FreezeThaw
diff --git a/devel/p5-File-Tail/Makefile b/devel/p5-File-Tail/Makefile
new file mode 100644
index 000000000000..a12bea0f33e5
--- /dev/null
+++ b/devel/p5-File-Tail/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: File-Tail
+# Date created: 19 December 2000
+# Whom: Jeremy Shaffner <jeremy@external.org>
+#
+# $FreeBSD$
+
+PORTNAME= File-Tail
+PORTVERSION= 0.97
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jeremy@external.org
+
+BUILD_DEPENDS= ${site_perl}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+
+site_perl= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
+
+USE_PERL5= YES
+PERL_CONFIGURE= YES
+
+MAN3= File::Tail.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Tail/distinfo b/devel/p5-File-Tail/distinfo
new file mode 100644
index 000000000000..d6d4fb3723cb
--- /dev/null
+++ b/devel/p5-File-Tail/distinfo
@@ -0,0 +1 @@
+MD5 (File-Tail-0.97.tar.gz) = f516d3e619db0bf7205b4ab4d6daede6
diff --git a/devel/p5-File-Tail/pkg-comment b/devel/p5-File-Tail/pkg-comment
new file mode 100644
index 000000000000..c75583c2a2c1
--- /dev/null
+++ b/devel/p5-File-Tail/pkg-comment
@@ -0,0 +1 @@
+Perl Module to read the end of a file as it's appended to
diff --git a/devel/p5-File-Tail/pkg-descr b/devel/p5-File-Tail/pkg-descr
new file mode 100644
index 000000000000..a00e317ac8b9
--- /dev/null
+++ b/devel/p5-File-Tail/pkg-descr
@@ -0,0 +1,3 @@
+The File::Tail module is designed for reading files which are continously
+appended to (the name comes from the tail -f directive). Usualy such files
+are logfiles of some description.
diff --git a/devel/p5-File-Tail/pkg-plist b/devel/p5-File-Tail/pkg-plist
new file mode 100644
index 000000000000..050adb86a85f
--- /dev/null
+++ b/devel/p5-File-Tail/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Tail/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/File/Tail.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/File/Tail/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Tail
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/File/Tail