aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-17 09:23:34 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-17 09:23:34 +0000
commitc704ae47c37dab845fcb6ddc257a469f8aede68e (patch)
treef5364b5b4ffcdbf44ba13da5e6cf5a536a5267a3 /devel
parentedb0d29c16ebf08b9e9e4f5e16ce99c3f4d54bd8 (diff)
downloadports-c704ae47c37dab845fcb6ddc257a469f8aede68e.tar.gz
ports-c704ae47c37dab845fcb6ddc257a469f8aede68e.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/wand-libconfig/Makefile32
-rw-r--r--devel/wand-libconfig/distinfo3
-rw-r--r--devel/wand-libconfig/pkg-descr3
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8b1ea5e7aefd..4c411d45c75d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2288,6 +2288,7 @@
SUBDIR += viewvc
SUBDIR += vstr
SUBDIR += vtcl
+ SUBDIR += wand-libconfig
SUBDIR += websvn
SUBDIR += wininfo
SUBDIR += winpdb
diff --git a/devel/wand-libconfig/Makefile b/devel/wand-libconfig/Makefile
new file mode 100644
index 000000000000..ef79e6e17405
--- /dev/null
+++ b/devel/wand-libconfig/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: wand-libconfig
+# Date created: Tue Oct 9 00:56:22 PDT 2007
+# Whom: Matt Peterson <matt@peterson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libconfig
+PORTVERSION= 1.0.5
+CATEGORIES= devel
+MASTER_SITES= http://research.wand.net.nz/software/libconfig/ \
+ http://matt.peterson.org/FreeBSD/ports/
+PKGNAMEPREFIX= wand-
+
+MAINTAINER= matt@peterson.org
+COMMENT= C library for parsing config files
+
+USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= include/libconfig.h lib/libconfig.a lib/libconfig.la \
+ lib/libconfig.so lib/libconfig.so.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/devel/wand-libconfig/distinfo b/devel/wand-libconfig/distinfo
new file mode 100644
index 000000000000..5397222ee24f
--- /dev/null
+++ b/devel/wand-libconfig/distinfo
@@ -0,0 +1,3 @@
+MD5 (libconfig-1.0.5.tar.gz) = c9b428565532a1de6c568b9e45958981
+SHA256 (libconfig-1.0.5.tar.gz) = 5cc4d0ea9f26b8563894eb06497d685f6c3835f4e58913bb75365bb9b86bc712
+SIZE (libconfig-1.0.5.tar.gz) = 318176
diff --git a/devel/wand-libconfig/pkg-descr b/devel/wand-libconfig/pkg-descr
new file mode 100644
index 000000000000..b34a55496197
--- /dev/null
+++ b/devel/wand-libconfig/pkg-descr
@@ -0,0 +1,3 @@
+libconfig is a simple library for dealing with parsing config files.
+
+WWW: http://research.wand.net.nz/software/libconfig.php