aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-20 03:25:19 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-20 03:25:19 +0000
commitd00138b689f5376ec4a1435833b24d64a27fd0a2 (patch)
tree0ad9bcb363f85379e969bffd6728c20ee27050ba /devel
parentfd27b6f6802e8910c9d0395b88c08577418346c2 (diff)
downloadports-d00138b689f5376ec4a1435833b24d64a27fd0a2.tar.gz
ports-d00138b689f5376ec4a1435833b24d64a27fd0a2.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/gauche-readline/Makefile14
-rw-r--r--devel/gauche-readline/pkg-plist3
2 files changed, 16 insertions, 1 deletions
diff --git a/devel/gauche-readline/Makefile b/devel/gauche-readline/Makefile
index 324fc940830a..3762c2df3063 100644
--- a/devel/gauche-readline/Makefile
+++ b/devel/gauche-readline/Makefile
@@ -7,6 +7,7 @@
PORTNAME= readline
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= devel scheme
MASTER_SITES= http://www.shiro.dreamhost.com/scheme/vault/
PKGNAMEPREFIX= gauche-
@@ -22,7 +23,18 @@ BUILD_DEPENDS= gauche-config:${PORTSDIR}/lang/gauche
GAUCHE_LIBDIR= share/gauche/site/lib
PLIST_SUB+= GAUCHE_LIBDIR=${GAUCHE_LIBDIR}
+# XXX: exists untill it will be committed to bsd.port.mk
+COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
+ 2>&1) && \
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
+ ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
+ ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
+
do-install:
- ${CP} -R ${WRKSRC}/readline* `gauche-config --sitelibdir`
+.if !exists(${PREFIX}/share/gauche/site/lib)
+ ${MKDIR} ${PREFIX}/share/gauche/site/lib
+.endif
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "readline.scm readline" \
+ ${PREFIX}/share/gauche/site/lib)
.include <bsd.port.mk>
diff --git a/devel/gauche-readline/pkg-plist b/devel/gauche-readline/pkg-plist
index a703de795e8e..2570023f68f2 100644
--- a/devel/gauche-readline/pkg-plist
+++ b/devel/gauche-readline/pkg-plist
@@ -3,3 +3,6 @@
%%GAUCHE_LIBDIR%%/readline/keymap.scm
%%GAUCHE_LIBDIR%%/readline/term-util.scm
@dirrm %%GAUCHE_LIBDIR%%/readline
+@dirrmtry %%GAUCHE_LIBDIR%%
+@dirrmtry share/gauche/site
+@dirrmtry share/gauche