aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 14:45:08 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 14:45:08 +0000
commite99ceadaf6c77b80c19e16d91306e944305b1c88 (patch)
treee8a8f4dac51e148717ae07e2de0c635ec5d58833 /devel
parent3a5afbdcc87c8da2cc12bd67ec501257e48bc034 (diff)
downloadports-e99ceadaf6c77b80c19e16d91306e944305b1c88.tar.gz
ports-e99ceadaf6c77b80c19e16d91306e944305b1c88.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/adasdl/Makefile23
-rw-r--r--devel/bugzilla/Makefile20
-rw-r--r--devel/bugzilla2/Makefile20
-rw-r--r--devel/bugzilla3/Makefile20
-rw-r--r--devel/ccdoc/Makefile2
-rw-r--r--devel/directfb/Makefile2
-rw-r--r--devel/fnorb/Makefile6
-rw-r--r--devel/glg/Makefile2
-rw-r--r--devel/gnome-vfs/Makefile2
-rw-r--r--devel/gnome-vfs1/Makefile2
-rw-r--r--devel/gnomevfs/Makefile2
-rw-r--r--devel/gnomevfs2/Makefile2
-rw-r--r--devel/invitation_to_ruby/Makefile3
-rw-r--r--devel/moonshine/Makefile2
-rw-r--r--devel/p4db/Makefile2
-rw-r--r--devel/p5-Class-Contract/Makefile2
-rw-r--r--devel/pharmacy/Makefile2
-rw-r--r--devel/py-omniorb/Makefile4
-rw-r--r--devel/qtez/Makefile2
-rw-r--r--devel/ruby-gnustep/Makefile5
-rw-r--r--devel/swig13-doc/Makefile6
-rw-r--r--devel/tcltls/Makefile2
-rw-r--r--devel/tla/Makefile3
-rw-r--r--devel/wxGlade/Makefile4
24 files changed, 76 insertions, 64 deletions
diff --git a/devel/adasdl/Makefile b/devel/adasdl/Makefile
index 58742639b4e5..78c6a7831160 100644
--- a/devel/adasdl/Makefile
+++ b/devel/adasdl/Makefile
@@ -25,10 +25,10 @@ USE_GMAKE= yes
USE_REINPLACE= yes
do-patch:
- for i in `find ${WRKSRC} -name 'Makefile'`; do \
+ for i in `${FIND} ${WRKSRC} -name 'Makefile'`; do \
${REINPLACE_CMD} -e '/gnatmake/!s/make\ /gmake\ /' $${i}; \
done
- for i in `find ${WRKSRC} -name 'make.conf_x11'`; do \
+ for i in `${FIND} ${WRKSRC} -name 'make.conf_x11'`; do \
${REINPLACE_CMD} \
-e 's,/usr/local,${LOCALBASE},g' \
-e 's,/usr/X11R6,${X11BASE},g' \
@@ -67,33 +67,40 @@ do-build:
do-install:
${MKDIR} ${PREFIX}/lib/adaSDL
for i in `cat pkg-plist|grep "lib/adaSDL/"|grep -v framebuffer|grep -v _mixer|grep -v _image|sed "s/lib\/adaSDL\///"`; do \
- find ${WRKSRC}/AdaSDL/binding -name $${i} -maxdepth 1|${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaSDL; \
+ ${FIND} ${WRKSRC}/AdaSDL/binding -name $${i} -maxdepth 1 | \
+ ${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaSDL; \
done
for i in `cat pkg-plist|grep "lib/adaSDL/"|grep framebuffer|sed "s/lib\/adaSDL\///"`; do \
- find ${WRKSRC}/AdaSDL_framebuff -name $${i} -maxdepth 1|${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaSDL; \
+ ${FIND} ${WRKSRC}/AdaSDL_framebuff -name $${i} -maxdepth 1 | \
+ ${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaSDL; \
done
${MKDIR} ${PREFIX}/share/adaSDL
${MKDIR} ${PREFIX}/share/adaSDL/examples
for i in `cat pkg-plist|grep "share/adaSDL/examples"|grep -v dirrm|sed "s/share\/adaSDL\/examples\///"`; do \
- find ${WRKSRC}/AdaSDL_framebuff/sdltests -name $${i} -maxdepth 1|${INSTALL_DATA} `grep ""` ${PREFIX}/share/adaSDL/examples; \
+ ${FIND} ${WRKSRC}/AdaSDL_framebuff/sdltests -name $${i} \
+ -maxdepth 1 | ${INSTALL_DATA} \
+ `grep ""` ${PREFIX}/share/adaSDL/examples; \
done
.if !defined(WITHOUT_SDL_IMAGE)
for i in `cat pkg-plist|grep "lib/adaSDL/"|grep _image|sed "s/lib\/adaSDL\///"`; do \
- find ${WRKSRC}/AdaSDL_image -name $${i} -maxdepth 1|${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaSDL; \
+ ${FIND} ${WRKSRC}/AdaSDL_image -name $${i} -maxdepth 1 | \
+ ${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaSDL; \
done
.endif
.if !defined(WITHOUT_SDL_MIXER)
for i in `cat pkg-plist|grep "lib/adaSDL/"|grep _mixer|sed "s/lib\/adaSDL\///"`; do \
- find ${WRKSRC}/AdaSDL_mixer -name $${i} -maxdepth 1|${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaSDL; \
+ ${FIND} ${WRKSRC}/AdaSDL_mixer -name $${i} -maxdepth 1 | \
+ ${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaSDL; \
done
.endif
.if !defined(WITHOUT_OPENGL)
${MKDIR} ${PREFIX}/lib/adaGL
for i in `cat pkg-plist|grep "/adaGL/"|sed "s/lib\/adaGL\///"`; do \
- find ${WRKSRC}/AdaGL/GL -name $${i} -maxdepth 1|${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaGL; \
+ ${FIND} ${WRKSRC}/AdaGL/GL -name $${i} -maxdepth 1 | \
+ ${INSTALL_DATA} `grep ""` ${PREFIX}/lib/adaGL; \
done
.endif
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index 8733d2f2543b..66b92c25b7f7 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -75,11 +75,11 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @find -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
- @find -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
- @find ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
- @find ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
- @find ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
+ @${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
+ @${FIND} -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
+ @${FIND} ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
.for i in ${BONSAIPERLWC}
@${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
${WRKSRC}/$i
@@ -88,16 +88,16 @@ post-patch:
@${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
${WRKSRC}/$i
.endfor
- @find ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
pre-install:
- @find ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
- @find ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
- @find ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
+ @${FIND} ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
do-install:
${MKDIR} ${PREFIX}/${BUGZILLADIR}
- find ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
+ ${FIND} ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
${INSTALL_SCRIPT} {} ${PREFIX}/${BUGZILLADIR} \;
${TAR} -C ${WRKSRC} -cf - template css | ${TAR} --unlink -C ${PREFIX}/${BUGZILLADIR} -xf -
.if !defined(NOPORTDOCS)
diff --git a/devel/bugzilla2/Makefile b/devel/bugzilla2/Makefile
index 8733d2f2543b..66b92c25b7f7 100644
--- a/devel/bugzilla2/Makefile
+++ b/devel/bugzilla2/Makefile
@@ -75,11 +75,11 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @find -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
- @find -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
- @find ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
- @find ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
- @find ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
+ @${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
+ @${FIND} -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
+ @${FIND} ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
.for i in ${BONSAIPERLWC}
@${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
${WRKSRC}/$i
@@ -88,16 +88,16 @@ post-patch:
@${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
${WRKSRC}/$i
.endfor
- @find ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
pre-install:
- @find ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
- @find ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
- @find ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
+ @${FIND} ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
do-install:
${MKDIR} ${PREFIX}/${BUGZILLADIR}
- find ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
+ ${FIND} ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
${INSTALL_SCRIPT} {} ${PREFIX}/${BUGZILLADIR} \;
${TAR} -C ${WRKSRC} -cf - template css | ${TAR} --unlink -C ${PREFIX}/${BUGZILLADIR} -xf -
.if !defined(NOPORTDOCS)
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index 8733d2f2543b..66b92c25b7f7 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -75,11 +75,11 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @find -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
- @find -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
- @find ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
- @find ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
- @find ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
+ @${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
+ @${FIND} -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
+ @${FIND} ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
.for i in ${BONSAIPERLWC}
@${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
${WRKSRC}/$i
@@ -88,16 +88,16 @@ post-patch:
@${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
${WRKSRC}/$i
.endfor
- @find ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
pre-install:
- @find ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
- @find ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
- @find ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
+ @${FIND} ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
do-install:
${MKDIR} ${PREFIX}/${BUGZILLADIR}
- find ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
+ ${FIND} ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
${INSTALL_SCRIPT} {} ${PREFIX}/${BUGZILLADIR} \;
${TAR} -C ${WRKSRC} -cf - template css | ${TAR} --unlink -C ${PREFIX}/${BUGZILLADIR} -xf -
.if !defined(NOPORTDOCS)
diff --git a/devel/ccdoc/Makefile b/devel/ccdoc/Makefile
index 7451d26d54e6..13dab00b0386 100644
--- a/devel/ccdoc/Makefile
+++ b/devel/ccdoc/Makefile
@@ -24,7 +24,7 @@ DOCDIR=${PREFIX}/share/doc/ccdoc
pre-patch:
@${ECHO} "Stripping ^M from all the files..."
- @find ${WRKSRC} -type f | xargs perl -pi -e 's/\r//'
+ @${FIND} ${WRKSRC} -type f | ${XARGS} perl -pi -e 's/\r//'
do-build:
(cd ${WRKSRC}/ccdoc_dev/libjdl/src; ${PERL} mk.pl opt)
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index 7cf1a29138bf..daa77eb4fe46 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -48,7 +48,7 @@ MAN1= directfb-csource.1 dfbg.1
MAN5= directfbrc.5
post-patch:
- @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
.include <bsd.port.mk>
diff --git a/devel/fnorb/Makefile b/devel/fnorb/Makefile
index ce1809299b6c..413217f88014 100644
--- a/devel/fnorb/Makefile
+++ b/devel/fnorb/Makefile
@@ -45,7 +45,7 @@ post-build:
post-install:
@ ${MKDIR} ${FNORB_DIR}/script
- @ cd ${WRKSRC} && find *.py *.pyc *.pyo compiler cos orb parser \
+ @ cd ${WRKSRC} && ${FIND} *.py *.pyc *.pyo compiler cos orb parser \
script/*.py script/*.pyc script/*.pyo \! -name \*.orig \
| ${CPIO} ${BINOWN}:${BINGRP} ${FNORB_DIR}
@ ${MKDIR} ${PREFIX}/bin
@@ -56,10 +56,10 @@ post-install:
${PREFIX}/etc/fnorb.cfg.sample
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${EXAMPLESDIR}
- @ cd ${WRKSRC}/examples && find * \
+ @ cd ${WRKSRC}/examples && ${FIND} * \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
@ ${MKDIR} ${DOCSDIR}
- @ cd ${WRKSRC}/doc && find . \
+ @ cd ${WRKSRC}/doc && ${FIND} . \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
@ ${CHMOD} -R u-x ${DOCSDIR} && ${CHMOD} -R u+X ${DOCSDIR}
.for file in ANNOUNCE CHANGES README LICENSE.HTML
diff --git a/devel/glg/Makefile b/devel/glg/Makefile
index fd22caf48685..47847f8e8ff0 100644
--- a/devel/glg/Makefile
+++ b/devel/glg/Makefile
@@ -28,7 +28,7 @@ USE_GNOME+= gnomelibs
.endif
pre-build:
- find ${WRKSRC} -name Makefile | xargs ${PERL} \
+ ${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${PERL} \
-pi -e "s@gtk-config@${GTK_CONFIG}@g"
.include <bsd.port.post.mk>
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 194622e7791e..b7decdbd1fab 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -48,7 +48,7 @@ LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
.endif
post-patch:
- @${FIND} ${WRKSRC} -name "*info.in" | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name "*info.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|\@datadir\@/gnome|\@datadir\@|g'
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/Makefile.in \
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index 58740eda5c16..12fe85e366e9 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -34,7 +34,7 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
post-patch:
- @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name 'xml-i18n-*' | ${XARGS} ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|g'
@${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/libcharset/Makefile.in
diff --git a/devel/gnomevfs/Makefile b/devel/gnomevfs/Makefile
index 58740eda5c16..12fe85e366e9 100644
--- a/devel/gnomevfs/Makefile
+++ b/devel/gnomevfs/Makefile
@@ -34,7 +34,7 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
post-patch:
- @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name 'xml-i18n-*' | ${XARGS} ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|g'
@${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/libcharset/Makefile.in
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index 194622e7791e..b7decdbd1fab 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -48,7 +48,7 @@ LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
.endif
post-patch:
- @${FIND} ${WRKSRC} -name "*info.in" | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name "*info.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|\@datadir\@/gnome|\@datadir\@|g'
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/Makefile.in \
diff --git a/devel/invitation_to_ruby/Makefile b/devel/invitation_to_ruby/Makefile
index 964b35601db8..2554ab2bea54 100644
--- a/devel/invitation_to_ruby/Makefile
+++ b/devel/invitation_to_ruby/Makefile
@@ -47,7 +47,8 @@ pre-install:
do-install:
${RM} -fr ${DOCSDIR}
${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}; find . | ${CPIO} -pdmv -R ${DOCOWN}:${DOCGRP} ${DOCSDIR}
+ cd ${WRKSRC}; ${FIND} . \
+ | ${CPIO} -pdmv -R ${DOCOWN}:${DOCGRP} ${DOCSDIR}
${CHMOD} -R ugo-w,ugo+rX ${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/devel/moonshine/Makefile b/devel/moonshine/Makefile
index 3af8fa7d7045..b13ff7e925c7 100644
--- a/devel/moonshine/Makefile
+++ b/devel/moonshine/Makefile
@@ -32,7 +32,7 @@ CFLAGS+= -O0
.endif
pre-configure:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\$$\{prefix\}/moonshine|\$$\{prefix\}/share/moonshine| ; \
s|\@INSTBIN\@|${PREFIX}/bin| ; s|moc -o|\$$\(MOC\) -o|'
@${PERL} -pi -e 's|/usr/share/moonshine|${PREFIX}/share/moonshine|' \
diff --git a/devel/p4db/Makefile b/devel/p4db/Makefile
index 9c30adc4d215..17a5bd2311c7 100644
--- a/devel/p4db/Makefile
+++ b/devel/p4db/Makefile
@@ -49,7 +49,7 @@ post-patch:
-e 's,!!PERFORCE_PORT!!,${PERFORCE_PORT},g;' \
-e 's,!!FQDN!!,${FQDN},g;' \
${WRKSRC}/${PORTNAME}/P4DB.conf.sample
- find ${WRKSRC}/${PORTNAME} -name '*.orig' -delete
+ ${FIND} ${WRKSRC}/${PORTNAME} -name '*.orig' -delete
do-install:
${MKDIR} ${P4DB_HOME}/www
diff --git a/devel/p5-Class-Contract/Makefile b/devel/p5-Class-Contract/Makefile
index 5580bd70f6d8..d0e0544a7a36 100644
--- a/devel/p5-Class-Contract/Makefile
+++ b/devel/p5-Class-Contract/Makefile
@@ -22,7 +22,7 @@ MAN3= Class::Contract.3 Class::Contract::Production.3
post-patch:
@${FIND} ${WRKSRC} -type f -name "*.p[lm]" | \
- xargs ${PERL} -pi -e 's/\x0d//g;'
+ ${XARGS} ${PERL} -pi -e 's/\x0d//g;'
pre-configure:
${MKDIR} ${WRKSRC}/examples
diff --git a/devel/pharmacy/Makefile b/devel/pharmacy/Makefile
index a801c7c63a3b..3878e2bf645a 100644
--- a/devel/pharmacy/Makefile
+++ b/devel/pharmacy/Makefile
@@ -26,7 +26,7 @@ pre-patch:
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/devel/py-omniorb/Makefile b/devel/py-omniorb/Makefile
index 22f805bd92d9..2ca080e81f82 100644
--- a/devel/py-omniorb/Makefile
+++ b/devel/py-omniorb/Makefile
@@ -47,7 +47,7 @@ EXAMPLESDIR= ${PREFIX}/share/examples/omniORBpy
pre-configure:
@ ${MKDIR} ${CONFIGURE_WRKSRC}
- @ cd ${OMNIORB_WRKSRC} && find idl | ${CPIO} ${WRKSRC}
+ @ cd ${OMNIORB_WRKSRC} && ${FIND} idl | ${CPIO} ${WRKSRC}
post-patch:
@${REINPLACE_CMD} -Ee 's#-pthread|-lc_r#${PTHREAD_LIBS}#' \
@@ -61,7 +61,7 @@ pre-install:
@ ${INSTALL_DATA} ${WRKSRC}/doc/omniORBpy/* ${DOCSDIR}/html
@ ${INSTALL_DATA} ${WRKSRC}/doc/tex/* ${DOCSDIR}/tex
@ ${MKDIR} ${EXAMPLESDIR}
- @ cd ${WRKSRC}/examples && find . \
+ @ cd ${WRKSRC}/examples && ${FIND} . \
| ${CPIO} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
diff --git a/devel/qtez/Makefile b/devel/qtez/Makefile
index 297e811a5b7c..c5354cc12f64 100644
--- a/devel/qtez/Makefile
+++ b/devel/qtez/Makefile
@@ -39,7 +39,7 @@ post-patch:
s|include/qaction.h|include/${QTNAME}/qaction.h|g ; \
s|qtdir/include$$|qtdir/include/${QTNAME}|g ; \
s|-lqt|-l${QTNAME}|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|doc po images|doc images|g ; \
s|prefix\)/qtez/plugins|prefix\)/lib/qtez/plugins|g ; \
s|prefix\)/qtez/img|QTEZ\)/img|g'
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index 4f625d900e5a..0f2a6c63dc22 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -71,14 +71,15 @@ PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
NO_FILTER_SHLIBS= yes
post-extract:
- find ${WRKSRC}/ -type f -name '.cvsignore' -delete
+ ${FIND} ${WRKSRC}/ -type f -name '.cvsignore' -delete
post-patch:
${RUBY} -i~ -p \
-e 'gsub(/-lpthread/, "-pthread");' \
-e 'gsub(/-lgmodel/, "");' \
${WRKSRC}/Source/${MAKEFILE}
- find ${WRKSRC}/ -type f | xargs ${RUBY} -i -pe 'gsub(/ ruby -/, " ${RUBY} -")'
+ ${FIND} ${WRKSRC}/ -type f | \
+ ${XARGS} ${RUBY} -i -pe 'gsub(/ ruby -/, " ${RUBY} -")'
post-install:
.if !defined(NOPORTDOCS)
diff --git a/devel/swig13-doc/Makefile b/devel/swig13-doc/Makefile
index 2dddd4fe75f7..c934b7fce878 100644
--- a/devel/swig13-doc/Makefile
+++ b/devel/swig13-doc/Makefile
@@ -25,7 +25,9 @@ do-build:
do-install:
${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && find Examples Doc -type d -exec ${INSTALL} -d ${DOCSDIR}/{} \;
- cd ${WRKSRC} && find Examples Doc -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ cd ${WRKSRC} && ${FIND} Examples Doc -type d \
+ -exec ${INSTALL} -d ${DOCSDIR}/{} \;
+ cd ${WRKSRC} && ${FIND} Examples Doc -type f \
+ -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
.include <bsd.port.mk>
diff --git a/devel/tcltls/Makefile b/devel/tcltls/Makefile
index a709b231e298..9a6aa9ebea8c 100644
--- a/devel/tcltls/Makefile
+++ b/devel/tcltls/Makefile
@@ -23,7 +23,7 @@ WRKSRC= ${WRKDIR}/tls1.4
pre-patch:
# Fixing the end-of-lines:
- for f in `find ${WRKSRC}/.. -type f` ; do \
+ for f in `${FIND} ${WRKSRC}/.. -type f` ; do \
${TR} -d '\015' < $$f > $$f.noms && \
${CAT} $$f.noms > $$f && ${RM} $$f.noms; done
diff --git a/devel/tla/Makefile b/devel/tla/Makefile
index e9323a36005a..6f2227de54a9 100644
--- a/devel/tla/Makefile
+++ b/devel/tla/Makefile
@@ -35,7 +35,8 @@ test:
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}; \
- for f in `find ${ORIGWRKSRC}/docs-tla/html -type f -name '*.html' -exec ${BASENAME} {} \;`; do \
+ for f in `${FIND} ${ORIGWRKSRC}/docs-tla/html -type f -name '*.html' \
+ -exec ${BASENAME} {} \;`; do \
${INSTALL_DATA} ${ORIGWRKSRC}/docs-tla/html/$$f ${DOCSDIR}/; \
printf "share/doc/${PORTNAME}/%s\n" $$f >> ${TMPPLIST}; \
done; \
diff --git a/devel/wxGlade/Makefile b/devel/wxGlade/Makefile
index c957b51612e6..7c4e83d90a49 100644
--- a/devel/wxGlade/Makefile
+++ b/devel/wxGlade/Makefile
@@ -23,14 +23,14 @@ do-install:
@${MKDIR} ${PYTHON_SITELIBDIR}/${PORTNAME}
(cd ${WRKSRC} && ${FIND} [^d]* \! -name ".cvsignore" -type f | cpio -R ${SHAREOWN}:${SHAREGRP} -pdum ${PYTHON_SITELIBDIR}/${PORTNAME})
${CHMOD} -R 644 ${PYTHON_SITELIBDIR}/${PORTNAME}
- ${FIND} ${PYTHON_SITELIBDIR}/${PORTNAME} -type d | xargs ${CHMOD} 755
+ ${FIND} ${PYTHON_SITELIBDIR}/${PORTNAME} -type d | ${XARGS} ${CHMOD} 755
${CHMOD} 755 ${PYTHON_SITELIBDIR}/${PORTNAME}/wxglade.py \
${PYTHON_SITELIBDIR}/${PORTNAME}/xrc2wxg.py
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
(cd ${WRKSRC}/docs && ${FIND} . -type f | cpio -R ${SHAREOWN}:${SHAREGRP} -pdum ${DOCSDIR})
${CHMOD} -R 644 ${DOCSDIR}
- ${FIND} ${DOCSDIR} -type d | xargs ${CHMOD} 755
+ ${FIND} ${DOCSDIR} -type d | ${XARGS} ${CHMOD} 755
.endif
.include <bsd.port.mk>