aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-01-28 08:50:53 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-01-28 08:50:53 +0000
commitfbf6b355a885ba53801b72d936461ab2f61689d9 (patch)
treef9f8fb927b9713bba3e70dfc3cc3577efd7871da /devel
parent8fdc4ba31e06ffccde135a9acb1fad76576c992a (diff)
downloadports-fbf6b355a885ba53801b72d936461ab2f61689d9.tar.gz
ports-fbf6b355a885ba53801b72d936461ab2f61689d9.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/dotconf/Makefile33
-rw-r--r--devel/dotconf/distinfo1
-rw-r--r--devel/dotconf/pkg-comment1
-rw-r--r--devel/dotconf/pkg-descr17
-rw-r--r--devel/dotconf/pkg-plist39
6 files changed, 92 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 351281b494b7..f83afaaf9cd7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -72,6 +72,7 @@
SUBDIR += dmake
SUBDIR += dmalloc
SUBDIR += doc++
+ SUBDIR += dotconf
SUBDIR += doxygen
SUBDIR += dryad
SUBDIR += elftoaout
diff --git a/devel/dotconf/Makefile b/devel/dotconf/Makefile
new file mode 100644
index 000000000000..1aec149174e3
--- /dev/null
+++ b/devel/dotconf/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# New ports collection makefile for: dotconf
+# Date created: Jan 28, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dotconf
+PORTVERSION= 1.0.0p2
+CATEGORIES= devel
+MASTER_SITES= http://www.azzit.de/dotconf/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/pre/}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}
+.for f in dotconf-api.txt dotconf-features.txt
+ @${INSTALL_DATA} ${WRKSRC}/doc/$f ${PREFIX}/share/${PORTNAME}
+.endfor
+ ${CP} -R ${WRKSRC}/examples ${PREFIX}/share/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/dotconf/distinfo b/devel/dotconf/distinfo
new file mode 100644
index 000000000000..0c22961d7fab
--- /dev/null
+++ b/devel/dotconf/distinfo
@@ -0,0 +1 @@
+MD5 (dotconf-1.0.0pre2.tar.gz) = c51c375b5a1df399d15ffda8df841a81
diff --git a/devel/dotconf/pkg-comment b/devel/dotconf/pkg-comment
new file mode 100644
index 000000000000..2908deb7be63
--- /dev/null
+++ b/devel/dotconf/pkg-comment
@@ -0,0 +1 @@
+A simple, powerful configuration-file parser
diff --git a/devel/dotconf/pkg-descr b/devel/dotconf/pkg-descr
new file mode 100644
index 000000000000..823d81e901b1
--- /dev/null
+++ b/devel/dotconf/pkg-descr
@@ -0,0 +1,17 @@
+dot.conf is a simple configuration-file parser library written in C.
+The configuration files created for dot.conf look very similar to
+those used by the Apache Webserver. Even Container-Directives known
+from httpd.conf can easily be used in the exact same manner as for
+Apache-Modules. It supports various types of arguments, dynamically
+loadable modules that create their own configuration options
+on-the-fly, a here-documents feature to pass very long ARG_STR data
+to your app, ${NAME:-default} style environment variable
+substitution for arguments, and on-the-fly inclusion of additional
+config files. Some behaviour can be toggled with flags at runtime.
+To keep dotconf from printing out warnings, you can install your
+own customized errorhandler.
+
+WWW: http://www.azzit.de/dotconf/
+
+-- Ying-Chieh Liao
+ ijliao@FreeBSD.org
diff --git a/devel/dotconf/pkg-plist b/devel/dotconf/pkg-plist
new file mode 100644
index 000000000000..504038f8c9d8
--- /dev/null
+++ b/devel/dotconf/pkg-plist
@@ -0,0 +1,39 @@
+bin/dotconf-config
+include/dotconf.h
+include/libpool.h
+lib/libpool.a
+lib/libdotconf.a
+lib/libdotconf.la
+lib/libdotconf.so
+lib/libdotconf-1.0.so
+lib/libdotconf-1.0.so.0
+share/aclocal/dotconf.m4
+%%PORTDOCS%%share/dotconf/dotconf-api.txt
+%%PORTDOCS%%share/dotconf/dotconf-features.txt
+%%PORTDOCS%%share/dotconf/examples/README
+%%PORTDOCS%%share/dotconf/examples/caseinsensitive/Makefile
+%%PORTDOCS%%share/dotconf/examples/caseinsensitive/caseinsensitive.c
+%%PORTDOCS%%share/dotconf/examples/caseinsensitive/caseinsensitive.conf
+%%PORTDOCS%%share/dotconf/examples/context/Makefile
+%%PORTDOCS%%share/dotconf/examples/context/context.c
+%%PORTDOCS%%share/dotconf/examples/context/context.conf
+%%PORTDOCS%%share/dotconf/examples/errorhandler/Makefile
+%%PORTDOCS%%share/dotconf/examples/errorhandler/errorhandler.c
+%%PORTDOCS%%share/dotconf/examples/errorhandler/errorhandler.conf
+%%PORTDOCS%%share/dotconf/examples/modules/Makefile
+%%PORTDOCS%%share/dotconf/examples/modules/include.conf
+%%PORTDOCS%%share/dotconf/examples/modules/module.c
+%%PORTDOCS%%share/dotconf/examples/modules/my_module.c
+%%PORTDOCS%%share/dotconf/examples/modules/sample.conf
+%%PORTDOCS%%share/dotconf/examples/simple/Makefile
+%%PORTDOCS%%share/dotconf/examples/simple/included.conf
+%%PORTDOCS%%share/dotconf/examples/simple/linecat.conf
+%%PORTDOCS%%share/dotconf/examples/simple/simple.c
+%%PORTDOCS%%share/dotconf/examples/simple/simple.conf
+%%PORTDOCS%%@dirrm share/dotconf/examples/caseinsensitive
+%%PORTDOCS%%@dirrm share/dotconf/examples/context
+%%PORTDOCS%%@dirrm share/dotconf/examples/errorhandler
+%%PORTDOCS%%@dirrm share/dotconf/examples/modules
+%%PORTDOCS%%@dirrm share/dotconf/examples/simple
+%%PORTDOCS%%@dirrm share/dotconf/examples
+%%PORTDOCS%%@dirrm share/dotconf