aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2014-07-14 10:33:13 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2014-07-14 10:33:13 +0000
commitffd0cbc6d0c21d8f9f283da3ccff738a9296bc57 (patch)
tree6bc278bded3833b4a96cacd6df93d62c919ce9eb /devel
parentb962a844e357d85a8a7ab85da8debd28e46f8f8a (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-termbox/Makefile25
-rw-r--r--devel/go-termbox/distinfo2
-rw-r--r--devel/go-termbox/pkg-descr12
-rw-r--r--devel/go-termbox/pkg-plist34
5 files changed, 74 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 162c7b3c1c70..978af3d5acc9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -599,6 +599,7 @@
SUBDIR += go-pretty
SUBDIR += go-runewidth
SUBDIR += go-sql-driver
+ SUBDIR += go-termbox
SUBDIR += gob2
SUBDIR += gobject-introspection
SUBDIR += goffice
diff --git a/devel/go-termbox/Makefile b/devel/go-termbox/Makefile
new file mode 100644
index 000000000000..6eff49269e93
--- /dev/null
+++ b/devel/go-termbox/Makefile
@@ -0,0 +1,25 @@
+# Created by: Akinori MUSHA aka knu <knu@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= termbox
+PORTVERSION= 0.0.0.20140625
+CATEGORIES= devel
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= go-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Pure Go termbox implementation
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= nsf
+GH_PROJECT= ${PORTNAME}-go
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 81b415f
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/go-termbox/distinfo b/devel/go-termbox/distinfo
new file mode 100644
index 000000000000..edc25added01
--- /dev/null
+++ b/devel/go-termbox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (termbox-0.0.0.20140625.tar.gz) = 5c617be6cb02f991b3a71e7ac6c5d4de50a9730a0952af6d0892fc3f02ccf8ed
+SIZE (termbox-0.0.0.20140625.tar.gz) = 23939
diff --git a/devel/go-termbox/pkg-descr b/devel/go-termbox/pkg-descr
new file mode 100644
index 000000000000..e2fdc69f4c0a
--- /dev/null
+++ b/devel/go-termbox/pkg-descr
@@ -0,0 +1,12 @@
+Termbox is a library that provides a minimalistic API which allows the
+programmer to write text-based user interfaces. The library is
+crossplatform and has both terminal-based implementations on *nix
+operating systems and a winapi console based implementation for
+windows operating systems. The basic idea is an abstraction of the
+greatest common subset of features available on all major terminals
+and other terminal-like APIs in a minimalistic fashion. Small API
+means it is easy to implement, test, maintain and learn it, that's
+what makes the termbox a distinct library in its area.
+
+Author: nsf <no.smile.face@gmail.com>
+WWW: https://code.google.com/p/termbox/
diff --git a/devel/go-termbox/pkg-plist b/devel/go-termbox/pkg-plist
new file mode 100644
index 000000000000..c4116fadad60
--- /dev/null
+++ b/devel/go-termbox/pkg-plist
@@ -0,0 +1,34 @@
+%%GO_LIBDIR%%/github.com/nsf/termbox-go.a
+@dirrmtry %%GO_LIBDIR%%/github.com/nsf
+@dirrmtry %%GO_LIBDIR%%/github.com
+@dirrmtry %%GO_LIBDIR%%
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/AUTHORS
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/_demos/editbox.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/_demos/keyboard.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/_demos/output.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/_demos/random_output.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/api.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/api_common.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/api_windows.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/collect_terminfo.py
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/syscalls.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/syscalls_darwin_386.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/syscalls_darwin_amd64.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/syscalls_freebsd.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/syscalls_linux.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/syscalls_openbsd.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/syscalls_windows.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/termbox.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/termbox_common.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/termbox_windows.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/terminfo.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/terminfo_builtin.go
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/_demos
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_SRCDIR%%/github.com/nsf
+@dirrmtry %%GO_SRCDIR%%/github.com
+@dirrmtry %%GO_SRCDIR%%
+@dirrmtry share/go/pkg
+@dirrmtry share/go