aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-08 07:03:32 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-08 07:03:32 +0000
commit12c33ab7367569f069e88dbd9217040328e92994 (patch)
tree91cc92bbe351340dd84b85f2fb40c67b3ead518f /devel
parent8d51c7ddcf80b3b60709e61c4b96b31cc650fe68 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cxxtest/Makefile9
-rw-r--r--devel/p5-Acme-Comment/Makefile9
-rw-r--r--devel/p5-Algorithm-Bucketizer/Makefile3
-rw-r--r--devel/p5-Data-MessagePack-Stream/Makefile3
-rw-r--r--devel/p5-Data-Page-NoTotalEntries/Makefile8
-rw-r--r--devel/p5-Data-Validate/Makefile9
-rw-r--r--devel/p5-DateTime-Format-XSD/Makefile9
-rw-r--r--devel/p5-Devel-Gladiator/Makefile3
-rw-r--r--devel/p5-Event-Notify/Makefile9
-rw-r--r--devel/p5-Luka/Makefile9
-rw-r--r--devel/p5-Paranoid/Makefile3
-rw-r--r--devel/p5-Pid-File-Flock/Makefile9
-rw-r--r--devel/p5-Regexp-Grammars/Makefile9
-rw-r--r--devel/p5-Stream-Buffered/Makefile3
-rw-r--r--devel/p5-TAP-Formatter-JUnit/Makefile8
-rw-r--r--devel/p5-Term-Sk/Makefile3
-rw-r--r--devel/p5-Test-Number-Delta/Makefile9
-rw-r--r--devel/p5-asa/Makefile8
-rw-r--r--devel/p5-carton/Makefile3
19 files changed, 47 insertions, 79 deletions
diff --git a/devel/cxxtest/Makefile b/devel/cxxtest/Makefile
index dbd8b83f8e24..59de089a4ff9 100644
--- a/devel/cxxtest/Makefile
+++ b/devel/cxxtest/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cxxtest
-# Date created: 14 August 2003
-# Whom: andrew morton
-#
+# Created by: andrew morton
# $FreeBSD$
-#
PORTNAME= cxxtest
PORTVERSION= 3.10.1
@@ -15,7 +11,8 @@ COMMENT= Simple and powerful JUnit/CppUnit/xUnit-like framework for C++
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GMAKE= yes
DOCS= README TODO docs/*.html docs/*.png
diff --git a/devel/p5-Acme-Comment/Makefile b/devel/p5-Acme-Comment/Makefile
index 35235ed9c48f..abd32c287ebc 100644
--- a/devel/p5-Acme-Comment/Makefile
+++ b/devel/p5-Acme-Comment/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Acme-Comment
-# Date created: 2012-07-18
-# Whom: Marcello Coutinho <marcellocoutinho@gmail.com>
-#
+# Created by: Marcello Coutinho <marcellocoutinho@gmail.com>
# $FreeBSD$
-#
PORTNAME= Acme-Comment
PORTVERSION= 1.04
@@ -17,7 +13,8 @@ COMMENT= Allow multi-line comments which are filtered out
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Acme::Comment.3
diff --git a/devel/p5-Algorithm-Bucketizer/Makefile b/devel/p5-Algorithm-Bucketizer/Makefile
index aa7469ed1f70..f78331a3fc96 100644
--- a/devel/p5-Algorithm-Bucketizer/Makefile
+++ b/devel/p5-Algorithm-Bucketizer/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Algorithm-Permute>=0:${PORTSDIR}/devel/p5-Algorithm-Permute \
p5-Sysadm-Install>=0.23:${PORTSDIR}/sysutils/p5-Sysadm-Install
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= bucketize.1
MAN3= Algorithm::Bucketizer.3
diff --git a/devel/p5-Data-MessagePack-Stream/Makefile b/devel/p5-Data-MessagePack-Stream/Makefile
index ec641069bfb1..fb484142b2b6 100644
--- a/devel/p5-Data-MessagePack-Stream/Makefile
+++ b/devel/p5-Data-MessagePack-Stream/Makefile
@@ -12,7 +12,8 @@ COMMENT= Perl extension for yet another messagepack streaming deserializer
BUILD_DEPENDS= p5-Data-MessagePack>0:${PORTSDIR}/devel/p5-Data-MessagePack
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE= yes
MAN3= Data::MessagePack::Stream.3
diff --git a/devel/p5-Data-Page-NoTotalEntries/Makefile b/devel/p5-Data-Page-NoTotalEntries/Makefile
index ca69befbaf69..d84127938967 100644
--- a/devel/p5-Data-Page-NoTotalEntries/Makefile
+++ b/devel/p5-Data-Page-NoTotalEntries/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Data::Page::NoTotalEntries
-# Date created: 26 Feb 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Data-Page-NoTotalEntries
PORTVERSION= 0.02
@@ -20,7 +15,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Page::NoTotalEntries.3 \
Data::Page::README.3
diff --git a/devel/p5-Data-Validate/Makefile b/devel/p5-Data-Validate/Makefile
index c615a5d11107..a6298983262b 100644
--- a/devel/p5-Data-Validate/Makefile
+++ b/devel/p5-Data-Validate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Data-Validate
-# Date created: 06 August 2007
-# Whom: Steven Kreuzer <skreuzer@exit2shell.com>
-#
+# Created by: Steven Kreuzer <skreuzer@exit2shell.com>
# $FreeBSD$
-#
PORTNAME= Data-Validate
PORTVERSION= 0.08
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Common data validation methods
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Validate.3
diff --git a/devel/p5-DateTime-Format-XSD/Makefile b/devel/p5-DateTime-Format-XSD/Makefile
index 7fcfe0f8755a..5dc0771ec65e 100644
--- a/devel/p5-DateTime-Format-XSD/Makefile
+++ b/devel/p5-DateTime-Format-XSD/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DateTime-Format-XSD
-# Date created: 29 oct 2009
-# Whom: Sergey V. Dyatko <Sergey.Dyatko@gmail.com>
-#
+# Created by: Sergey V. Dyatko <Sergey.Dyatko@gmail.com>
# $FreeBSD$
-#
PORTNAME= DateTime-Format-XSD
PORTVERSION= 0.2
@@ -17,7 +13,8 @@ COMMENT= Format DateTime according to xsd:dateTime
BUILD_DEPENDS= p5-DateTime-Format-ISO8601>=0:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601
RUN_DEPENDS= p5-DateTime-Format-ISO8601>=0:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DateTime::Format::XSD.3
diff --git a/devel/p5-Devel-Gladiator/Makefile b/devel/p5-Devel-Gladiator/Makefile
index 8afcf9fc8253..0cf6df3e61f2 100644
--- a/devel/p5-Devel-Gladiator/Makefile
+++ b/devel/p5-Devel-Gladiator/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= miwi@FreeBSD.org
COMMENT= Perl 5 module to walk Perls arena
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::Gladiator.3
diff --git a/devel/p5-Event-Notify/Makefile b/devel/p5-Event-Notify/Makefile
index c63e14d344e8..9440ad83a8fa 100644
--- a/devel/p5-Event-Notify/Makefile
+++ b/devel/p5-Event-Notify/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Event-Notify
-# Date created: 2008-01-03
-# Whom: Masahiro Teramoto <markun@onohara.to>
-#
+# Created by: Masahiro Teramoto <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= Event-Notify
PORTVERSION= 0.00004
@@ -18,7 +14,8 @@ COMMENT= Simple Observer/Notifier
BUILD_DEPENDS= p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject
RUN_DEPENDS= p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Event::Notify.3
diff --git a/devel/p5-Luka/Makefile b/devel/p5-Luka/Makefile
index fc6ac4ab732a..feb585f27cc4 100644
--- a/devel/p5-Luka/Makefile
+++ b/devel/p5-Luka/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Luka
-# Date created: 2006-07-15
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Luka
PORTVERSION= 1.08
@@ -26,7 +22,8 @@ RUN_DEPENDS= p5-Class-Std>=0:${PORTSDIR}/devel/p5-Class-Std \
p5-What>=0:${PORTSDIR}/net/p5-What
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Luka.3 Luka::Conf.3 Luka::Exceptions.3 Luka::Mailer.3
diff --git a/devel/p5-Paranoid/Makefile b/devel/p5-Paranoid/Makefile
index 7acc865c647b..bad5966c0166 100644
--- a/devel/p5-Paranoid/Makefile
+++ b/devel/p5-Paranoid/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Paranoid::Data.3 \
Paranoid::Log::File.3 \
diff --git a/devel/p5-Pid-File-Flock/Makefile b/devel/p5-Pid-File-Flock/Makefile
index 3d85f4ba6d7f..5710e20c6cc2 100644
--- a/devel/p5-Pid-File-Flock/Makefile
+++ b/devel/p5-Pid-File-Flock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Pid-File-Flock
-# Date created: 2010-01-13
-# Whom: Oleg Mamontov <oleg@mamontov.net>
-#
+# Created by: Oleg Mamontov <oleg@mamontov.net>
# $FreeBSD$
-#
PORTNAME= Pid-File-Flock
PORTVERSION= 0.08
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= oleg@mamontov.net
COMMENT= PID file operations
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Pid::File::Flock.3
diff --git a/devel/p5-Regexp-Grammars/Makefile b/devel/p5-Regexp-Grammars/Makefile
index 8859ac16d44f..e8f13b7814dd 100644
--- a/devel/p5-Regexp-Grammars/Makefile
+++ b/devel/p5-Regexp-Grammars/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: p5-Regexp-Grammars
-# Date created: Mon Sep 27, 2010
-# Whom: Dan Rench <citric@cubicone.tmetic.com>
-#
+# Created by: Dan Rench <citric@cubicone.tmetic.com>
# $FreeBSD$
-#
PORTNAME= Regexp-Grammars
PORTVERSION= 1.026
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= citric@cubicone.tmetic.com
COMMENT= Add grammatical parsing features to Perl 5.10 regexes
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Regexp::Grammars.3
diff --git a/devel/p5-Stream-Buffered/Makefile b/devel/p5-Stream-Buffered/Makefile
index a79c94aa74bd..8b9c7a443cdf 100644
--- a/devel/p5-Stream-Buffered/Makefile
+++ b/devel/p5-Stream-Buffered/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for temporary buffer to save bytes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Stream::Buffered.3
diff --git a/devel/p5-TAP-Formatter-JUnit/Makefile b/devel/p5-TAP-Formatter-JUnit/Makefile
index ba5afbd247e6..0b67ba316688 100644
--- a/devel/p5-TAP-Formatter-JUnit/Makefile
+++ b/devel/p5-TAP-Formatter-JUnit/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: TAP::Formatter::JUnit
-# Date created: 10 Apr 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= TAP-Formatter-JUnit
PORTVERSION= 0.09
@@ -24,7 +19,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Differences>=0.61:${PORTSDIR}/devel/p5-Test-Differences \
p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= tap2junit.1
MAN3= TAP::Formatter::JUnit.3 \
diff --git a/devel/p5-Term-Sk/Makefile b/devel/p5-Term-Sk/Makefile
index bec32847cbf6..507854bc1722 100644
--- a/devel/p5-Term-Sk/Makefile
+++ b/devel/p5-Term-Sk/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension to display a progress indicator on a terminal
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Term::Sk.3
diff --git a/devel/p5-Test-Number-Delta/Makefile b/devel/p5-Test-Number-Delta/Makefile
index 26423853d586..309538c769f9 100644
--- a/devel/p5-Test-Number-Delta/Makefile
+++ b/devel/p5-Test-Number-Delta/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-Number-Delta
-# Date created: 2006-07-22
-# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
-#
+# Created by: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
# $FreeBSD$
-#
PORTNAME= Test-Number-Delta
PORTVERSION= 1.03
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tjs@cdpa.nsysu.edu.tw
COMMENT= Compare the difference between two numbers within a specified amount
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Number::Delta.3
diff --git a/devel/p5-asa/Makefile b/devel/p5-asa/Makefile
index 8e0487598037..3e849b7fc055 100644
--- a/devel/p5-asa/Makefile
+++ b/devel/p5-asa/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: p5-asa
-# Date created: 16 Apr 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= asa
PORTVERSION= 1.03
@@ -15,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to say your class/object working like something else
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= asa.3
diff --git a/devel/p5-carton/Makefile b/devel/p5-carton/Makefile
index 61ee2e660ccf..345b40ab4876 100644
--- a/devel/p5-carton/Makefile
+++ b/devel/p5-carton/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= \
p5-local-lib>=1.008:${PORTSDIR}/devel/p5-local-lib
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Carton.3 \
Carton::Doc::Check.3 \