aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2008-07-09 07:29:25 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2008-07-09 07:29:25 +0000
commit423706cf125cdd7093a9719af05df58bdd40a139 (patch)
treeba4a1ca65b818fce63198f13870907673a9a4f98 /devel
parent2b021c3e144baa58d275737467b191b37962dd34 (diff)
downloadports-423706cf125cdd7093a9719af05df58bdd40a139.tar.gz
ports-423706cf125cdd7093a9719af05df58bdd40a139.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/protobuf/Makefile27
-rw-r--r--devel/protobuf/distinfo3
-rw-r--r--devel/protobuf/pkg-descr5
-rw-r--r--devel/protobuf/pkg-plist45
5 files changed, 81 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e7f037ba8a6e..0dc1b24d36e5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2016,6 +2016,7 @@
SUBDIR += privman
SUBDIR += projectcenter.app
SUBDIR += projectmanager
+ SUBDIR += protobuf
SUBDIR += prototype
SUBDIR += pstreams
SUBDIR += psvn
diff --git a/devel/protobuf/Makefile b/devel/protobuf/Makefile
new file mode 100644
index 000000000000..eee7e17ea75d
--- /dev/null
+++ b/devel/protobuf/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: protobuf
+# Date created: Aug 9, 2008
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= protobuf
+PORTVERSION= 2.0.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PORTNAME}-${PORTVERSION}beta
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= A data interchange format library
+
+USE_GMAKE= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GCC= 3.2+
+USE_LDCONFIG= yes
+
+tests: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
+.include <bsd.port.mk>
diff --git a/devel/protobuf/distinfo b/devel/protobuf/distinfo
new file mode 100644
index 000000000000..671597d23ac2
--- /dev/null
+++ b/devel/protobuf/distinfo
@@ -0,0 +1,3 @@
+MD5 (protobuf-2.0.0beta.tar.bz2) = 79a8072490f863139f32488c3ff84d39
+SHA256 (protobuf-2.0.0beta.tar.bz2) = b2ab129a70989894e89377e8279e8132d91037a26345ac8d498a6b25d59e81b4
+SIZE (protobuf-2.0.0beta.tar.bz2) = 704775
diff --git a/devel/protobuf/pkg-descr b/devel/protobuf/pkg-descr
new file mode 100644
index 000000000000..c9b826497682
--- /dev/null
+++ b/devel/protobuf/pkg-descr
@@ -0,0 +1,5 @@
+Protocol Buffers are a way of encoding structured data in an efficient yet
+extensible format. Google uses Protocol Buffers for almost all of its
+internal RPC protocols and file formats.
+
+WWW: http://code.google.com/p/protobuf/
diff --git a/devel/protobuf/pkg-plist b/devel/protobuf/pkg-plist
new file mode 100644
index 000000000000..8abce592bf31
--- /dev/null
+++ b/devel/protobuf/pkg-plist
@@ -0,0 +1,45 @@
+bin/protoc
+include/google/protobuf/compiler/code_generator.h
+include/google/protobuf/compiler/command_line_interface.h
+include/google/protobuf/compiler/cpp/cpp_generator.h
+include/google/protobuf/compiler/importer.h
+include/google/protobuf/compiler/java/java_generator.h
+include/google/protobuf/compiler/parser.h
+include/google/protobuf/compiler/python/python_generator.h
+include/google/protobuf/descriptor.h
+include/google/protobuf/descriptor.pb.h
+include/google/protobuf/descriptor.proto
+include/google/protobuf/descriptor_database.h
+include/google/protobuf/dynamic_message.h
+include/google/protobuf/extension_set.h
+include/google/protobuf/generated_message_reflection.h
+include/google/protobuf/io/coded_stream.h
+include/google/protobuf/io/printer.h
+include/google/protobuf/io/tokenizer.h
+include/google/protobuf/io/zero_copy_stream.h
+include/google/protobuf/io/zero_copy_stream_impl.h
+include/google/protobuf/message.h
+include/google/protobuf/reflection_ops.h
+include/google/protobuf/repeated_field.h
+include/google/protobuf/service.h
+include/google/protobuf/stubs/common.h
+include/google/protobuf/text_format.h
+include/google/protobuf/unknown_field_set.h
+include/google/protobuf/wire_format.h
+include/google/protobuf/wire_format_inl.h
+lib/libprotobuf.a
+lib/libprotobuf.la
+lib/libprotobuf.so
+lib/libprotobuf.so.0
+lib/libprotoc.a
+lib/libprotoc.la
+lib/libprotoc.so
+lib/libprotoc.so.0
+@dirrm include/google/protobuf/stubs
+@dirrm include/google/protobuf/io
+@dirrm include/google/protobuf/compiler/python
+@dirrm include/google/protobuf/compiler/java
+@dirrm include/google/protobuf/compiler/cpp
+@dirrm include/google/protobuf/compiler
+@dirrm include/google/protobuf
+@dirrmtry include/google