aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2009-01-30 23:23:18 +0000
committerAlex Dupre <ale@FreeBSD.org>2009-01-30 23:23:18 +0000
commit4926cbc0b9a6b87582ebb2827118e7ff35d85b7f (patch)
tree3ac4f483a2b4f87cadee7566fdd9a17df03b8c09 /devel
parentb90483fe596f1758a357fe10278ef01effa18adb (diff)
downloadports-4926cbc0b9a6b87582ebb2827118e7ff35d85b7f.tar.gz
ports-4926cbc0b9a6b87582ebb2827118e7ff35d85b7f.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/avr-gcc-devel/Makefile3
-rw-r--r--devel/cross-gcc/Makefile2
-rw-r--r--devel/djgpp-gcc/Makefile2
-rw-r--r--devel/mingw32-gcc/Makefile2
4 files changed, 5 insertions, 4 deletions
diff --git a/devel/avr-gcc-devel/Makefile b/devel/avr-gcc-devel/Makefile
index fe61aedc5b1f..0c4f009430ba 100644
--- a/devel/avr-gcc-devel/Makefile
+++ b/devel/avr-gcc-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcc-devel
PORTVERSION= 4.3.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
@@ -22,7 +23,7 @@ COMMENT= FSF GCC 4.3.x for Atmel AVR 8-bit RISC cross-development
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
-LIB_DEPENDS= mpfr.2:${PORTSDIR}/math/mpfr \
+LIB_DEPENDS= mpfr.3:${PORTSDIR}/math/mpfr \
gmp.7:${PORTSDIR}/math/libgmp4
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index cd527e430675..a33aebe355b3 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -158,7 +158,7 @@ TGTLANGS:= "${TGTLANGS},objc"
.if defined(WITH_FORTRAN)
TGTLANGS:= "${TGTLANGS},fortran"
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
PLIST_FILES+= bin/${OURTARGET}-gfortran \
${OURTARGET}/bin/gfortran
diff --git a/devel/djgpp-gcc/Makefile b/devel/djgpp-gcc/Makefile
index 1ca74f3bfa09..5d26bc285f90 100644
--- a/devel/djgpp-gcc/Makefile
+++ b/devel/djgpp-gcc/Makefile
@@ -33,7 +33,7 @@ BUILD_DEPENDS= ${TARGET}-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
aclocal-1.9:${PORTSDIR}/devel/automake19
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
.endif
RUN_DEPENDS= ${TARGET}-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
${LOCALBASE}/${TARGET}/bin/stubify:${PORTSDIR}/devel/${PKGNAMEPREFIX}crx
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index 31f1d4eae658..06a116abe894 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -115,7 +115,7 @@ PLIST_SUB+= OBJCXX="@comment "
.if defined(WITH_LANG_FORTRAN)
DISTFILES+= gcc-fortran-${GCCVERSION}${EXTRACT_SUFX}
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE} \
--with-mpfr=${LOCALBASE}
MAN1+= ${PKGNAMEPREFIX}gfortran.1