aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-05-08 03:59:38 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-05-08 03:59:38 +0000
commit63991c69ed4473912dcde4a66e4f7858ffb42f7e (patch)
tree8aeee71243e0b492203ec20d58c2af882253d3ea /devel
parent5f98b25a62cd17654e3e273b0d1eefdea658bfc9 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/rudiments/Makefile13
-rw-r--r--devel/rudiments/distinfo4
-rw-r--r--devel/rudiments/files/patch-Makefile24
-rw-r--r--devel/rudiments/files/patch-bin_Makefile16
-rw-r--r--devel/rudiments/files/patch-configure42
-rw-r--r--devel/rudiments/files/patch-doc_Makefile90
-rw-r--r--devel/rudiments/files/patch-include_Makefile.in39
-rw-r--r--devel/rudiments/files/patch-man_Makefile18
-rw-r--r--devel/rudiments/files/patch-src_Makefile.in49
-rw-r--r--devel/rudiments/pkg-plist9
10 files changed, 287 insertions, 17 deletions
diff --git a/devel/rudiments/Makefile b/devel/rudiments/Makefile
index 23c5a74f8df4..f88524d88d5f 100644
--- a/devel/rudiments/Makefile
+++ b/devel/rudiments/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rudiments
-PORTVERSION= 0.49
-PORTREVISION= 1
+PORTVERSION= 0.50
CATEGORIES= devel
MASTER_SITES= SF
@@ -30,16 +29,6 @@ SSL_CONFIGURE_ENABLE= ssl
SSL_CONFIGURE_ON= --with-ssl-includes=-I${OPENSSLINC} \
--with-ssl-libs=-L${OPENSSLLIB}
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
- '/pkgconfig/s| $$(libdir)/| $${DESTDIR}$$(prefix)/libdata/| ; \
- /INSTALL/s| $$(bindir)| $${DESTDIR}$$(bindir)| ; \
- /INSTALL/s| $$(docdir)| $${DESTDIR}$$(docdir)| ; \
- /INSTALL/s| $$(includedir)| $${DESTDIR}$$(includedir)| ; \
- /INSTALL/s| $$(mandir)| $${DESTDIR}$$(mandir)| ; \
- /INSTALL/s| $$(libdir)| $${DESTDIR}$$(libdir)| ; \
- /finish/s| $$(libdir)| $${DESTDIR}$$(libdir)|'
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librudiments-${PORTVERSION}.so.1
diff --git a/devel/rudiments/distinfo b/devel/rudiments/distinfo
index 9838ccde52b3..fff26e118878 100644
--- a/devel/rudiments/distinfo
+++ b/devel/rudiments/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rudiments-0.49.tar.gz) = 4e9391f48d611b437f229845120669ca0def44502af0a284782a390d896ee00d
-SIZE (rudiments-0.49.tar.gz) = 1773815
+SHA256 (rudiments-0.50.tar.gz) = d5a93261bc14f1224504a71a76685ec5822a4314e4a0b1e4d812ebf7fcb71e78
+SIZE (rudiments-0.50.tar.gz) = 1749741
diff --git a/devel/rudiments/files/patch-Makefile b/devel/rudiments/files/patch-Makefile
new file mode 100644
index 000000000000..f3461e098d9f
--- /dev/null
+++ b/devel/rudiments/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig 2015-02-04 18:02:12 UTC
++++ Makefile
+@@ -16,9 +16,9 @@ install:
+ cd bin $(AND) $(MAKE) install
+ cd doc $(AND) $(MAKE) install
+ cd man $(AND) $(MAKE) install
+- $(MKINSTALLDIRS) $(libdir)/pkgconfig
+- $(CP) rudiments.pc $(libdir)/pkgconfig/rudiments.pc
+- $(CHMOD) 644 $(libdir)/pkgconfig/rudiments.pc
++ $(MKINSTALLDIRS) $(DESTDIR)$(prefix)/libdata/pkgconfig
++ $(CP) rudiments.pc $(DESTDIR)$(prefix)/libdata/pkgconfig/rudiments.pc
++ $(CHMOD) 644 $(DESTDIR)$(prefix)/libdata/pkgconfig/rudiments.pc
+
+ uninstall:
+ cd src $(AND) $(MAKE) uninstall
+@@ -26,7 +26,7 @@ uninstall:
+ cd bin $(AND) $(MAKE) uninstall
+ cd doc $(AND) $(MAKE) uninstall
+ cd man $(AND) $(MAKE) uninstall
+- $(RM) $(libdir)/pkgconfig/rudiments.pc
++ $(RM) $(DESTDIR)$(libdir)/pkgconfig/rudiments.pc
+
+ distclean: clean
+ $(RM) config.mk config.cache config.h config.log config.status features.mk libtool rudiments.pc include/Makefile include/rudiments/private/config.h include/rudiments/private/config.h.in~ bin/rudiments-config src/Makefile msvc/rudiments.opensdf msvc/rudiments.sdf msvc/rudiments.suo
diff --git a/devel/rudiments/files/patch-bin_Makefile b/devel/rudiments/files/patch-bin_Makefile
new file mode 100644
index 000000000000..dff40e40467f
--- /dev/null
+++ b/devel/rudiments/files/patch-bin_Makefile
@@ -0,0 +1,16 @@
+--- bin/Makefile.orig 2015-01-13 22:38:32 UTC
++++ bin/Makefile
+@@ -3,9 +3,9 @@ top_builddir = ..
+ include ../config.mk
+
+ install:
+- $(MKINSTALLDIRS) $(bindir)
+- $(CP) rudiments-config $(bindir)
+- $(CHMOD) 755 $(bindir)/rudiments-config
++ $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
++ $(CP) rudiments-config $(DESTDIR)$(bindir)
++ $(CHMOD) 755 $(DESTDIR)$(bindir)/rudiments-config
+
+ uninstall:
+- $(RM) $(bindir)/rudiments-config
++ $(RM) $(DESTDIR)$(bindir)/rudiments-config
diff --git a/devel/rudiments/files/patch-configure b/devel/rudiments/files/patch-configure
index 445451468aaf..30574c0122db 100644
--- a/devel/rudiments/files/patch-configure
+++ b/devel/rudiments/files/patch-configure
@@ -1,6 +1,42 @@
---- configure.orig 2014-06-21 04:23:02 UTC
+--- configure.orig 2015-04-11 01:05:36 UTC
+++ configure
-@@ -15765,6 +15765,9 @@
+@@ -9216,7 +9216,7 @@ $as_echo_n "checking whether the $compil
+ hardcode_minus_L=no
+ hardcode_shlibpath_var=unsupported
+ inherit_rpath=no
+- link_all_deplibs=unknown
++ link_all_deplibs=no
+ module_cmds=
+ module_expsym_cmds=
+ old_archive_from_new_cmds=
+@@ -10913,7 +10913,7 @@ freebsd* | dragonfly*)
+ version_type=freebsd-$objformat
+ case $version_type in
+ freebsd-elf*)
+- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
++ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext' soname_spec='$libname$release$shared_ext$major'
+ need_version=no
+ need_lib_prefix=no
+ ;;
+@@ -12248,7 +12248,7 @@ hardcode_automatic_CXX=no
+ inherit_rpath_CXX=no
+ module_cmds_CXX=
+ module_expsym_cmds_CXX=
+-link_all_deplibs_CXX=unknown
++link_all_deplibs_CXX=no
+ old_archive_cmds_CXX=$old_archive_cmds
+ reload_flag_CXX=$reload_flag
+ reload_cmds_CXX=$reload_cmds
+@@ -14748,7 +14748,7 @@ freebsd* | dragonfly*)
+ version_type=freebsd-$objformat
+ case $version_type in
+ freebsd-elf*)
+- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
++ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext' soname_spec='$libname$release$shared_ext$major'
+ need_version=no
+ need_lib_prefix=no
+ ;;
+@@ -15767,6 +15767,9 @@ case $host_os in
*mingw32* )
WERROR=""
;;
@@ -10,7 +46,7 @@
*)
;;
esac
-@@ -30750,47 +30747,47 @@
+@@ -31537,47 +31540,47 @@ fi
# prepend DESTDIR where appropriate
if ( test "`echo $ac_default_prefix | cut -c1`" = "/" )
then
diff --git a/devel/rudiments/files/patch-doc_Makefile b/devel/rudiments/files/patch-doc_Makefile
new file mode 100644
index 000000000000..68d527c5bbd9
--- /dev/null
+++ b/devel/rudiments/files/patch-doc_Makefile
@@ -0,0 +1,90 @@
+--- doc/Makefile.orig 2015-05-07 19:18:13 UTC
++++ doc/Makefile
+@@ -3,46 +3,46 @@ top_builddir = ..
+ include ../config.mk
+
+ install:
+- $(MKINSTALLDIRS) $(docdir)
+- $(MKINSTALLDIRS) $(docdir)/css
+- $(MKINSTALLDIRS) $(docdir)/classes/html
+- $(MKINSTALLDIRS) $(docdir)/programming
+- $(CP) installing.html $(docdir)
+- $(CP) index.html $(docdir)
+- $(CP) introduction.html $(docdir)
+- $(CP) invisible.gif $(docdir)
+- $(CP) css/styles.css $(docdir)/css
+- $(CP) classes/html/*.html $(docdir)/classes/html
+- $(CP) classes/html/*.png $(docdir)/classes/html
+- $(CP) classes/html/*.css $(docdir)/classes/html
+- $(CP) classes/html/*.js $(docdir)/classes/html
+- $(CP) programming/guide.html $(docdir)/programming
+- $(CHMOD) 644 $(docdir)/*.html
+- $(CHMOD) 644 $(docdir)/*.gif
+- $(CHMOD) 644 $(docdir)/css/*
+- $(CHMOD) 644 $(docdir)/classes/html/a*.html
+- $(CHMOD) 644 $(docdir)/classes/html/b*.html
+- $(CHMOD) 644 $(docdir)/classes/html/c*.html
+- $(CHMOD) 644 $(docdir)/classes/html/d*.html
+- $(CHMOD) 644 $(docdir)/classes/html/e*.html
+- $(CHMOD) 644 $(docdir)/classes/html/f*.html
+- $(CHMOD) 644 $(docdir)/classes/html/g*.html
+- $(CHMOD) 644 $(docdir)/classes/html/h*.html
+- $(CHMOD) 644 $(docdir)/classes/html/i*.html
+- $(CHMOD) 644 $(docdir)/classes/html/l*.html
+- $(CHMOD) 644 $(docdir)/classes/html/m*.html
+- $(CHMOD) 644 $(docdir)/classes/html/n*.html
+- $(CHMOD) 644 $(docdir)/classes/html/p*.html
+- $(CHMOD) 644 $(docdir)/classes/html/r*.html
+- $(CHMOD) 644 $(docdir)/classes/html/s*.html
+- $(CHMOD) 644 $(docdir)/classes/html/t*.html
+- $(CHMOD) 644 $(docdir)/classes/html/u*.html
+- $(CHMOD) 644 $(docdir)/classes/html/w*.html
+- $(CHMOD) 644 $(docdir)/classes/html/x*.html
+- $(CHMOD) 644 $(docdir)/classes/html/*.png
+- $(CHMOD) 644 $(docdir)/classes/html/*.css
+- $(CHMOD) 644 $(docdir)/classes/html/*.js
+- $(CHMOD) 644 $(docdir)/programming/*.html
++ $(MKINSTALLDIRS) $(DESTDIR)$(docdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(docdir)/css
++ $(MKINSTALLDIRS) $(DESTDIR)$(docdir)/classes/html
++ $(MKINSTALLDIRS) $(DESTDIR)$(docdir)/programming
++ $(CP) installing.html $(DESTDIR)$(docdir)
++ $(CP) index.html $(DESTDIR)$(docdir)
++ $(CP) introduction.html $(DESTDIR)$(docdir)
++ $(CP) invisible.gif $(DESTDIR)$(docdir)
++ $(CP) css/styles.css $(DESTDIR)$(docdir)/css
++ $(CP) classes/html/*.html $(DESTDIR)$(docdir)/classes/html
++ $(CP) classes/html/*.png $(DESTDIR)$(docdir)/classes/html
++ $(CP) classes/html/*.css $(DESTDIR)$(docdir)/classes/html
++ $(CP) classes/html/*.js $(DESTDIR)$(docdir)/classes/html
++ $(CP) programming/guide.html $(DESTDIR)$(docdir)/programming
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/*.gif
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/css/*
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/a*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/b*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/c*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/d*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/e*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/f*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/g*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/h*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/i*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/l*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/m*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/n*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/p*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/r*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/s*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/t*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/u*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/w*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/x*.html
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/*.png
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/*.css
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/classes/html/*.js
++ $(CHMOD) 644 $(DESTDIR)$(docdir)/programming/*.html
+
+ uninstall:
+- $(RMTREE) $(docdir)
++ $(RMTREE) $(DESTDIR)$(docdir)
diff --git a/devel/rudiments/files/patch-include_Makefile.in b/devel/rudiments/files/patch-include_Makefile.in
new file mode 100644
index 000000000000..267f6159ba6f
--- /dev/null
+++ b/devel/rudiments/files/patch-include_Makefile.in
@@ -0,0 +1,39 @@
+--- include/Makefile.in.orig 2015-02-08 07:07:44 UTC
++++ include/Makefile.in
+@@ -18,21 +18,21 @@ PRIVATEHEADERS7 = @PRIVATEHEADERS7@
+ all:
+
+ install:
+- $(MKINSTALLDIRS) $(includedir)/rudiments
+- $(MKINSTALLDIRS) $(includedir)/rudiments/private
+- cd rudiments $(AND) $(CP) $(HEADERS0) $(includedir)/rudiments
+- cd rudiments $(AND) $(CP) $(HEADERS1) $(includedir)/rudiments
+- cd rudiments $(AND) $(CP) $(HEADERS2) $(includedir)/rudiments
+- cd rudiments $(AND) $(CP) $(HEADERS3) $(includedir)/rudiments
+- cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS0) $(includedir)/rudiments/private
+- cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS1) $(includedir)/rudiments/private
+- cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS2) $(includedir)/rudiments/private
+- cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS3) $(includedir)/rudiments/private
+- cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS4) $(includedir)/rudiments/private
+- cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS5) $(includedir)/rudiments/private
+- cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS6) $(includedir)/rudiments/private
+- cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS7) $(includedir)/rudiments/private
+- $(CHMOD) 644 $(includedir)/rudiments/*.h $(includedir)/rudiments/private/*.h
++ $(MKINSTALLDIRS) ${DESTDIR}$(includedir)/rudiments
++ $(MKINSTALLDIRS) ${DESTDIR}$(includedir)/rudiments/private
++ cd rudiments $(AND) $(CP) $(HEADERS0) ${DESTDIR}$(includedir)/rudiments
++ cd rudiments $(AND) $(CP) $(HEADERS1) ${DESTDIR}$(includedir)/rudiments
++ cd rudiments $(AND) $(CP) $(HEADERS2) ${DESTDIR}$(includedir)/rudiments
++ cd rudiments $(AND) $(CP) $(HEADERS3) ${DESTDIR}$(includedir)/rudiments
++ cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS0) ${DESTDIR}$(includedir)/rudiments/private
++ cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS1) ${DESTDIR}$(includedir)/rudiments/private
++ cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS2) ${DESTDIR}$(includedir)/rudiments/private
++ cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS3) ${DESTDIR}$(includedir)/rudiments/private
++ cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS4) ${DESTDIR}$(includedir)/rudiments/private
++ cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS5) ${DESTDIR}$(includedir)/rudiments/private
++ cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS6) ${DESTDIR}$(includedir)/rudiments/private
++ cd rudiments $(AND) cd private $(AND) $(CP) $(PRIVATEHEADERS7) ${DESTDIR}$(includedir)/rudiments/private
++ $(CHMOD) 644 ${DESTDIR}$(includedir)/rudiments/*.h ${DESTDIR}$(includedir)/rudiments/private/*.h
+
+ uninstall:
+ $(RMTREE) $(includedir)/rudiments
diff --git a/devel/rudiments/files/patch-man_Makefile b/devel/rudiments/files/patch-man_Makefile
new file mode 100644
index 000000000000..4869b8649dcd
--- /dev/null
+++ b/devel/rudiments/files/patch-man_Makefile
@@ -0,0 +1,18 @@
+--- man/Makefile.orig 2015-01-13 22:38:32 UTC
++++ man/Makefile
+@@ -3,10 +3,10 @@ top_builddir = ..
+ include ../config.mk
+
+ install:
+- $(MKINSTALLDIRS) $(mandir)
+- $(MKINSTALLDIRS) $(mandir)/man1
+- $(CP) rudiments-config.1 $(mandir)/man1
+- $(CHMOD) 644 $(mandir)/man1/rudiments-config.1
++ $(MKINSTALLDIRS) $(DESTDIR)$(mandir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man1
++ $(CP) rudiments-config.1 $(DESTDIR)$(mandir)/man1
++ $(CHMOD) 644 $(DESTDIR)$(mandir)/man1/rudiments-config.1
+
+ uninstall:
+- $(RM) $(mandir)/man1/rudiments-config.1
++ $(RM) $(DESTDIR)$(mandir)/man1/rudiments-config.1
diff --git a/devel/rudiments/files/patch-src_Makefile.in b/devel/rudiments/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..8a23a18db1a6
--- /dev/null
+++ b/devel/rudiments/files/patch-src_Makefile.in
@@ -0,0 +1,49 @@
+--- src/Makefile.in.orig 2015-02-06 03:20:27 UTC
++++ src/Makefile.in
+@@ -11,7 +11,7 @@ LOBJS = @LOBJS@
+ .SUFFIXES: .lo
+
+ .cpp.lo:
+- $(LTCOMPILE) $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(COMPILE) $< $(OUT)$@
++ $(LTCOMPILE) $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(COMPILE) $< $(OUT) $@
+
+ .cpp.obj:
+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(COMPILE) $<
+@@ -22,26 +22,26 @@ clean:
+ $(LTCLEAN) $(RM) *.lo *.o *.obj *.$(LIBEXT) *.lib *.exp *.idb *.pdb *.manifest
+
+ librudiments.$(LIBEXT): $(SRCS) $(LOBJS)
+- $(LTLINK) $(LINK) $(OUT)$@ $(LOBJS) $(LDFLAGS) $(LIBS) $(LINKFLAGS)
++ $(LTLINK) $(LINK) $(OUT) $@ $(LOBJS) $(LDFLAGS) $(LIBS) $(LINKFLAGS)
+
+ install: $(INSTALLLIB)
+
+ installdll:
+- $(MKINSTALLDIRS) $(bindir)
+- $(LTINSTALL) $(CP) librudiments.$(LIBEXT) $(bindir)
+- $(MKINSTALLDIRS) $(libdir)
+- $(LTINSTALL) $(CP) librudiments.lib $(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
++ $(LTINSTALL) $(CP) librudiments.$(LIBEXT) $(DESTDIR)$(bindir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(LTINSTALL) $(CP) librudiments.lib $(DESTDIR)$(libdir)
+
+ installlib:
+- $(MKINSTALLDIRS) $(libdir)
+- $(LTINSTALL) $(CP) librudiments.$(LIBEXT) $(libdir)
+- $(LTFINISH) $(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(LTINSTALL) $(CP) librudiments.$(LIBEXT) $(DESTDIR)$(libdir)
++ $(LTFINISH) $(DESTDIR)$(libdir)
+
+ uninstall: $(UNINSTALLLIB)
+
+ uninstalldll:
+- $(LTUNINSTALL) $(RM) $(bindir)/librudiments.$(LIBEXT)
+- $(LTUNINSTALL) $(RM) $(libdir)/librudiments.lib
++ $(LTUNINSTALL) $(RM) $(DESTDIR)$(bindir)/librudiments.$(LIBEXT)
++ $(LTUNINSTALL) $(RM) $(DESTDIR)$(libdir)/librudiments.lib
+
+ uninstalllib:
+- $(LTUNINSTALL) $(RM) $(libdir)/librudiments.$(LIBEXT)
++ $(LTUNINSTALL) $(RM) $(DESTDIR)$(libdir)/librudiments.$(LIBEXT)
diff --git a/devel/rudiments/pkg-plist b/devel/rudiments/pkg-plist
index 41d1b49e72c6..977cbb7b030f 100644
--- a/devel/rudiments/pkg-plist
+++ b/devel/rudiments/pkg-plist
@@ -13,6 +13,7 @@ include/rudiments/device.h
include/rudiments/dictionary.h
include/rudiments/directory.h
include/rudiments/dtd.h
+include/rudiments/dynamicarray.h
include/rudiments/dynamiclib.h
include/rudiments/environment.h
include/rudiments/error.h
@@ -63,6 +64,9 @@ include/rudiments/private/directoryincludes.h
include/rudiments/private/dll.h
include/rudiments/private/dtd.h
include/rudiments/private/dtdincludes.h
+include/rudiments/private/dynamicarray.h
+include/rudiments/private/dynamicarrayincludes.h
+include/rudiments/private/dynamicarrayinlines.h
include/rudiments/private/dynamiclib.h
include/rudiments/private/dynamiclibincludes.h
include/rudiments/private/environment.h
@@ -107,6 +111,7 @@ include/rudiments/private/modemclientincludes.h
include/rudiments/private/modemserver.h
include/rudiments/private/modemserverincludes.h
include/rudiments/private/modemutil.h
+include/rudiments/private/new.h
include/rudiments/private/parameterstring.h
include/rudiments/private/parameterstringincludes.h
include/rudiments/private/permissions.h
@@ -148,7 +153,10 @@ include/rudiments/private/socketclient.h
include/rudiments/private/socketclientincludes.h
include/rudiments/private/socketserver.h
include/rudiments/private/socketserverincludes.h
+include/rudiments/private/staticarray.h
+include/rudiments/private/staticarrayinlines.h
include/rudiments/private/stderrdestination.h
+include/rudiments/private/stdio.h
include/rudiments/private/stdoutdestination.h
include/rudiments/private/stringbuffer.h
include/rudiments/private/stringbufferincludes.h
@@ -191,6 +199,7 @@ include/rudiments/singlylinkedlist.h
include/rudiments/snooze.h
include/rudiments/socketclient.h
include/rudiments/socketserver.h
+include/rudiments/staticarray.h
include/rudiments/stdio.h
include/rudiments/stringbuffer.h
include/rudiments/sys.h