aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-05-30 14:22:36 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-05-30 14:22:36 +0000
commit7b67ca5eafc593c3a696c9212c3de27efbc18b24 (patch)
treeb1bcc69b17be0c5ed88a90cfe67f41dfc1db2fce /devel
parentb94e42c0e722192b449aa52fcfaf6a55a39e6f96 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libvhdi/Makefile32
-rw-r--r--devel/libvhdi/distinfo2
-rw-r--r--devel/libvhdi/pkg-descr3
-rw-r--r--devel/libvhdi/pkg-plist19
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5aec10473b73..6e89b2e14efa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1144,6 +1144,7 @@
SUBDIR += libvanessa_logger
SUBDIR += libvanessa_socket
SUBDIR += libvc
+ SUBDIR += libvhdi
SUBDIR += libvirt
SUBDIR += libvirt-glib
SUBDIR += libvirt-java
diff --git a/devel/libvhdi/Makefile b/devel/libvhdi/Makefile
new file mode 100644
index 000000000000..da215cca3256
--- /dev/null
+++ b/devel/libvhdi/Makefile
@@ -0,0 +1,32 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libvhdi
+# If/When moving from experimental to alpha, override DISTNAME to prevent PORTEPOCH
+DISTVERSION= experimental-20140330
+CATEGORIES= devel
+MASTER_SITES= https://googledrive.com/host/0B3fBvzttpiiSY250RjRzRXQ0bDg/ \
+ LOCAL/antoine
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Library and tools to access the Virtual Hard Disk image format
+
+LICENSE= LGPL3
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE} ${ICONV_CONFIGURE_ARG}
+USES= fuse gettext iconv libtool pathfix pkgconfig
+USE_PYTHON= 2
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+
+PORTDOCS= AUTHORS ChangeLog
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/libvhdi/distinfo b/devel/libvhdi/distinfo
new file mode 100644
index 000000000000..852b2eb875b6
--- /dev/null
+++ b/devel/libvhdi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libvhdi-experimental-20140330.tar.gz) = eb57d9907e1be98cc8e45dd68581fdd3e4a007573cc732649ac00985da7d9677
+SIZE (libvhdi-experimental-20140330.tar.gz) = 1306365
diff --git a/devel/libvhdi/pkg-descr b/devel/libvhdi/pkg-descr
new file mode 100644
index 000000000000..4ebccbc200e2
--- /dev/null
+++ b/devel/libvhdi/pkg-descr
@@ -0,0 +1,3 @@
+Library and tools to access the Virtual Hard Disk (VHD) image format.
+
+WWW: http://code.google.com/p/libvhdi/
diff --git a/devel/libvhdi/pkg-plist b/devel/libvhdi/pkg-plist
new file mode 100644
index 000000000000..8380836c5652
--- /dev/null
+++ b/devel/libvhdi/pkg-plist
@@ -0,0 +1,19 @@
+bin/vhdiinfo
+bin/vhdimount
+include/libvhdi.h
+include/libvhdi/codepage.h
+include/libvhdi/definitions.h
+include/libvhdi/error.h
+include/libvhdi/extern.h
+include/libvhdi/features.h
+include/libvhdi/types.h
+lib/libvhdi.a
+lib/libvhdi.so
+lib/libvhdi.so.1
+lib/libvhdi.so.1.0.0
+%%PYTHON_SITELIBDIR%%/pyvhdi.a
+%%PYTHON_SITELIBDIR%%/pyvhdi.so
+libdata/pkgconfig/libvhdi.pc
+man/man1/vhdiinfo.1.gz
+man/man3/libvhdi.3.gz
+@dirrm include/libvhdi