aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2014-07-14 10:31:45 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2014-07-14 10:31:45 +0000
commitb962a844e357d85a8a7ab85da8debd28e46f8f8a (patch)
tree92f50c54b8af307cbf57e9df9a7db63510954d0f /devel
parentc189f5fcc965d205eb6f3f4c0119fc1e0f9d53d1 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-runewidth/Makefile25
-rw-r--r--devel/go-runewidth/distinfo2
-rw-r--r--devel/go-runewidth/pkg-descr5
-rw-r--r--devel/go-runewidth/pkg-plist15
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6fdb7536cb65..162c7b3c1c70 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -597,6 +597,7 @@
SUBDIR += go-flags
SUBDIR += go-json-rest
SUBDIR += go-pretty
+ SUBDIR += go-runewidth
SUBDIR += go-sql-driver
SUBDIR += gob2
SUBDIR += gobject-introspection
diff --git a/devel/go-runewidth/Makefile b/devel/go-runewidth/Makefile
new file mode 100644
index 000000000000..42fd950c5e70
--- /dev/null
+++ b/devel/go-runewidth/Makefile
@@ -0,0 +1,25 @@
+# Created by: Akinori MUSHA aka knu <knu@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= runewidth
+PORTVERSION= 0.0.0.20140623
+CATEGORIES= devel
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= go-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Go library to get the fixed width of a character or string
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= mattn
+GH_PROJECT= ${PKGNAMEPREFIX}${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= d70c973
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/go-runewidth/distinfo b/devel/go-runewidth/distinfo
new file mode 100644
index 000000000000..bb6090a5a9f2
--- /dev/null
+++ b/devel/go-runewidth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (runewidth-0.0.0.20140623.tar.gz) = fb03cbe156fc21b974a350ca76afe667e9aa3cab08010cf36a902f32792c8723
+SIZE (runewidth-0.0.0.20140623.tar.gz) = 4508
diff --git a/devel/go-runewidth/pkg-descr b/devel/go-runewidth/pkg-descr
new file mode 100644
index 000000000000..991e6486fc1b
--- /dev/null
+++ b/devel/go-runewidth/pkg-descr
@@ -0,0 +1,5 @@
+Go-runewidth provides functions to get the fixed width of a character
+or string.
+
+Author: Yasuhiro Matsumoto
+WWW: https://github.com/mattn/go-runewidth
diff --git a/devel/go-runewidth/pkg-plist b/devel/go-runewidth/pkg-plist
new file mode 100644
index 000000000000..6572dd682e50
--- /dev/null
+++ b/devel/go-runewidth/pkg-plist
@@ -0,0 +1,15 @@
+%%GO_LIBDIR%%/github.com/mattn/go-runewidth.a
+@dirrmtry %%GO_LIBDIR%%/github.com/mattn
+@dirrmtry %%GO_LIBDIR%%/github.com
+@dirrmtry %%GO_LIBDIR%%
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.mkd
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/runewidth.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/runewidth_posix.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/runewidth_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/runewidth_windows.go
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_SRCDIR%%/github.com/mattn
+@dirrmtry %%GO_SRCDIR%%/github.com
+@dirrmtry %%GO_SRCDIR%%
+@dirrmtry share/go/pkg
+@dirrmtry share/go