aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-04-19 10:43:42 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-04-19 10:43:42 +0000
commitbf330a57d40cb5c6f57f61de4d24c0dcbf14dbee (patch)
treefbc3a0515acb659ae86ec22a706ac4607711c903 /devel
parent7db76e2b98b1517c19aa3a79957ac3b37bf853ae (diff)
downloadports-bf330a57d40cb5c6f57f61de4d24c0dcbf14dbee.tar.gz
ports-bf330a57d40cb5c6f57f61de4d24c0dcbf14dbee.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/avr-gcc/Makefile3
-rw-r--r--devel/binutils/Makefile3
-rw-r--r--devel/cross-gcc/Makefile4
-rw-r--r--devel/darcs/Makefile4
-rw-r--r--devel/djgpp-gcc/Makefile4
-rw-r--r--devel/hs-Stream/Makefile3
-rw-r--r--devel/hs-alex/Makefile4
-rw-r--r--devel/hs-c2hs/Makefile4
-rw-r--r--devel/hs-cpphs/Makefile3
-rw-r--r--devel/hs-darcs/Makefile4
-rw-r--r--devel/hs-drift/Makefile4
-rw-r--r--devel/hs-haddock/Makefile3
-rw-r--r--devel/hs-happy/Makefile3
-rw-r--r--devel/hs-hdoc/Makefile4
-rw-r--r--devel/hs-hmake/Makefile4
-rw-r--r--devel/hs-hoogle/Makefile3
-rw-r--r--devel/hs-idoc/Makefile4
-rw-r--r--devel/hs-mueval/Makefile3
-rw-r--r--devel/hs-uuagc/Makefile3
-rw-r--r--devel/libYGP/Makefile3
-rw-r--r--devel/libuninum/Makefile4
-rw-r--r--devel/mingw32-gcc/Makefile3
-rw-r--r--devel/ppl/Makefile3
-rw-r--r--devel/ppl/files/patch-configure21
-rw-r--r--devel/py-mx-experimental/Makefile3
-rw-r--r--devel/root/Makefile4
-rw-r--r--devel/sfslite/Makefile3
27 files changed, 73 insertions, 38 deletions
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index 5eedcfe62327..2ef5d0996e4d 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcc
PORTVERSION= 4.3.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
@@ -23,7 +24,7 @@ COMMENT= FSF GCC 4.x for Atmel AVR 8-bit RISC cross-development
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
LIB_DEPENDS= mpfr.3:${PORTSDIR}/math/mpfr \
- gmp.8:${PORTSDIR}/math/libgmp4
+ gmp.10:${PORTSDIR}/math/gmp
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 85af89984d2b..833c37d84b54 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= binutils
PORTVERSION= 2.20.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
@@ -18,7 +19,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-BUILD_DEPENDS= ${LOCALBASE}/lib/libgmp.so:${PORTSDIR}/math/libgmp4 \
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgmp.so:${PORTSDIR}/math/gmp \
${LOCALBASE}/lib/libmpfr.so:${PORTSDIR}/math/mpfr
CONFLICTS= libbfd-[0-9]*
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index 1e3f2de865ee..a71202d7950a 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= gcc
PORTVERSION= 4.4.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC:S,$,:gcc,} \
${MASTER_SITE_SOURCEWARE:S,$,:newlib,}
@@ -23,7 +23,7 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= stas@FreeBSD.org
COMMENT= GNU gcc for cross-target development
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
#
diff --git a/devel/darcs/Makefile b/devel/darcs/Makefile
index 8b67f448d100..a793c53f0656 100644
--- a/devel/darcs/Makefile
+++ b/devel/darcs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= darcs
PORTVERSION= 2.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= http://darcs.net/
@@ -16,7 +16,7 @@ COMMENT= Yet another replacement for CVS, written in Haskell
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- gmp.8:${PORTSDIR}/math/libgmp4
+ gmp.10:${PORTSDIR}/math/gmp
OPTIONS= SERVER "install server" on
GNU_CONFIGURE= yes
diff --git a/devel/djgpp-gcc/Makefile b/devel/djgpp-gcc/Makefile
index 4637153f801f..ac1484e3ebef 100644
--- a/devel/djgpp-gcc/Makefile
+++ b/devel/djgpp-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= ${GCCVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= ftp://ftp.delorie.com/pub/djgpp/current/v2gnu/:djsource \
ftp://ftp.mirror.ac.uk/sites/www.delorie.com/current/v2gnu/:djsource \
@@ -32,7 +32,7 @@ BUILD_DEPENDS= ${TARGET}-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
autoconf-2.62:${PORTSDIR}/devel/autoconf262 \
aclocal-1.9:${PORTSDIR}/devel/automake19
.if defined(WITH_FORTRAN)
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
.endif
RUN_DEPENDS= ${TARGET}-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
diff --git a/devel/hs-Stream/Makefile b/devel/hs-Stream/Makefile
index 807975d4a7de..c9d4dcbd6ee2 100644
--- a/devel/hs-Stream/Makefile
+++ b/devel/hs-Stream/Makefile
@@ -6,6 +6,7 @@
PORTNAME= Stream
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
http://carte.kerneled.org/mirror/
@@ -20,7 +21,7 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
hs-QuickCheck>=2.0:${PORTSDIR}/devel/hs-QuickCheck \
hs-lazysmallcheck-ghc>=0.3:${PORTSDIR}/devel/hs-lazysmallcheck-ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
GHC_VERSION= 6.10.4
STREAM_VERSION= ${PORTVERSION}
diff --git a/devel/hs-alex/Makefile b/devel/hs-alex/Makefile
index 39ed628b053b..a6e193477353 100644
--- a/devel/hs-alex/Makefile
+++ b/devel/hs-alex/Makefile
@@ -6,7 +6,7 @@
PORTNAME= alex
PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/alex/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -15,7 +15,7 @@ MAINTAINER= haskell@FreeBSD.org
COMMENT= Alex is a tool for generating lexical analysers in Haskell
BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= ${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl \
diff --git a/devel/hs-c2hs/Makefile b/devel/hs-c2hs/Makefile
index 64ca31528b98..7cf4184a8f1d 100644
--- a/devel/hs-c2hs/Makefile
+++ b/devel/hs-c2hs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= c2hs
PORTVERSION= 0.16.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -18,7 +18,7 @@ COMMENT= C->Haskell, an Interface Generator for Haskell
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-language-c-ghc>=0.3.1.1:${PORTSDIR}/devel/hs-language-c-ghc
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
GHC_VERSION= 6.10.4
C2HS_VERSION= ${PORTVERSION}
diff --git a/devel/hs-cpphs/Makefile b/devel/hs-cpphs/Makefile
index cd7447581e4f..8b0481815a0b 100644
--- a/devel/hs-cpphs/Makefile
+++ b/devel/hs-cpphs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cpphs
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://www.cs.york.ac.uk/fp/cpphs/
PKGNAMEPREFIX= hs-
@@ -16,7 +17,7 @@ COMMENT= A simplified re-implementation of cpp in Haskell
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
GHC_VERSION= 6.10.4
CPPHS_VERSION= ${PORTVERSION}
diff --git a/devel/hs-darcs/Makefile b/devel/hs-darcs/Makefile
index 8b67f448d100..a793c53f0656 100644
--- a/devel/hs-darcs/Makefile
+++ b/devel/hs-darcs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= darcs
PORTVERSION= 2.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= http://darcs.net/
@@ -16,7 +16,7 @@ COMMENT= Yet another replacement for CVS, written in Haskell
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- gmp.8:${PORTSDIR}/math/libgmp4
+ gmp.10:${PORTSDIR}/math/gmp
OPTIONS= SERVER "install server" on
GNU_CONFIGURE= yes
diff --git a/devel/hs-drift/Makefile b/devel/hs-drift/Makefile
index 032d08a91b85..e070435e77cd 100644
--- a/devel/hs-drift/Makefile
+++ b/devel/hs-drift/Makefile
@@ -6,7 +6,7 @@
PORTNAME= drift
PORTVERSION= 2.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MASTER_SITES= http://repetae.net/computer/haskell/DrIFT/drop/
PKGNAMEPREFIX= hs-
@@ -22,7 +22,7 @@ OPTIONS= NHC98 "Build with nhc98" off \
.if !defined(WITH_NHC98)
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
.else
BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
BROKEN= Does not build
diff --git a/devel/hs-haddock/Makefile b/devel/hs-haddock/Makefile
index f65f3035e217..526afbf8a325 100644
--- a/devel/hs-haddock/Makefile
+++ b/devel/hs-haddock/Makefile
@@ -6,6 +6,7 @@
PORTNAME= haddock
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://www.haskell.org/haddock/dist/ \
http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
@@ -19,7 +20,7 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-ghc-paths>=0.1.0.5:${PORTSDIR}/devel/hs-ghc-paths
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-ghc-paths>=0.1.0.5:${PORTSDIR}/devel/hs-ghc-paths
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
.else
NO_PKG_REGISTER=
.endif
diff --git a/devel/hs-happy/Makefile b/devel/hs-happy/Makefile
index 5a5932fd6707..a4e9969b1779 100644
--- a/devel/hs-happy/Makefile
+++ b/devel/hs-happy/Makefile
@@ -6,6 +6,7 @@
PORTNAME= happy
PORTVERSION= 1.18.4
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -14,7 +15,7 @@ MAINTAINER= haskell@FreeBSD.org
COMMENT= An LALR(1) parser generator for the functional language Haskell
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= ${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl \
${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt
diff --git a/devel/hs-hdoc/Makefile b/devel/hs-hdoc/Makefile
index 19aa85386496..fc88caf374c9 100644
--- a/devel/hs-hdoc/Makefile
+++ b/devel/hs-hdoc/Makefile
@@ -6,7 +6,7 @@
PORTNAME= hdoc
PORTVERSION= 0.8.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel haskell
MASTER_SITES= http://staff.fmi.uni-passau.de/~groessli/hdoc/
PKGNAMEPREFIX= hs-
@@ -15,7 +15,7 @@ MAINTAINER= haskell@FreeBSD.org
COMMENT= HTML documentation tool for Haskell
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
diff --git a/devel/hs-hmake/Makefile b/devel/hs-hmake/Makefile
index 13dcbdcb5e6f..d1652a0ba9db 100644
--- a/devel/hs-hmake/Makefile
+++ b/devel/hs-hmake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hmake
PORTVERSION= 3.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel haskell
MASTER_SITES= http://www.haskell.org/hmake/ \
ftp://ftp.cs.york.ac.uk/pub/haskell/hmake/ \
@@ -20,7 +20,7 @@ COMMENT= Intelligent compilation management tool for Haskell programs
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-readline>=1.0.1.0:${PORTSDIR}/devel/hs-readline
RUN_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
HAS_CONFIGURE= YES
CONFIGURE_ARGS+= --prefix=${PREFIX}
diff --git a/devel/hs-hoogle/Makefile b/devel/hs-hoogle/Makefile
index 9e5510f80bc7..4cb54464bbca 100644
--- a/devel/hs-hoogle/Makefile
+++ b/devel/hs-hoogle/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hoogle
PORTVERSION= 4.0.7
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -20,7 +21,7 @@ BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
hs-safe>=0.2:${PORTSDIR}/devel/hs-safe \
hs-uniplate>=1.2.0.3:${PORTSDIR}/devel/hs-uniplate
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
GHC_VERSION= 6.10.4
HOOGLE_VERSION= ${PORTVERSION}
diff --git a/devel/hs-idoc/Makefile b/devel/hs-idoc/Makefile
index e656a731040a..9f072dba4325 100644
--- a/devel/hs-idoc/Makefile
+++ b/devel/hs-idoc/Makefile
@@ -6,7 +6,7 @@
PORTNAME= idoc
PORTVERSION= 0.2.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel haskell
MASTER_SITES= http://www.cse.unsw.edu.au/~chak/haskell/idoc/
PKGNAMEPREFIX= hs-
@@ -15,7 +15,7 @@ MAINTAINER= haskell@FreeBSD.org
COMMENT= A No Frills Haskell Interface Documentation System
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
PLIST_FILES= bin/idoc
USE_GMAKE= yes
diff --git a/devel/hs-mueval/Makefile b/devel/hs-mueval/Makefile
index 52f807368759..6b2a9f2b714d 100644
--- a/devel/hs-mueval/Makefile
+++ b/devel/hs-mueval/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mueval
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -22,7 +23,7 @@ RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
hs-utf8-string-ghc>=0.3:${PORTSDIR}/devel/hs-utf8-string-ghc \
hs-show>=0.3:${PORTSDIR}/devel/hs-show \
hs-hint>=0.3.1:${PORTSDIR}/devel/hs-hint
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
GHC_VERSION= 6.10.4
MUEVAL_VERSION= ${PORTVERSION}
diff --git a/devel/hs-uuagc/Makefile b/devel/hs-uuagc/Makefile
index 289701fd8540..163bf6594227 100644
--- a/devel/hs-uuagc/Makefile
+++ b/devel/hs-uuagc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= uuagc
PORTVERSION= 0.9.12
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -16,7 +17,7 @@ COMMENT= Attribute Grammar System of Universiteit Utrecht
BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
hs-uulib>=0.9.5:${PORTSDIR}/devel/hs-uulib
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
GHC_VERSION= 6.10.4
UUAGC_VERSION= ${PORTVERSION}
diff --git a/devel/libYGP/Makefile b/devel/libYGP/Makefile
index b859a5ae3360..c1108af5608e 100644
--- a/devel/libYGP/Makefile
+++ b/devel/libYGP/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= libYGP
PORTVERSION= 0.9.30
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/libymp/libymp/libYGP-${PORTVERSION}
DISTNAME= libYGP-${PORTVERSION}
@@ -14,7 +15,7 @@ DISTNAME= libYGP-${PORTVERSION}
MAINTAINER= corky1951@comcast.net
COMMENT= Yet another General Purpose library
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
boost_filesystem:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
diff --git a/devel/libuninum/Makefile b/devel/libuninum/Makefile
index 0167ce5cff79..9fad8cf742d4 100644
--- a/devel/libuninum/Makefile
+++ b/devel/libuninum/Makefile
@@ -7,14 +7,14 @@
PORTNAME= libuninum
PORTVERSION= 2.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://billposer.org/Software/Downloads/
MAINTAINER= clsung@FreeBSD.org
COMMENT= Library for converting Unicode strings to numbers
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index 2b264cbd21d0..c3f8c0fcdd89 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcc
PORTVERSION= ${GCCVERSION}
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
@@ -20,7 +21,7 @@ COMMENT= FSF gcc-4 for Windows cross-development
BUILD_DEPENDS= ${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
mingwm10.dll:${PORTSDIR}/devel/${PKGNAMEPREFIX}bin-msvcrt
RUN_DEPENDS= ${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
GCCVERSION= 4.4.0
diff --git a/devel/ppl/Makefile b/devel/ppl/Makefile
index a254e7282fe4..625707543882 100644
--- a/devel/ppl/Makefile
+++ b/devel/ppl/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ppl
PORTVERSION= 0.10.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cs.unipr.it/pub/ppl/releases/%SUBDIR%/ \
http://www.cs.unipr.it/ppl/Download/ftp/releases/%SUBDIR%/
@@ -17,7 +18,7 @@ MAINTAINER= grosser@fim.uni-passau.de
COMMENT= The Parma Polyhedra Library
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
USE_GMAKE= yes
USE_GNOME= gnometarget
diff --git a/devel/ppl/files/patch-configure b/devel/ppl/files/patch-configure
new file mode 100644
index 000000000000..6802f484f464
--- /dev/null
+++ b/devel/ppl/files/patch-configure
@@ -0,0 +1,21 @@
+--- configure.orig 2010-04-13 10:19:13.000000000 +0200
++++ configure 2010-04-13 10:19:48.000000000 +0200
+@@ -16469,18 +16469,6 @@
+ return 1;
+ }
+
+- if (sizeof(mp_limb_t)*CHAR_BIT != GMP_LIMB_BITS
+- || GMP_LIMB_BITS != mp_bits_per_limb) {
+- std::cerr
+- << "GMP header (gmp.h) and library (ligmp.*) bits-per-limb mismatch:\n"
+- << "header gives " << __GMP_BITS_PER_MP_LIMB << ";\n"
+- << "library gives " << mp_bits_per_limb << ".\n"
+- << "This probably means you are on a bi-arch system and\n"
+- << "you are compiling with the wrong header or linking with\n"
+- << "the wrong library." << std::endl;
+- return 1;
+- }
+-
+ mpz_class n("3141592653589793238462643383279502884");
+ return 0;
+ }
diff --git a/devel/py-mx-experimental/Makefile b/devel/py-mx-experimental/Makefile
index 959850bdb919..e7d1433e53c4 100644
--- a/devel/py-mx-experimental/Makefile
+++ b/devel/py-mx-experimental/Makefile
@@ -8,6 +8,7 @@
PORTNAME= mx-experimental
PORTVERSION= 3.0.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://downloads.egenix.com/python/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ DISTNAME= egenix-${PORTNAME}-${PORTVERSION}
MAINTAINER= sergio@softshark.org
COMMENT= The eGenix mx Extensions - EXPERIMENTAL Package
-BUILD_DEPENDS= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp4
+BUILD_DEPENDS= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/gmp
#RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/BeeBase/BeeBase.py:${PORTSDIR}/lang/py-mx-base
USE_PYTHON= yes
diff --git a/devel/root/Makefile b/devel/root/Makefile
index 4bb86ddb5284..cac9ed048c98 100644
--- a/devel/root/Makefile
+++ b/devel/root/Makefile
@@ -7,7 +7,7 @@
PORTNAME= root
PORTVERSION= 5.02.00
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= devel science math
MASTER_SITES= ftp://root.cern.ch/root/
DISTNAME= ${PORTNAME}_v${PORTVERSION}.source
@@ -33,7 +33,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
USE_OPENSSL= yes
USE_GMAKE= yes
USE_XORG= xpm x11
diff --git a/devel/sfslite/Makefile b/devel/sfslite/Makefile
index d617d6d486a0..52f8231c9249 100644
--- a/devel/sfslite/Makefile
+++ b/devel/sfslite/Makefile
@@ -7,13 +7,14 @@
PORTNAME= sfslite
PORTVERSION= 1.2.7
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://dist.okws.org/dist/
MAINTAINER= ports@okws.org
COMMENT= Standard version of the sfslite library
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
CONFIGURE_ARGS= --with-gmp=${LOCALBASE}