aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
commitc7c32639cce504dbfefa9d1a09034d60600acaca (patch)
tree542278ecb4449b3df78960fd5f6cf7d8be50914f /devel
parent42aab3eb75f5152697ee03e5e8457ce58906e2c1 (diff)
downloadports-c7c32639cce504dbfefa9d1a09034d60600acaca.tar.gz
ports-c7c32639cce504dbfefa9d1a09034d60600acaca.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/geany/Makefile10
-rw-r--r--devel/jakarta-commons-io/Makefile11
-rw-r--r--devel/qdevelop/Makefile16
3 files changed, 12 insertions, 25 deletions
diff --git a/devel/geany/Makefile b/devel/geany/Makefile
index f7da98c5c8dd..44ee43f72ef3 100644
--- a/devel/geany/Makefile
+++ b/devel/geany/Makefile
@@ -30,14 +30,10 @@ VTE_DESC= Embedded virtual terminal
VTE_CONFIGURE_ENABLE= vte
VTE_USE= GNOME=vte
-.include <bsd.port.options.mk>
-
-post-patch:
-.if !${PORT_OPTIONS:MDOCS}
+post-patch-DOCS-off:
@${REINPLACE_CMD} -e '/^SUBDIRS/ s|doc||' ${WRKSRC}/Makefile.in
-.endif
-.if !${PORT_OPTIONS:MNLS}
+
+post-patch-NLS-off:
@${REINPLACE_CMD} -e '/^SUBDIRS/ s|po||' ${WRKSRC}/Makefile.in
-.endif
.include <bsd.port.mk>
diff --git a/devel/jakarta-commons-io/Makefile b/devel/jakarta-commons-io/Makefile
index 3e1bbdddc26f..e31b9de8c9d7 100644
--- a/devel/jakarta-commons-io/Makefile
+++ b/devel/jakarta-commons-io/Makefile
@@ -27,20 +27,15 @@ PORTDOCS= LICENSE.txt NOTICE.txt RELEASE-NOTES.txt apidocs
JAR_VERSION= ${PORTNAME}-2.2-SNAPSHOT
OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-ALL_TARGET+= javadoc
-.endif
+DOCS_ALL_TARGET= javadoc
do-install:
${INSTALL_DATA} ${WRKSRC}/target/${JAR_VERSION}.jar \
${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
(cd ${WRKSRC}/target && ${COPYTREE_SHARE} apidocs ${STAGEDIR}${DOCSDIR})
(cd ${WRKSRC} && ${INSTALL_DATA} LICENSE.txt NOTICE.txt \
RELEASE-NOTES.txt ${STAGEDIR}${DOCSDIR})
-.endif
.include <bsd.port.mk>
diff --git a/devel/qdevelop/Makefile b/devel/qdevelop/Makefile
index 0404e5532f4c..761d8a650bc0 100644
--- a/devel/qdevelop/Makefile
+++ b/devel/qdevelop/Makefile
@@ -25,15 +25,13 @@ DESKTOP_ENTRIES= "QDevelop" \
true
OPTIONS_DEFINE= TOOLS DOCS NLS
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+OPTIONS_DEFAULT:= ${OPTIONS_DEFINE}
OPTIONS_SUB= yes
NLS_USE= QT4=linguisttools_build
TOOLS_DESC= Install Qt 4 development tools (qmake, moc, etc.)
TOOLS_USE= ${_TOOLS:C|.*|QT4=&_run|}
_TOOLS= assistant linguisttools moc qmake rcc uic
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e "s|\"qmake\"|\"qmake-qt4\"|g" \
-e "s|\"linguist\"|\"linguist-qt4\"|g" \
@@ -51,20 +49,18 @@ post-patch:
${WRKSRC}/plugins/tools-regexp-planner/replugin.cpp \
${WRKSRC}/plugins/formatting-astyle/astyleplugin.cpp
-post-configure:
-.if ${PORT_OPTIONS:MNLS}
+post-configure-NLS-on:
${LRELEASE} ${WRKSRC}/QDevelop.pro
-.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/resources/images/logo.png ${STAGEDIR}${PREFIX}/share/pixmaps/qdevelop.png
-.if ${PORT_OPTIONS:MNLS}
+
+post-install-NLS-on:
@${MKDIR} ${STAGEDIR}${DATADIR}/translations
${INSTALL_DATA} ${WRKSRC}/resources/translations/*.qm ${STAGEDIR}${DATADIR}/translations
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog.txt ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>