aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-07 11:23:12 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-07 11:23:12 +0000
commit1fd451d376c04b6df48cea64574e4b1d7ba21fb0 (patch)
tree3a403691ecd77fedbd9c457b0c7ad9ee1091d996 /devel
parent82bdc6ed1f0cf3469e71c361f443eec10e4ce686 (diff)
downloadports-1fd451d376c04b6df48cea64574e4b1d7ba21fb0.tar.gz
ports-1fd451d376c04b6df48cea64574e4b1d7ba21fb0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-optparse/Makefile49
-rw-r--r--devel/ruby-optparse/distinfo1
-rw-r--r--devel/ruby-optparse/pkg-comment1
-rw-r--r--devel/ruby-optparse/pkg-descr8
-rw-r--r--devel/ruby-optparse/pkg-plist15
6 files changed, 75 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ec69e4dc09b2..90ed79081650 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -262,6 +262,7 @@
SUBDIR += rinfo
SUBDIR += robodoc
SUBDIR += rpc2
+ SUBDIR += ruby-optparse
SUBDIR += ruby-property
SUBDIR += ruby-racc
SUBDIR += rvm
diff --git a/devel/ruby-optparse/Makefile b/devel/ruby-optparse/Makefile
new file mode 100644
index 000000000000..4df71b5ed000
--- /dev/null
+++ b/devel/ruby-optparse/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: Ruby-OptionParser
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= optparse
+PORTVERSION= 0.7.5
+CATEGORIES= devel # ruby
+MASTER_SITES= http://member.nifty.ne.jp/nokada/archive/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/ruby/site_ruby/optparse
+.for f in optparse.rb optparse/shellwords.rb optparse/time.rb
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/ruby/site_ruby/${f}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/optparse/examples/ja
+ ${MKDIR} ${PREFIX}/share/doc/ruby/optparse/ja
+.for f in optparse.rlog
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/optparse/
+.endfor
+.for f in optparse.ja.rd
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/optparse/ja/
+.endfor
+.for f in cmd-ls.rb cmd.rb getopts.test.en opttest.rb
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/optparse/examples/
+.endfor
+.for f in getopts.test
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/optparse/examples/ja
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-optparse/distinfo b/devel/ruby-optparse/distinfo
new file mode 100644
index 000000000000..838b099e683b
--- /dev/null
+++ b/devel/ruby-optparse/distinfo
@@ -0,0 +1 @@
+MD5 (optparse-0.7.5.tar.gz) = 6b4a5e1957f62c030b81d8041dc1f63a
diff --git a/devel/ruby-optparse/pkg-comment b/devel/ruby-optparse/pkg-comment
new file mode 100644
index 000000000000..727ead5987b3
--- /dev/null
+++ b/devel/ruby-optparse/pkg-comment
@@ -0,0 +1 @@
+Yet another command line option parser for Ruby
diff --git a/devel/ruby-optparse/pkg-descr b/devel/ruby-optparse/pkg-descr
new file mode 100644
index 000000000000..be0473d5854b
--- /dev/null
+++ b/devel/ruby-optparse/pkg-descr
@@ -0,0 +1,8 @@
+OptionParser is yet another command line option parser for Ruby.
+
+Features:
+ * describe option definition with its handler
+ * specify argument format and convert automatically
+ * can emit options' summaries
+ * can add options on the fly
+ * completion for option/argument
diff --git a/devel/ruby-optparse/pkg-plist b/devel/ruby-optparse/pkg-plist
new file mode 100644
index 000000000000..52ce9ed63d64
--- /dev/null
+++ b/devel/ruby-optparse/pkg-plist
@@ -0,0 +1,15 @@
+lib/ruby/site_ruby/optparse/shellwords.rb
+lib/ruby/site_ruby/optparse/time.rb
+lib/ruby/site_ruby/optparse.rb
+@dirrm lib/ruby/site_ruby/optparse
+share/doc/ruby/optparse/examples/ja/getopts.test
+share/doc/ruby/optparse/examples/cmd-ls.rb
+share/doc/ruby/optparse/examples/cmd.rb
+share/doc/ruby/optparse/examples/getopts.test.en
+share/doc/ruby/optparse/examples/opttest.rb
+share/doc/ruby/optparse/ja/optparse.ja.rd
+share/doc/ruby/optparse/optparse.rlog
+@dirrm share/doc/ruby/optparse/examples/ja
+@dirrm share/doc/ruby/optparse/examples
+@dirrm share/doc/ruby/optparse/ja
+@dirrm share/doc/ruby/optparse