aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-01-18 12:01:38 +0000
committerRene Ladan <rene@FreeBSD.org>2022-01-30 11:45:26 +0000
commit5003158b43ab436f59c96a3f30b2b0149cf7eb70 (patch)
treef024977aa369544f630127da41f0d4b33b12b7a8 /devel
parent66fe7cd9f3093c602d7657d803d24d1a9aef5c39 (diff)
downloadports-5003158b43ab436f59c96a3f30b2b0149cf7eb70.tar.gz
ports-5003158b43ab436f59c96a3f30b2b0149cf7eb70.zip
cleanup: remove transitive py27 deprecation (www/qt5-webengine)
(cherry picked from commit 48d98ef9181e828b575f37e1841ad53e5def5987)
Diffstat (limited to 'devel')
-rw-r--r--devel/RStudio/Makefile2
-rw-r--r--devel/gammaray/Makefile3
-rw-r--r--devel/kdevelop/Makefile7
-rw-r--r--devel/pyside2-tools/Makefile2
-rw-r--r--devel/pyside2/Makefile2
-rw-r--r--devel/qtcreator/Makefile5
6 files changed, 0 insertions, 21 deletions
diff --git a/devel/RStudio/Makefile b/devel/RStudio/Makefile
index 8d610762eda6..b031e76d63e1 100644
--- a/devel/RStudio/Makefile
+++ b/devel/RStudio/Makefile
@@ -64,8 +64,6 @@ GWT_VERSION= 2.8.1
GIN_VERSION= 2.1.2
.if ${FLAVOR:U} == desktop
-DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
-EXPIRATION_DATE=2021-06-23
COMMENT+= (desktop UI version)
USES+= desktop-file-utils qt:5 shared-mime-info
USE_QT= core dbus declarative gui location network opengl printsupport quickcontrols sensors \
diff --git a/devel/gammaray/Makefile b/devel/gammaray/Makefile
index 210df2f96001..3a4877a28741 100644
--- a/devel/gammaray/Makefile
+++ b/devel/gammaray/Makefile
@@ -6,9 +6,6 @@ CATEGORIES= devel
MAINTAINER= swills@FreeBSD.org
COMMENT= Debugging tool for Qt-application
-DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
-EXPIRATION_DATE=2021-06-23
-
USES= cmake kde:5 pkgconfig qt:5
USE_QT= 3d concurrent core declarative designer gui help linguisttools \
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index ba367139462c..bf2d26fb758e 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -60,11 +60,4 @@ SHEBANG_LANG= zsh
zsh_OLD_CMD= /bin/zsh
zsh_CMD= ${LOCALBASE}/bin/zsh
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MWEBENGINE}
-DEPRECATED= Uses EOL Pyton 2.7 via www/qt5-webengine
-EXPIRATION_DATE=2021-06-23
-.endif
-
.include <bsd.port.mk>
diff --git a/devel/pyside2-tools/Makefile b/devel/pyside2-tools/Makefile
index 47652867cc62..91efc9a1ecbe 100644
--- a/devel/pyside2-tools/Makefile
+++ b/devel/pyside2-tools/Makefile
@@ -35,8 +35,6 @@ CMAKE_ARGS+= "-DUSE_PYTHON_VERSION=${PYTHON_VER}"
WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION:C/^([0-9].[0-9]+.[0-9])(.[0-9])?/\1/}/sources/pyside2-tools
.if ${ARCH} == amd64 || ${ARCH} == i386
-DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
-EXPIRATION_DATE=2021-06-23
USE_QT+= webengine
.endif
diff --git a/devel/pyside2/Makefile b/devel/pyside2/Makefile
index c82d074f2ec7..e7211fb4fc05 100644
--- a/devel/pyside2/Makefile
+++ b/devel/pyside2/Makefile
@@ -36,8 +36,6 @@ PLIST_SUB+= DISTVERSION=${DISTVERSION}
WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION:C/^([0-9].[0-9]+.[0-9])(.[0-9])?/\1/}/sources/pyside2
.if ${ARCH} == amd64 || ${ARCH} == i386
-DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
-EXPIRATION_DATE=2021-06-23
PLIST_SUB+= WEBENGINE=""
USE_QT+= webengine
.else
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index f4bd60617309..b7de8f357629 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -86,11 +86,6 @@ SHEBANG_FILES= tests/system/tools/objectsToTable.py \
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MWEBENGINE}
-DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
-EXPIRATION_DATE=2021-06-23
-.endif
-
# Force a modern LLVM >= 10
.if ${LLVM_DEFAULT:C/[1-5]./&0/:S,-devel,990,} > 80
LLVM_DEFAULT= 11