aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-29 16:05:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-29 16:05:51 +0000
commit8ea5d54880eba153e2205d8bef253a680191aae0 (patch)
tree36180ad0769190c1bcd4b7edea63c44014197217 /devel
parente62cdd2934dd920c2c11d3d2fb66e7b2b4288e62 (diff)
downloadports-8ea5d54880eba153e2205d8bef253a680191aae0.tar.gz
ports-8ea5d54880eba153e2205d8bef253a680191aae0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Getopt-Compact-WithCmd/Makefile38
-rw-r--r--devel/p5-Getopt-Compact-WithCmd/distinfo2
-rw-r--r--devel/p5-Getopt-Compact-WithCmd/pkg-descr4
-rw-r--r--devel/p5-Getopt-Compact-WithCmd/pkg-plist7
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e812bb227091..c988fab7c778 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1853,6 +1853,7 @@
SUBDIR += p5-Getopt-ArgvFile
SUBDIR += p5-Getopt-Attribute
SUBDIR += p5-Getopt-Compact
+ SUBDIR += p5-Getopt-Compact-WithCmd
SUBDIR += p5-Getopt-Declare
SUBDIR += p5-Getopt-Euclid
SUBDIR += p5-Getopt-GUI-Long
diff --git a/devel/p5-Getopt-Compact-WithCmd/Makefile b/devel/p5-Getopt-Compact-WithCmd/Makefile
new file mode 100644
index 000000000000..2a5757f98a10
--- /dev/null
+++ b/devel/p5-Getopt-Compact-WithCmd/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-Getopt-Compact-WithCmd
+# Date created: 27 Feb 2012
+# Whom: Kan Sasaki <sasaki@fcc.ad.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getopt-Compact-WithCmd
+PORTVERSION= 0.19
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Sub-command friendly, like Getopt::Compact
+
+BUILD_DEPENDS= p5-Text-Table>=0:${PORTSDIR}/textproc/p5-Text-Table
+RUN_DEPENDS= p5-Text-Table>=0:${PORTSDIR}/textproc/p5-Text-Table
+
+TEST_DEPENDS= p5-Test-Output>=0:${PORTSDIR}/devel/p5-Test-Output \
+ p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
+
+PERL_CONFIGURE= yes
+
+MAN3= Getopt::Compact::WithCmd.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
+RUN_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
+.endif
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Getopt-Compact-WithCmd/distinfo b/devel/p5-Getopt-Compact-WithCmd/distinfo
new file mode 100644
index 000000000000..1bb87baeb031
--- /dev/null
+++ b/devel/p5-Getopt-Compact-WithCmd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Getopt-Compact-WithCmd-0.19.tar.gz) = a419510a488510c8a6c482383f9bee03306b53aa6143682b801ee5eeca5c8031
+SIZE (Getopt-Compact-WithCmd-0.19.tar.gz) = 37296
diff --git a/devel/p5-Getopt-Compact-WithCmd/pkg-descr b/devel/p5-Getopt-Compact-WithCmd/pkg-descr
new file mode 100644
index 000000000000..9c0bf9bb949f
--- /dev/null
+++ b/devel/p5-Getopt-Compact-WithCmd/pkg-descr
@@ -0,0 +1,4 @@
+Getopt::Compact::WithCmd is yet another Getopt::* module. It allows you to
+define git-like options. In addition, usage can be set at the same time.
+
+WWW: http://search.cpan.org/dist/Getopt-Compact-WithCmd/
diff --git a/devel/p5-Getopt-Compact-WithCmd/pkg-plist b/devel/p5-Getopt-Compact-WithCmd/pkg-plist
new file mode 100644
index 000000000000..daabf7d22cc1
--- /dev/null
+++ b/devel/p5-Getopt-Compact-WithCmd/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Getopt/Compact/WithCmd.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Compact/WithCmd/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Compact/WithCmd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Compact
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt
+@dirrmtry %%SITE_PERL%%/Getopt/Compact
+@dirrmtry %%SITE_PERL%%/Getopt