aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2001-06-22 22:16:31 +0000
committerDima Dorfman <dd@FreeBSD.org>2001-06-22 22:16:31 +0000
commit9516b65faac18e1b0a2813f7fa6774bec20ff60f (patch)
tree00867ec6c5fc083b093a32fdfa9083d54addaf74 /devel
parentd0b9cb18ec28662d7312d653fc99300700894676 (diff)
downloadports-9516b65faac18e1b0a2813f7fa6774bec20ff60f.tar.gz
ports-9516b65faac18e1b0a2813f7fa6774bec20ff60f.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/error/Makefile73
-rw-r--r--devel/error/distinfo1
-rw-r--r--devel/error/files/tarignore1
-rw-r--r--devel/error/pkg-comment1
-rw-r--r--devel/error/pkg-descr14
-rw-r--r--devel/error/pkg-plist1
7 files changed, 92 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5bfe04871972..751b779d792e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -103,6 +103,7 @@
SUBDIR += elib-emacs
SUBDIR += elib-emacs20
SUBDIR += entity
+ SUBDIR += error
SUBDIR += f77flow
SUBDIR += fam
SUBDIR += fampp
diff --git a/devel/error/Makefile b/devel/error/Makefile
new file mode 100644
index 000000000000..ca3e135cc378
--- /dev/null
+++ b/devel/error/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: error
+# Date created: 16 June 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= error
+PORTVERSION= 20010616
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www.unixfreak.org/~dima/distfiles/
+MASTER_SITE_SUBDIR= dd
+
+MAINTAINER= dd@FreeBSD.org
+
+MANSECTS= 1
+MAN1= error.1
+MANCOMPRESSED= maybe
+
+# MAN page COMPression SUFFIX
+.if !defined(NOMANCOMPRESS)
+MANCOMPSUFFIX= .gz
+.else
+MANCOMPSUFFIX=
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/error ${PREFIX}/bin/error
+.for __s in ${MANSECTS}
+.for __m in ${MAN${__s}:S/$/${MANCOMPSUFFIX}/}
+ @${INSTALL_MAN} ${WRKSRC}/${__m} ${PREFIX}/man/man${__s}/${__m}
+.endfor
+.endfor
+
+#
+# Ports build/install stuff stops here. Tarball creation stuff begins here.
+#
+.include <bsd.port.pre.mk>
+CVS_CMD?= cvs -z3
+CVS_DATE= Sun Jun 16 15:58:14 PDT 2001
+CVS_SITES?= anoncvs@anoncvs.openbsd.org:/cvs
+CVS_MODULE= src/usr.bin/error
+
+#
+# CVS checkout stuff mostly stolen from security/openssh-askpass port by
+# kris@freebsd.org
+#
+tarball:
+ @${MKDIR} ${DISTDIR}/${PKGNAME} && \
+ cd ${DISTDIR}/${PKGNAME}; \
+ for CVS_SITE in ${CVS_SITES}; do \
+ ${ECHO_MSG} ">> Attempting to check out from $${CVS_SITE}."; \
+ if ${CVS_CMD} -d $${CVS_SITE} co -D "${CVS_DATE}" \
+ ${CVS_MODULE}; then \
+ cd ${DISTDIR}; \
+ ${ECHO_MSG} ">> Creating dist tarball in ${DISTDIR}"; \
+ ${ECHO_MSG} ">> \"${PKGNAME}.tar.gz\"."; \
+ ${MV} ${PKGNAME}/${CVS_MODULE} \
+ ${PKGNAME}/${CVS_MODULE:H}/${PKGNAME}; \
+ ${TAR} -cz \
+ -X ${FILESDIR}/tarignore \
+ -f ${PKGNAME}.tar.gz \
+ -C ${PKGNAME}/${CVS_MODULE:H} \
+ ${PKGNAME}; \
+ exit; \
+ fi \
+ done; \
+ ${RMDIR} ${DISTDIR}/${PKGNAME}; \
+ ${ECHO_MSG} ">> CVS checkout failed."; \
+ exit 1;
+
+.include <bsd.port.post.mk>
diff --git a/devel/error/distinfo b/devel/error/distinfo
new file mode 100644
index 000000000000..73c515ad63a3
--- /dev/null
+++ b/devel/error/distinfo
@@ -0,0 +1 @@
+MD5 (error-20010616.tar.gz) = 13ba524981d469fd85593b8d61702c52
diff --git a/devel/error/files/tarignore b/devel/error/files/tarignore
new file mode 100644
index 000000000000..7ac83b287f2f
--- /dev/null
+++ b/devel/error/files/tarignore
@@ -0,0 +1 @@
+CVS
diff --git a/devel/error/pkg-comment b/devel/error/pkg-comment
new file mode 100644
index 000000000000..0e85dfa55422
--- /dev/null
+++ b/devel/error/pkg-comment
@@ -0,0 +1 @@
+Analyze diagnostic error output from compilers and other processors
diff --git a/devel/error/pkg-descr b/devel/error/pkg-descr
new file mode 100644
index 000000000000..0d836bbc9703
--- /dev/null
+++ b/devel/error/pkg-descr
@@ -0,0 +1,14 @@
+Error analyzes and optionally disperses the diagnostic error messages
+produced by a number of compilers and language processors to the
+source file and line where the errors occurred. It can replace the
+painful, traditional methods of scribbling abbreviations of errors on
+paper, and permits error messages and source code to be viewed
+simultaneously without machinations of multiple windows in a screen
+editor.
+
+Error knows about the error messages produced by: make(1), cc(1),
+cpp(1), ccom(1), as(1), ld(1), lint(1), pi(1), pc(1), f77(1), and DEC
+Western Research Modula-2. However, please note that error hasn't
+been taught about the toolchain currently in use on FreeBSD, so the
+aforementioned programs may not necessarily be the ones installed on
+your system!
diff --git a/devel/error/pkg-plist b/devel/error/pkg-plist
new file mode 100644
index 000000000000..14a58353c5d8
--- /dev/null
+++ b/devel/error/pkg-plist
@@ -0,0 +1 @@
+bin/error