aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-06-22 07:26:14 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-06-22 07:26:14 +0000
commitc0849c64b87d65f88239d07dc63550a0f619e619 (patch)
tree942a91d64d1e37d60a9ef6a9054edeb873d5f5e8 /devel
parent657ab0b207bb25e1f73b48f069cf4668e30b9ed7 (diff)
downloadports-c0849c64b87d65f88239d07dc63550a0f619e619.tar.gz
ports-c0849c64b87d65f88239d07dc63550a0f619e619.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-String-Similarity/Makefile22
-rw-r--r--devel/p5-String-Similarity/distinfo1
-rw-r--r--devel/p5-String-Similarity/pkg-comment1
-rw-r--r--devel/p5-String-Similarity/pkg-descr5
-rw-r--r--devel/p5-String-Similarity/pkg-plist7
6 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7a27ac6ce315..5bfe04871972 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -361,6 +361,7 @@
SUBDIR += p5-String-Checker
SUBDIR += p5-String-Random
SUBDIR += p5-String-RexxParse
+ SUBDIR += p5-String-Similarity
SUBDIR += p5-Term-ANSIColor
SUBDIR += p5-Term-Prompt
SUBDIR += p5-Term-Query
diff --git a/devel/p5-String-Similarity/Makefile b/devel/p5-String-Similarity/Makefile
new file mode 100644
index 000000000000..7e239c2a9f1b
--- /dev/null
+++ b/devel/p5-String-Similarity/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-String-Similarity
+# Date created: 22 June 2001
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Similarity
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kevlo@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= String::Similarity.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-String-Similarity/distinfo b/devel/p5-String-Similarity/distinfo
new file mode 100644
index 000000000000..830c8c6151f4
--- /dev/null
+++ b/devel/p5-String-Similarity/distinfo
@@ -0,0 +1 @@
+MD5 (String-Similarity-0.02.tar.gz) = 0fe22428831653557c304489e08d17ec
diff --git a/devel/p5-String-Similarity/pkg-comment b/devel/p5-String-Similarity/pkg-comment
new file mode 100644
index 000000000000..e2ca015f01e8
--- /dev/null
+++ b/devel/p5-String-Similarity/pkg-comment
@@ -0,0 +1 @@
+Perl module that calculates the similarity of two strings
diff --git a/devel/p5-String-Similarity/pkg-descr b/devel/p5-String-Similarity/pkg-descr
new file mode 100644
index 000000000000..d3957c278cb5
--- /dev/null
+++ b/devel/p5-String-Similarity/pkg-descr
@@ -0,0 +1,5 @@
+The "String::Similarity" calculates the similarity index of its two
+arguments. A value of '0' means that the strings are entirely
+different. A value of '1' means that the strings are identical.
+Everything else lies between 0 and 1 and describes the amount of
+similarity between the strings.
diff --git a/devel/p5-String-Similarity/pkg-plist b/devel/p5-String-Similarity/pkg-plist
new file mode 100644
index 000000000000..a3a703465f44
--- /dev/null
+++ b/devel/p5-String-Similarity/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/String/Similarity.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Similarity/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Similarity/Similarity.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Similarity/Similarity.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Similarity
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/String 2>/dev/null || true