aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-28 11:33:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-28 11:33:22 +0000
commit0a9d010bc6886673e8c70f5e746b55257d66a261 (patch)
treee2848ff29b05d80e402c87f038188eef316e115c /devel
parent2a4e8ea11a959cb564c093c4b9e72753b7e305c0 (diff)
downloadports-0a9d010bc6886673e8c70f5e746b55257d66a261.tar.gz
ports-0a9d010bc6886673e8c70f5e746b55257d66a261.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/obby/Makefile16
-rw-r--r--devel/obby/distinfo4
-rw-r--r--devel/obby/pkg-plist21
3 files changed, 21 insertions, 20 deletions
diff --git a/devel/obby/Makefile b/devel/obby/Makefile
index 59461cb333ca..f1872186aab8 100644
--- a/devel/obby/Makefile
+++ b/devel/obby/Makefile
@@ -6,22 +6,22 @@
#
PORTNAME= obby
-PORTVERSION= 0.4.7
-PORTREVISION= 1
+PORTVERSION= 0.4.8
CATEGORIES= devel
-MASTER_SITES= http://releases.0x539.de/obby/ \
- http://www.atarininja.org/~wxs/distfiles/
+MASTER_SITES= http://releases.0x539.de/obby/
MAINTAINER= ports@FreeBSD.org
COMMENT= A library for synced document buffers
+LICENSE= GPLv2
+
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
net6:${PORTSDIR}/net/net6
-MAKE_JOBS_SAFE= yes
+USE_GNOME= gnomehack
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-howl
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
.if !defined(WITHOUT_NLS)
CPPFLAGS+= -I${LOCALBASE}/include
@@ -33,8 +33,4 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} 's,^pkgconfigdir = .*,pkgconfigdir=$${prefix}/libdata/pkgconfig,' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.mk>
diff --git a/devel/obby/distinfo b/devel/obby/distinfo
index c8e7ed5a2bcc..00687c610d59 100644
--- a/devel/obby/distinfo
+++ b/devel/obby/distinfo
@@ -1,2 +1,2 @@
-SHA256 (obby-0.4.7.tar.gz) = 2c22668f6915e10e04dabb5f7724e16aea4e1a4166e6e6dd1605bccb5585c1a6
-SIZE (obby-0.4.7.tar.gz) = 511541
+SHA256 (obby-0.4.8.tar.gz) = 7d1d7ba6e800cea1b1a3c47d1189f959ef49a647ebe77170351e2dfd27b89b67
+SIZE (obby-0.4.8.tar.gz) = 530525
diff --git a/devel/obby/pkg-plist b/devel/obby/pkg-plist
index e142a1051a6f..d8fe194ead34 100644
--- a/devel/obby/pkg-plist
+++ b/devel/obby/pkg-plist
@@ -1,6 +1,6 @@
include/obby/buffer.hpp
-include/obby/client_buffer.hpp
include/obby/chat.hpp
+include/obby/client_buffer.hpp
include/obby/client_document_info.hpp
include/obby/colour.hpp
include/obby/command.hpp
@@ -28,6 +28,11 @@ include/obby/position.hpp
include/obby/ptr_iterator.hpp
include/obby/record.hpp
include/obby/ring.hpp
+include/obby/serialise/attribute.hpp
+include/obby/serialise/error.hpp
+include/obby/serialise/object.hpp
+include/obby/serialise/parser.hpp
+include/obby/serialise/token.hpp
include/obby/server_buffer.hpp
include/obby/server_document_info.hpp
include/obby/split_operation.hpp
@@ -35,26 +40,26 @@ include/obby/text.hpp
include/obby/user.hpp
include/obby/user_table.hpp
include/obby/vector_time.hpp
-include/obby/serialise/attribute.hpp
-include/obby/serialise/error.hpp
-include/obby/serialise/object.hpp
-include/obby/serialise/parser.hpp
-include/obby/serialise/token.hpp
lib/libobby-0.4.so
lib/libobby-0.4.so.1
lib/libobby.a
lib/libobby.la
lib/libobby.so
libdata/pkgconfig/obby-0.4.pc
+%%NLS%%share/locale/ast/LC_MESSAGES/obby.mo
%%NLS%%share/locale/ca/LC_MESSAGES/obby.mo
+%%NLS%%share/locale/da/LC_MESSAGES/obby.mo
%%NLS%%share/locale/de/LC_MESSAGES/obby.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/obby.mo
%%NLS%%share/locale/es/LC_MESSAGES/obby.mo
%%NLS%%share/locale/fr/LC_MESSAGES/obby.mo
%%NLS%%share/locale/it/LC_MESSAGES/obby.mo
%%NLS%%share/locale/nl/LC_MESSAGES/obby.mo
%%NLS%%share/locale/oc/LC_MESSAGES/obby.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/obby.mo
%%NLS%%share/locale/sv/LC_MESSAGES/obby.mo
-%%NLS%%@dirrm share/locale/oc/LC_MESSAGES
-%%NLS%%@dirrm share/locale/oc
+%%NLS%%share/locale/uk/LC_MESSAGES/obby.mo
+%%NLS%%@dirrmtry share/locale/oc/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/oc
@dirrm include/obby/serialise
@dirrm include/obby