aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-05-16 04:00:55 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-05-16 04:00:55 +0000
commit71cd6682c1110d9f03a84fcfc3f0367354077698 (patch)
treebc5b1a96a6a894279ee6b404ab9360fe5c4235ba /devel
parente84a5962aec32f92f1b02603e31d832a892462e4 (diff)
downloadports-71cd6682c1110d9f03a84fcfc3f0367354077698.tar.gz
ports-71cd6682c1110d9f03a84fcfc3f0367354077698.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cscope/Makefile69
-rw-r--r--devel/cscope/distinfo2
-rw-r--r--devel/cscope/pkg-descr15
3 files changed, 16 insertions, 70 deletions
diff --git a/devel/cscope/Makefile b/devel/cscope/Makefile
index bb5bdc47e557..ad110c2187ca 100644
--- a/devel/cscope/Makefile
+++ b/devel/cscope/Makefile
@@ -1,3 +1,4 @@
+# ex:ts=8
# ports collection makefile for: cscope
# Date created: 1998-11-21
# Whom: Castor Fu
@@ -6,68 +7,16 @@
#
PORTNAME= cscope
-PORTVERSION= 13.7
+PORTVERSION= 15.0.bl2
CATEGORIES= devel
+MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/cscope/ \
+ http://download.sourceforge.net/cscope/
+DISTNAME= ${PORTNAME}-15.0bl2
-MAINTAINER= castor@alumni.caltech.edu
+MAINTAINER= obrien@FreeBSD.org
-NO_WRKSUBDIR=yes
-NO_CHECKSUM=yes
-NO_PACKAGE="Redistribution license from Lucent Technologies required."
-RESTRICTED="Redistribution license from Lucent Technologies required."
-MAKEFILE=makefile
-
-# Location of the Cscope sources as distributed on Toolchest disk
-CDROMDIR=/cdrom/cscope
-TESTFILE=cscope.1
-
-MAN1= cscope.1
-
-TRUNCATED_NAMES=fixkeypad.c constants.h
-
-do-fetch:
- @${DO_NADA}
-
-#
-# Introduce the ability to get things from a fixed distribution filesystem.
-#
-pre-extract:
- @${MKDIR} ${_DISTDIR}
- @(cd ${_DISTDIR}; \
- for file in ${DISTFILES}; do \
- if [ ! -f $$file -a ! -f `${BASENAME} $$file` ]; then \
- if [ -h $$file -o -h `${BASENAME} $$file` ]; then \
- ${ECHO_MSG} ">> ${_DISTDIR}/$$file is a broken symlink."; \
- ${ECHO_MSG} ">> Perhaps a filesystem (most likely a CD) isn't mounted?"; \
- ${ECHO_MSG} ">> Please correct this problem and try again."; \
- exit 1; \
- fi ; \
- ${ECHO_MSG} ">> $$file doesn't seem to exist on this system."; \
- if [ ! -d ${CDROMDIR} -a ! -f ${CDROMDIR}/${TESTFILE} ] ; then \
- ${ECHO_MSG} ">> ${CDROMDIR}/${TESTFILE} not found. Perhaps the AT&T CD isn't mounted?"; \
- ${ECHO_MSG} ">> See <http://www.lucent.com/ssg/html/toolchest.html>."; \
- exit 1; \
- else \
- (cd ${CDROMDIR}; tar czf ${_DISTDIR}/$$file .); \
- fi; \
- fi \
- done)
-
-#
-# Get rid of any <CR>'s in the files and expand out file names which may have been truncated.
-#
-
-post-extract:
- @(${CHMOD} +w ${WRKSRC})
- @(for file in ${WRKSRC}/* ; do ${TR} -d '\015' < $$file > $$file.x ; ${MV} -f $$file.x $$file ; done)
- @(for file in ${TRUNCATED_NAMES} ; do \
- x=`${ECHO} $$file | ${SED} -e 's/^\(......\).*/\1/'` ; \
- y=$${file#*.} ; \
- ${MV} ${WRKSRC}/$${x}*.$${y} ${WRKSRC}/$$file; \
- done)
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cscope ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/cscope.1 ${PREFIX}/man/man1
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+GNU_CONFIGURE= yes
+MAN1= cscope.1
.include <bsd.port.mk>
diff --git a/devel/cscope/distinfo b/devel/cscope/distinfo
index 7fe78ca904df..b6e5438e4922 100644
--- a/devel/cscope/distinfo
+++ b/devel/cscope/distinfo
@@ -1 +1 @@
-MD5 (cscope-13.7.tar.gz) = 615fc7ca93c52cf5ecccd9ebff92e4c6
+MD5 (cscope-15.0bl2.tar.gz) = dff40f905bb8709fb6a2ec4365b0bbcc
diff --git a/devel/cscope/pkg-descr b/devel/cscope/pkg-descr
index d166544d553e..a1f25f33fe87 100644
--- a/devel/cscope/pkg-descr
+++ b/devel/cscope/pkg-descr
@@ -1,11 +1,8 @@
-This port of Lucent Technologies 'cscope' from the Software Toolchest
-Volume II lets one easily navigate large C programs. It's designed
-to answer questions like where symbols are defined and used, and where
-variables are assigned.
+This port of SCO / USL's 'cscope' lets one easily navigate large C programs.
+It's designed to answer questions like where symbols are defined and used,
+and where variables are assigned.
-A source site license is available for approximately US$500 from distributors
-such as Unipress Software, <http://www.unipress.com/att>, or directly
-from Lucent, <http://www.lucent.com/ssg/html/toolchest.html>.
+The Santa Cruz Operation (SCO) has made this available under a very friendly,
+BSD-style Open Source License.
- -castor fu
- castor@alumni.caltech.edu
+WWW: http://cscope.sourceforge.net/