aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-04-27 08:50:46 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-04-27 08:50:46 +0000
commit821843ca06f2354ffe250825fcdffabb6d0caefa (patch)
tree5b8de344e457d5da2cf746d56e495a2ce03e1d99 /devel
parent89d548370ac959aac24d63bd8ab8e32723ecf53d (diff)
downloadports-821843ca06f2354ffe250825fcdffabb6d0caefa.tar.gz
ports-821843ca06f2354ffe250825fcdffabb6d0caefa.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/apr1/Makefile2
-rw-r--r--devel/apr2/Makefile2
-rw-r--r--devel/automoc4/Makefile3
-rw-r--r--devel/boost-libs/Makefile2
-rw-r--r--devel/cgit/Makefile2
-rw-r--r--devel/cxxtools/Makefile2
-rw-r--r--devel/doxygen/Makefile3
-rw-r--r--devel/ecore-main/Makefile3
-rw-r--r--devel/eina/Makefile3
-rw-r--r--devel/gdb/Makefile2
-rw-r--r--devel/gdb66/Makefile3
-rw-r--r--devel/gettext/Makefile3
-rw-r--r--devel/git/Makefile2
-rw-r--r--devel/glib20/Makefile3
-rw-r--r--devel/gnome-vfs1/Makefile7
-rw-r--r--devel/hs-haskeline/Makefile2
-rw-r--r--devel/hwloc/Makefile5
-rw-r--r--devel/ice/Makefile2
-rw-r--r--devel/libconfuse/Makefile3
-rw-r--r--devel/libdatrie/Makefile3
-rw-r--r--devel/libevt/Makefile3
-rw-r--r--devel/libevtx/Makefile3
-rw-r--r--devel/libewf/Makefile3
-rw-r--r--devel/libhtp/Makefile3
-rw-r--r--devel/libisofs/Makefile2
-rw-r--r--devel/liblnk/Makefile3
-rw-r--r--devel/libmsiecf/Makefile3
-rw-r--r--devel/libpff/Makefile3
-rw-r--r--devel/libplist/Makefile3
-rw-r--r--devel/librcc/Makefile4
-rw-r--r--devel/libregf/Makefile3
-rw-r--r--devel/libslang2/Makefile2
-rw-r--r--devel/libunistring/Makefile3
-rw-r--r--devel/libvshadow/Makefile3
-rw-r--r--devel/mingw32-binutils/Makefile2
-rw-r--r--devel/mingw32-gcc/Makefile3
-rw-r--r--devel/monotone/Makefile4
-rw-r--r--devel/motor/Makefile2
-rw-r--r--devel/msp430-gcc/Makefile3
-rw-r--r--devel/objectivelib/Makefile2
-rw-r--r--devel/popt/Makefile3
-rw-r--r--devel/py-fusefs/Makefile3
-rw-r--r--devel/sdl12/Makefile3
-rw-r--r--devel/sdl20/Makefile3
-rw-r--r--devel/stfl/Makefile2
-rw-r--r--devel/styx/Makefile2
-rw-r--r--devel/tig/Makefile2
-rw-r--r--devel/xdg-user-dirs/Makefile3
-rw-r--r--devel/yasm/Makefile3
49 files changed, 54 insertions, 84 deletions
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 3937ac360c0e..80dd392f78ce 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -34,7 +34,7 @@ NSS_DESC= NSS crypto driver
APR_VERSION= 1.4.6
APU_VERSION= 1.4.1
-USE_ICONV= yes
+USES= iconv
USE_AUTOTOOLS= automake autoconf libtool:env
USE_PYTHON_BUILD= -2.7
USE_LDCONFIG= yes
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 7f3cc399fc0c..df49e8a92d80 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -32,7 +32,7 @@ DEVELOPER_ONLY_DESC= I want to test apr2 not the maintainer
.include <bsd.port.options.mk>
-USE_ICONV= yes
+USES= iconv
USE_AUTOTOOLS= automake autoconf libtool:env
USE_PERL5_BUILD= yes
USE_PYTHON_BUILD= -2.7
diff --git a/devel/automoc4/Makefile b/devel/automoc4/Makefile
index f85c3e70565a..bbd896227d3b 100644
--- a/devel/automoc4/Makefile
+++ b/devel/automoc4/Makefile
@@ -15,10 +15,9 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Automatic moc for Qt 4 packages
-USE_ICONV= yes
USE_QT4= corelib moc qmake_build rcc_build uic_build
USE_BZIP2= yes
-USES= cmake
+USES= cmake iconv
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index da9de87a977f..129d0211ef6e 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -24,7 +24,7 @@ BJAM_ARGS+= --without-python
LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
BJAM_ARGS+= -sICU_PATH=${LOCALBASE}
.else
-USE_ICONV= yes
+USES+= iconv
BJAM_ARGS+= -sICONV_PATH=${LOCALBASE}
.endif
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index 376bf42c9d79..8414a0b2ed68 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
GIT_VERSION= 1.7.4.4
USE_BZIP2= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_GMAKE= yes
USE_OPENSSL= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index 6e00646d3329..d5633173a76c 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= nox@FreeBSD.org
COMMENT= Collection of general-purpose C++ classes
PATCH_STRIP= -p1
-USE_ICONV= yes
+USES= iconv
USE_CSTD= gnu89
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index c9b1b282b889..71e613dda5fa 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -18,8 +18,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-USES= bison
-USE_ICONV= yes
+USES= bison iconv
ALL_TARGET= all
USE_PERL5= yes
HAS_CONFIGURE= yes
diff --git a/devel/ecore-main/Makefile b/devel/ecore-main/Makefile
index e7e4b7e84aa9..8e19fffd466f 100644
--- a/devel/ecore-main/Makefile
+++ b/devel/ecore-main/Makefile
@@ -17,9 +17,8 @@ LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig iconv
USE_EFL= eina libtool_hack
-USE_ICONV= yes
USE_LDCONFIG= yes
EXAMPLESDIR= ${PREFIX}/share/examples/ecore
diff --git a/devel/eina/Makefile b/devel/eina/Makefile
index 9d17d10686c9..01169b7d7d22 100644
--- a/devel/eina/Makefile
+++ b/devel/eina/Makefile
@@ -15,9 +15,8 @@ LICENSE= LGPL21
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= pathfix
+USES= pathfix iconv
USE_EFL= librt_hack libtool_hack
-USE_ICONV= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-amalgamation
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 644f01f87843..952048823691 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv3
USE_BZIP2= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
CONFIGURE_ENV= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index d031a2b22386..d0a89d6e64f6 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -29,8 +29,7 @@ MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
USE_GCC= any
USE_GMAKE= yes
-USES= gettext
-USE_ICONV= yes
+USES= gettext iconv
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 19620880798b..a5b74419ad1b 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= gettext
MAINTAINER= autotools@FreeBSD.org
COMMENT= GNU gettext package
-USES= charsetfix
-USE_ICONV= yes
+USES= charsetfix iconv
LIBTOOLFILES= gettext-runtime/configure \
gettext-runtime/libasprintf/configure gettext-tools/configure
USE_AUTOTOOLS= libtool
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 2edd49b288ff..b118c559a1b5 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -259,7 +259,7 @@ PLIST_SUB+= PERLSUB="@comment "
.endif
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
MAKE_ENV+= NEEDS_LIBICONV=yes \
ICONVDIR=${LOCALBASE}
CONFIGURE_ARGS+= --with-iconv=${LOCALBASE}
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 8cde0a8189f0..e350b14c0ed6 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -24,10 +24,9 @@ PORTSCOUT= limitw:1,even
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre \
ffi:${PORTSDIR}/devel/libffi
-USE_ICONV= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USES= pkgconfig gettext
+USES= pkgconfig gettext iconv
USE_GNOME= gnomehack ltverhack
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index 655559bab403..417e8d9141a2 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -16,12 +16,11 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME Virtual File System
-USE_ICONV= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix glib12 libxml gtk12 orbit gconf \
- gnomemimedata gnomelibs
-USES= gettext
+USE_GNOME= gnomeprefix glib12 libxml gtk12 orbit gconf gnomemimedata \
+ gnomelibs
+USES= gettext iconv pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
diff --git a/devel/hs-haskeline/Makefile b/devel/hs-haskeline/Makefile
index 446d041c085d..ba84c2507d6b 100644
--- a/devel/hs-haskeline/Makefile
+++ b/devel/hs-haskeline/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD
CABAL_SETUP= Setup.hs
USE_CABAL= transformers>=0.2
-USE_ICONV= yes
+USES+= iconv
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hwloc/Makefile b/devel/hwloc/Makefile
index 851d22e0496b..c89caa3e8749 100644
--- a/devel/hwloc/Makefile
+++ b/devel/hwloc/Makefile
@@ -17,11 +17,10 @@ LIB_DEPENDS= pciaccess:${PORTSDIR}/devel/libpciaccess
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-static \
--enable-libxml2
-USES= pkgconfig
+USES= pkgconfig pathfix iconv
USE_BZIP2= yes
-USE_ICONV= yes
USE_LDCONFIG= yes
-USE_GNOME= libxml2 gnomehack
+USE_GNOME= libxml2
MAKE_JOBS_SAFE= yes
PORTDOCS= *
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 92035bcfc787..295abb69a014 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -25,7 +25,7 @@ USE_PYTHON_BUILD= yes
.endif
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_BDB= 42+
INVALID_BDB_VER= 2 3 40 41
USE_LDCONFIG= yes
diff --git a/devel/libconfuse/Makefile b/devel/libconfuse/Makefile
index d94ea12ddde5..107d5e778426 100644
--- a/devel/libconfuse/Makefile
+++ b/devel/libconfuse/Makefile
@@ -19,10 +19,9 @@ COMMENT= Configuration file parsing library
LIB_DEPENDS+= ${LOCALBASE}/lib/libcheck.a:${PORTSDIR}/devel/libcheck
.endif
-USE_ICONV= yes
+USES= iconv pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig
CONFIGURE_ARGS+= --disable-nls
CFLAGS+= -I${WRKSRC}/src
.if defined(WITH_CHECK)
diff --git a/devel/libdatrie/Makefile b/devel/libdatrie/Makefile
index ef2f8d1294f0..2b63f06856d8 100644
--- a/devel/libdatrie/Makefile
+++ b/devel/libdatrie/Makefile
@@ -13,8 +13,7 @@ LICENSE= LGPL21
USE_XZ= yes
GNU_CONFIGURE= yes
-USES= pathfix
-USE_ICONV= yes
+USES= iconv pathfix
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/libevt/Makefile b/devel/libevt/Makefile
index e8ae473dbc4c..073876e119ed 100644
--- a/devel/libevt/Makefile
+++ b/devel/libevt/Makefile
@@ -13,8 +13,7 @@ LICENSE= LGPL3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python
-USES= pathfix gettext
-USE_ICONV= yes
+USES= pathfix gettext iconv
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/devel/libevtx/Makefile b/devel/libevtx/Makefile
index 0882d17cbeb9..6d13ff97dfba 100644
--- a/devel/libevtx/Makefile
+++ b/devel/libevtx/Makefile
@@ -13,8 +13,7 @@ LICENSE= LGPL3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python
-USES= pathfix gettext
-USE_ICONV= yes
+USES= pathfix gettext iconv
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/devel/libewf/Makefile b/devel/libewf/Makefile
index 55465f27a8f7..62d09e94fdac 100644
--- a/devel/libewf/Makefile
+++ b/devel/libewf/Makefile
@@ -14,8 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
-USES= fuse pathfix gettext
-USE_ICONV= yes
+USES= fuse pathfix gettext iconv
USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_PYTHON= yes
diff --git a/devel/libhtp/Makefile b/devel/libhtp/Makefile
index 2a9aa909ea7c..dff6c82ebf33 100644
--- a/devel/libhtp/Makefile
+++ b/devel/libhtp/Makefile
@@ -16,8 +16,7 @@ GH_COMMIT= a334539
USE_AUTOTOOLS= libtool autoheader aclocal
ACLOCAL_ARGS= -Im4
USE_LDCONFIG= yes
-USE_GNOME= pkgconfig gnomehack
-USE_ICONV= yes
+USES= pkgconfig pathfix iconv
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
diff --git a/devel/libisofs/Makefile b/devel/libisofs/Makefile
index 3fd576fff217..d08b829a7d9e 100644
--- a/devel/libisofs/Makefile
+++ b/devel/libisofs/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= burn.4:${PORTSDIR}/devel/libburn
GNU_CONFIGURE= yes
-USE_ICONV= yes
+USES= iconv
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/devel/liblnk/Makefile b/devel/liblnk/Makefile
index b83ce1762af1..3c09a876482e 100644
--- a/devel/liblnk/Makefile
+++ b/devel/liblnk/Makefile
@@ -14,8 +14,7 @@ LICENSE= LGPL3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python
-USES= pathfix gettext
-USE_ICONV= yes
+USES= pathfix gettext iconv
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/devel/libmsiecf/Makefile b/devel/libmsiecf/Makefile
index 7c83fecd4252..b0f8f2b5c112 100644
--- a/devel/libmsiecf/Makefile
+++ b/devel/libmsiecf/Makefile
@@ -13,8 +13,7 @@ LICENSE= LGPL3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python
-USES= pathfix gettext
-USE_ICONV= yes
+USES= pathfix gettext iconv
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/devel/libpff/Makefile b/devel/libpff/Makefile
index 60787e53e015..75ca3f44682c 100644
--- a/devel/libpff/Makefile
+++ b/devel/libpff/Makefile
@@ -13,8 +13,7 @@ LICENSE= LGPL3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python
-USES= pathfix gettext
-USE_ICONV= yes
+USES= pathfix gettext iconv
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/devel/libplist/Makefile b/devel/libplist/Makefile
index 8bc891e60903..cfa06420b9c1 100644
--- a/devel/libplist/Makefile
+++ b/devel/libplist/Makefile
@@ -12,9 +12,8 @@ LICENSE= LGPL21
USE_GNOME= libxml2
# Unlisted dependency.
-USE_ICONV= yes
USE_BZIP2= yes
-USES= cmake
+USES= cmake iconv
# Required for iconv headers.
CFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/librcc/Makefile b/devel/librcc/Makefile
index 47e5d355abfd..32f9966d05bf 100644
--- a/devel/librcc/Makefile
+++ b/devel/librcc/Makefile
@@ -24,9 +24,9 @@ LIB_DEPENDS= rcd.1:${PORTSDIR}/devel/librcd \
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack lthack libxml2
+USE_GNOME= lthack libxml2
USE_GMAKE= yes
-USE_ICONV= yes
+USES= pathfix iconv
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoheader
diff --git a/devel/libregf/Makefile b/devel/libregf/Makefile
index c69f86c380c4..73f66dee78dc 100644
--- a/devel/libregf/Makefile
+++ b/devel/libregf/Makefile
@@ -13,8 +13,7 @@ LICENSE= LGPL3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python
-USES= fuse pathfix gettext
-USE_ICONV= yes
+USES= fuse pathfix gettext iconv
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/devel/libslang2/Makefile b/devel/libslang2/Makefile
index 36b21448c1b9..35291f96c2fb 100644
--- a/devel/libslang2/Makefile
+++ b/devel/libslang2/Makefile
@@ -55,7 +55,7 @@ PLIST_SUB+= PNG="@comment "
.endif
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
PLIST_SUB+= ICONV=""
.else
CONFIGURE_ARGS+= --without-iconv
diff --git a/devel/libunistring/Makefile b/devel/libunistring/Makefile
index da140351dc68..5d7bb83f50b1 100644
--- a/devel/libunistring/Makefile
+++ b/devel/libunistring/Makefile
@@ -14,9 +14,8 @@ LICENSE_COMB= dual
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LIB
-USES= charsetfix
+USES= charsetfix iconv
USE_GMAKE= yes
-USE_ICONV= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INFO= ${PORTNAME}
diff --git a/devel/libvshadow/Makefile b/devel/libvshadow/Makefile
index 6c29c77ad220..cbe5e04bc9d7 100644
--- a/devel/libvshadow/Makefile
+++ b/devel/libvshadow/Makefile
@@ -13,8 +13,7 @@ COMMENT= A library to support the Volume Service Snapshot (VSS) format
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= fuse pathfix gettext
-USE_ICONV= yes
+USES= fuse pathfix gettext iconv
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/devel/mingw32-binutils/Makefile b/devel/mingw32-binutils/Makefile
index 5503d4be98ad..78587178cb0e 100644
--- a/devel/mingw32-binutils/Makefile
+++ b/devel/mingw32-binutils/Makefile
@@ -17,7 +17,7 @@ BINUTILVERSION= 2.23.1
USE_BZIP2= yes
USE_GCC= any
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=${PKGNAMEPREFIX:S/-$//} \
--with-gcc --with-gnu-ld --with-gnu-as \
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index 35c3917ed899..c06acc8a4bf0 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -22,10 +22,9 @@ GCCVERSION= 4.7.2
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
USE_LDCONFIG= yes
-USES= bison
+USES= bison iconv
USE_BZIP2= yes
USE_GMAKE= yes
-USE_ICONV= yes
USE_PERL5_BUILD= yes
MAKE_JOBS_SAFE= yes
diff --git a/devel/monotone/Makefile b/devel/monotone/Makefile
index a8c6dffe9362..f962ce6a59b5 100644
--- a/devel/monotone/Makefile
+++ b/devel/monotone/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
SUB_FILES= pkg-message
USE_BZIP2= yes
USE_PERL5_BUILD=yes
-USE_ICONV= yes
+USES= iconv
USE_GMAKE= yes
USE_LUA= 5.1+
@@ -64,7 +64,7 @@ USE_GCC= 4.2+
.endif
.if ${PORT_OPTIONS:MNLS}
-USES= gettext
+USES+= gettext
PLIST_FILES+= share/locale/de/LC_MESSAGES/monotone.mo \
share/locale/fr/LC_MESSAGES/monotone.mo \
share/locale/it/LC_MESSAGES/monotone.mo \
diff --git a/devel/motor/Makefile b/devel/motor/Makefile
index 5a5b3dd9cfc0..25314a6aa3bb 100644
--- a/devel/motor/Makefile
+++ b/devel/motor/Makefile
@@ -16,7 +16,7 @@ COMMENT= A powerful text mode based programming IDE
USE_BZIP2= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
.if !defined(WITHOUT_NLS)
diff --git a/devel/msp430-gcc/Makefile b/devel/msp430-gcc/Makefile
index c3bdf43eafea..d1bead368e78 100644
--- a/devel/msp430-gcc/Makefile
+++ b/devel/msp430-gcc/Makefile
@@ -47,8 +47,7 @@ PATCH_WRKSRC= ${SRCDIR}
USE_BZIP2= yes
USE_GMAKE= yes
-USES= bison
-USE_ICONV= yes
+USES= bison iconv
USE_PERL5_BUILD=yes
MAKE_JOBS_SAFE= yes
diff --git a/devel/objectivelib/Makefile b/devel/objectivelib/Makefile
index 80e042fbac87..b2d1e469f4d3 100644
--- a/devel/objectivelib/Makefile
+++ b/devel/objectivelib/Makefile
@@ -16,7 +16,7 @@ USE_GNUSTEP_CONFIGURE= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
-USE_ICONV= yes
+USES= iconv
WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
diff --git a/devel/popt/Makefile b/devel/popt/Makefile
index e6282f454703..fa57e4927f4a 100644
--- a/devel/popt/Makefile
+++ b/devel/popt/Makefile
@@ -19,8 +19,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-USES= pathfix
-USE_ICONV= yes
+USES= pathfix iconv
USE_LDCONFIG= yes
MAN3= popt.3
diff --git a/devel/py-fusefs/Makefile b/devel/py-fusefs/Makefile
index 5ccd55e78de9..894449307cbd 100644
--- a/devel/py-fusefs/Makefile
+++ b/devel/py-fusefs/Makefile
@@ -11,10 +11,9 @@ DISTNAME= fuse-python-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= FUSE Python bindings
-USES= fuse pkgconfig
+USES= fuse pkgconfig iconv
USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
-USE_ICONV= yes
PORTDOCS= AUTHORS Changelog FAQ INSTALL README.1st README.historic \
README.new_fusepy_api
PORTEXAMPLES= _find_fuse_parts.py hello.py xmp.py
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 7abf7504af1d..dffe5c1a6240 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -23,8 +23,7 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
-USE_GNOME= gnomehack pkgconfig
-USE_ICONV= yes
+USES= pathfix pkgconfig iconv
CONFIGURE_ENV= ac_cv_header_libusbhid_h=no
CFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/sdl20/Makefile b/devel/sdl20/Makefile
index fd25ea464afc..3ca1bd2bb5b9 100644
--- a/devel/sdl20/Makefile
+++ b/devel/sdl20/Makefile
@@ -9,8 +9,7 @@ DISTNAME= SDL-2.0.0-7046
MAINTAINER= mva@FreeBSD.org
COMMENT= Cross-platform multimedia development API
-USES= pathfix cmake:outsource
-USE_ICONV= yes
+USES= pathfix cmake:outsource iconv
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/devel/stfl/Makefile b/devel/stfl/Makefile
index 78e7c1076c88..dc86dc1aa401 100644
--- a/devel/stfl/Makefile
+++ b/devel/stfl/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_NCURSES= yes
MAKE_JOBS_SAFE= yes
ALL_TARGET= libstfl.so
diff --git a/devel/styx/Makefile b/devel/styx/Makefile
index 0a05a86ca36f..3e97bf4a9329 100644
--- a/devel/styx/Makefile
+++ b/devel/styx/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A scanner/parser generator
USE_AUTOTOOLS= libtool
-USE_ICONV= yes
+USES= iconv
USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/tig/Makefile b/devel/tig/Makefile
index 9a88d9927738..fe8b5681a7d9 100644
--- a/devel/tig/Makefile
+++ b/devel/tig/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
PLIST_FILES= bin/tig
diff --git a/devel/xdg-user-dirs/Makefile b/devel/xdg-user-dirs/Makefile
index f652febaf789..3bbdf2c7234f 100644
--- a/devel/xdg-user-dirs/Makefile
+++ b/devel/xdg-user-dirs/Makefile
@@ -14,8 +14,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Tool to help manage personal user directories
GNU_CONFIGURE= yes
-USES= gettext
-USE_ICONV= yes
+USES= gettext iconv
USE_GMAKE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/yasm/Makefile b/devel/yasm/Makefile
index e38321bc80f7..1f588b2f2923 100644
--- a/devel/yasm/Makefile
+++ b/devel/yasm/Makefile
@@ -27,8 +27,7 @@ CFLAGS:= ${CFLAGS:C/-O[0-9]//g}
.endif
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-USE_ICONV= yes
+USES+= gettext iconv
.else
CONFIGURE_ARGS+=--disable-nls --without-libiconv-prefix --without-libintl-prefix
.endif