aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-02-25 03:13:11 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-02-25 03:13:11 +0000
commitb2da0c288352f7c512c83067107ca39a8a841564 (patch)
tree4784b2103d09df0e17638660c4f891099ed0f93a /devel
parent83dc615256644f23276eaff158405ca9a25937d2 (diff)
downloadports-b2da0c288352f7c512c83067107ca39a8a841564.tar.gz
ports-b2da0c288352f7c512c83067107ca39a8a841564.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cvsgraph/Makefile15
-rw-r--r--devel/cvsgraph/distinfo2
-rw-r--r--devel/cvsgraph/files/patch-Makefile13
-rw-r--r--devel/cvsgraph/files/patch-configure.in36
-rw-r--r--devel/cvsgraph/files/patch-cvsgraph.c11
-rw-r--r--devel/cvsgraph/pkg-descr3
6 files changed, 50 insertions, 30 deletions
diff --git a/devel/cvsgraph/Makefile b/devel/cvsgraph/Makefile
index 1798b239670e..61b90c19e0ee 100644
--- a/devel/cvsgraph/Makefile
+++ b/devel/cvsgraph/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cvsgraph
-PORTVERSION= 1.0.0
+PORTVERSION= 1.0.1
CATEGORIES= devel graphics
MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/
@@ -19,8 +19,19 @@ LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
ALL_TARGET= cvsgraph
DOCDIR= share/doc/${PORTNAME}
-DOCS= LICENCE README
+DOCS= ChangeLog LICENCE README
PLIST= ${WRKDIR}/pkg-plist
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gd=${LOCALBASE} \
+ --with-png=${LOCALBASE} \
+ --with-z=/usr
+
+post-configure:
+ ${PERL} -pi -e \
+ "s|CFLAGS =|CFLAGS += -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/gd|g" \
+ ${WRKSRC}/Makefile
pre-install:
${ECHO} bin/cvsgraph > ${PLIST}
diff --git a/devel/cvsgraph/distinfo b/devel/cvsgraph/distinfo
index fcd1d85fb370..1812015431d2 100644
--- a/devel/cvsgraph/distinfo
+++ b/devel/cvsgraph/distinfo
@@ -1 +1 @@
-MD5 (cvsgraph-1.0.0.tar.gz) = 4ace6080169cda17023107e46807bab7
+MD5 (cvsgraph-1.0.1.tar.gz) = 6e531971d73a8f9a9956079a315c8ebe
diff --git a/devel/cvsgraph/files/patch-Makefile b/devel/cvsgraph/files/patch-Makefile
deleted file mode 100644
index 5829d737e56e..000000000000
--- a/devel/cvsgraph/files/patch-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig Mon Feb 19 11:31:12 2001
-+++ Makefile Wed Feb 21 00:01:17 2001
-@@ -9,8 +9,8 @@
-
- # Be carefull editing these settings
- DEBUG = -g
--LIBS = -lgd
--CFLAGS = -Wall $(DEBUG) -O2 -DETCDIR=\"$(ETCDIR)\"
-+LIBS = -L${LOCALBASE}/lib -lgd
-+CFLAGS += -I${LOCALBASE}/include -I${LOCALBASE}/include/gd -DETCDIR=\"$(ETCDIR)\"
-
- # Everything below here should be alright
- TARGET = cvsgraph
diff --git a/devel/cvsgraph/files/patch-configure.in b/devel/cvsgraph/files/patch-configure.in
new file mode 100644
index 000000000000..607b749def2b
--- /dev/null
+++ b/devel/cvsgraph/files/patch-configure.in
@@ -0,0 +1,36 @@
+--- configure.in.orig Fri Feb 23 14:53:13 2001
++++ configure.in Sat Feb 24 18:58:31 2001
+@@ -11,18 +11,18 @@
+
+ dnl Extra libraries 'with'-options
+ AC_ARG_WITH(gd,[ --with-gd=DIR location of the gd lib/inc],
+- [LDFLAGS="${LDFLAGS} -L${withval}"
+- CFLAGS="${CFLAGS} -I${withval}"
++ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
++ CFLAGS="${CFLAGS} -I${withval}/include/gd"
+ ])
+
+ AC_ARG_WITH(z,[ --with-z=DIR location of zlib lib/inc],
+- [LDFLAGS="${LDFLAGS} -L${withval}"
+- CFLAGS="${CFLAGS} -I${withval}"
++ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
++ CFLAGS="${CFLAGS} -I${withval}/include"
+ ])
+
+ AC_ARG_WITH(png,[ --with-png=DIR location of png lib/inc],
+- [LDFLAGS="${LDFLAGS} -L${withval}"
+- CFLAGS="${CFLAGS} -I${withval}"
++ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
++ CFLAGS="${CFLAGS} -I${withval}/include"
+ ])
+
+ LDFLAGS="${LDFLAGS} -lgd"
+@@ -73,7 +73,7 @@
+ dnl Make sure the header is here
+ AC_CHECK_HEADER( gd.h,[ have_gd_h="yes" ],[ have_gd_h="no" ])
+
+-if test $have_gd_h != "yes"; then
++if test $have_gd_h = "bogus"; then
+ echo
+ echo "** The GD library is required for CvsGraph to function."
+ echo " Get it from http://www.boutell.com, compile it and"
diff --git a/devel/cvsgraph/files/patch-cvsgraph.c b/devel/cvsgraph/files/patch-cvsgraph.c
deleted file mode 100644
index 02145a6cd091..000000000000
--- a/devel/cvsgraph/files/patch-cvsgraph.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- cvsgraph.c.orig Mon Feb 19 15:30:29 2001
-+++ cvsgraph.c Wed Feb 21 00:03:56 2001
-@@ -1229,7 +1229,7 @@
- }
- else
- fp = stdout;
-- gdImageGif(im, fp);
-+ gdImagePng(im, fp);
- if(outfile)
- fclose(fp);
- gdImageDestroy(im);
diff --git a/devel/cvsgraph/pkg-descr b/devel/cvsgraph/pkg-descr
index 8eb84e1fd7a6..827b27ad5d0f 100644
--- a/devel/cvsgraph/pkg-descr
+++ b/devel/cvsgraph/pkg-descr
@@ -5,9 +5,6 @@ cvsgraph -r /home/ncvs -m ports/devel/cvsgraph -o test.png pkg-descr,v
It can also be used with cvsweb.
-The sorting is buggy: revision 1.2 appears between 1.19 and 1.20,
-for instance.
-
WWW: http://www.akhphd.au.dk/~bertho/cvsgraph/
Trevor Johnson