aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-02-21 13:03:51 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-02-21 13:03:51 +0000
commitc3323bd8f1eff77022c84d20425dea64578dad88 (patch)
tree5359aed8cdc6f5bc4b5cf3986330b324fe1b5770 /devel
parent7682bbd3ab689c7a31755e880340320a755f4ab5 (diff)
downloadports-c3323bd8f1eff77022c84d20425dea64578dad88.tar.gz
ports-c3323bd8f1eff77022c84d20425dea64578dad88.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ucommon/Makefile23
-rw-r--r--devel/ucommon/distinfo2
-rw-r--r--devel/ucommon/pkg-descr9
-rw-r--r--devel/ucommon/pkg-plist45
5 files changed, 80 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 07d8d719a6fa..981b28b1eefa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3403,6 +3403,7 @@
SUBDIR += truc
SUBDIR += u-boot
SUBDIR += uclmmbase
+ SUBDIR += ucommon
SUBDIR += ucpp
SUBDIR += udis86
SUBDIR += umem
diff --git a/devel/ucommon/Makefile b/devel/ucommon/Makefile
new file mode 100644
index 000000000000..28fbf104f228
--- /dev/null
+++ b/devel/ucommon/Makefile
@@ -0,0 +1,23 @@
+# New ports collection Makefile for: ucommon
+# Date created: 21 February 2011
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= ucommon
+PORTVERSION= 4.1.5
+CATEGORIES= devel
+MASTER_SITES= GNU
+MASTER_SITE_SUBDIR= commoncpp
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A very light-weight C++ design patternlibrary
+
+USE_GNOME= pkgconfig gnomehack
+GNU_CONFIGURE= yes
+
+MAN1= args.1 scrub.1 mdsum.1 zerofill.1 ucommon-config.1
+
+.include <bsd.port.mk>
+
diff --git a/devel/ucommon/distinfo b/devel/ucommon/distinfo
new file mode 100644
index 000000000000..477cef2f6f42
--- /dev/null
+++ b/devel/ucommon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ucommon-4.1.5.tar.gz) = 78495db363f85b639e98bb68bf1b25cc1763d1537661a9a9358088a88cb18673
+SIZE (ucommon-4.1.5.tar.gz) = 617107
diff --git a/devel/ucommon/pkg-descr b/devel/ucommon/pkg-descr
new file mode 100644
index 000000000000..e27a51f14d7e
--- /dev/null
+++ b/devel/ucommon/pkg-descr
@@ -0,0 +1,9 @@
+GNU uCommon C++ is meant as a very light-weight C++ library to facilitate using C++
+design patterns even for very deeply embedded applications, such as for systems using
+uclibc along with posix threading support. For this reason, GNU uCommon C++ disables
+language features that consume memory or introduce runtime overhead, such as rtti and
+exception handling, and assumes one will mostly be linking applications with other pure
+C based libraries rather than using the overhead of the standard C++ library and other
+similar class frameworks.
+
+WWW: http://www.gnutelephony.org/index.php/GNU_uCommon_C%2B%2B
diff --git a/devel/ucommon/pkg-plist b/devel/ucommon/pkg-plist
new file mode 100644
index 000000000000..ff4013d5ef19
--- /dev/null
+++ b/devel/ucommon/pkg-plist
@@ -0,0 +1,45 @@
+bin/args
+bin/scrub
+bin/mdsum
+bin/zerofill
+bin/ucommon-config
+lib/libucommon.a
+lib/libucommon.la
+lib/libucommon.so
+lib/libucommon.so.4
+lib/libusecure.a
+lib/libusecure.la
+lib/libusecure.so
+lib/libusecure.so.4
+include/ucommon/access.h
+include/ucommon/atomic.h
+include/ucommon/bitmap.h
+include/ucommon/buffer.h
+include/ucommon/containers.h
+include/ucommon/counter.h
+include/ucommon/datetime.h
+include/ucommon/export.h
+include/ucommon/fsys.h
+include/ucommon/generics.h
+include/ucommon/keydata.h
+include/ucommon/linked.h
+include/ucommon/mapped.h
+include/ucommon/memory.h
+include/ucommon/numbers.h
+include/ucommon/object.h
+include/ucommon/persist.h
+include/ucommon/platform.h
+include/ucommon/protocols.h
+include/ucommon/secure.h
+include/ucommon/shell.h
+include/ucommon/socket.h
+include/ucommon/stream.h
+include/ucommon/string.h
+include/ucommon/thread.h
+include/ucommon/timers.h
+include/ucommon/ucommon.h
+include/ucommon/unicode.h
+include/ucommon/vector.h
+include/ucommon/xml.h
+libdata/pkgconfig/ucommon.pc
+@dirrm include/ucommon