aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-07-26 07:55:02 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-07-26 07:55:02 +0000
commitee1b204170c8cbd9e6ff99bcbe17b2c060aee14e (patch)
tree55bd2dd7213302a5a578f5021a8ae5c753553bc2 /devel
parent5adbd489e12a4d583b89ff71c4201fa5eda2b8e1 (diff)
downloadports-ee1b204170c8cbd9e6ff99bcbe17b2c060aee14e.tar.gz
ports-ee1b204170c8cbd9e6ff99bcbe17b2c060aee14e.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libgamepad/Makefile21
-rw-r--r--devel/libgamepad/distinfo3
-rw-r--r--devel/libgamepad/pkg-descr5
-rw-r--r--devel/libgamepad/pkg-plist8
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 101c8ca3c6bd..4a7f69f477d5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -613,6 +613,7 @@
SUBDIR += libftdi
SUBDIR += libg++
SUBDIR += libgalago
+ SUBDIR += libgamepad
SUBDIR += libgconf-java
SUBDIR += libgetline
SUBDIR += libghthash
diff --git a/devel/libgamepad/Makefile b/devel/libgamepad/Makefile
new file mode 100644
index 000000000000..7410889d03b2
--- /dev/null
+++ b/devel/libgamepad/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: libgamepad
+# Date created: Jul 2008
+# Whom: Jason Bacon <jwbacon@tds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgamepad
+PORTVERSION= 0.1
+CATEGORIES= devel games
+MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/ \
+ http://jbacon.dyndns.org/~bacon/Ports/distfiles/
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Generic gamepad API
+
+USE_LDCONFIG= yes
+
+MAN3= libgamepad.3
+
+.include <bsd.port.mk>
diff --git a/devel/libgamepad/distinfo b/devel/libgamepad/distinfo
new file mode 100644
index 000000000000..8ea47a714cf0
--- /dev/null
+++ b/devel/libgamepad/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgamepad-0.1.tar.gz) = 64782133f916091da43b4bd580f55cf6
+SHA256 (libgamepad-0.1.tar.gz) = 9e22ce771d349102b29bd49fc7bc6572ee9a9aa35f73ff7ab52a082ca05bda1b
+SIZE (libgamepad-0.1.tar.gz) = 12270
diff --git a/devel/libgamepad/pkg-descr b/devel/libgamepad/pkg-descr
new file mode 100644
index 000000000000..4a1923f23f92
--- /dev/null
+++ b/devel/libgamepad/pkg-descr
@@ -0,0 +1,5 @@
+Libgamepad is an API for various gamepad devices under Unix. The goal is
+to provide both abstract and device-dependent interfaces for various joystick
+and gamepad devices. The library interfaces with multiple lower-level
+interfaces, such as the BSD "joy" and "usbhid" drivers, as well as
+the user-space "libhid", which in turn overlays "libusb".
diff --git a/devel/libgamepad/pkg-plist b/devel/libgamepad/pkg-plist
new file mode 100644
index 000000000000..5a219632562b
--- /dev/null
+++ b/devel/libgamepad/pkg-plist
@@ -0,0 +1,8 @@
+bin/gamepad_test
+include/libgamepad/gamepad.h
+include/libgamepad/gamepad_analog.h
+include/libgamepad/gamepad_libhid.h
+include/libgamepad/gamepad_usbhid.h
+lib/libgamepad.so.1
+lib/libgamepad.so
+@dirrm include/libgamepad