aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:13:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:13:55 +0000
commitfebc6fb0097f693da426c570054f23c344c81588 (patch)
tree7097c194f5d304d452abd6594ca9a08db8bd8e95 /devel
parent2c31fcf4a25df2f06df31810b0c93d54d00ad786 (diff)
downloadports-febc6fb0097f693da426c570054f23c344c81588.tar.gz
ports-febc6fb0097f693da426c570054f23c344c81588.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Module-Extract/Makefile24
-rw-r--r--devel/p5-Module-Extract/distinfo3
-rw-r--r--devel/p5-Module-Extract/pkg-descr12
-rw-r--r--devel/p5-Module-Extract/pkg-plist3
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cb106f328949..5be9b47f8c59 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1540,6 +1540,7 @@
SUBDIR += p5-Module-CoreList
SUBDIR += p5-Module-Dependency
SUBDIR += p5-Module-Depends
+ SUBDIR += p5-Module-Extract
SUBDIR += p5-Module-ExtractUse
SUBDIR += p5-Module-Find
SUBDIR += p5-Module-Info
diff --git a/devel/p5-Module-Extract/Makefile b/devel/p5-Module-Extract/Makefile
new file mode 100644
index 000000000000..d98ef22e6cea
--- /dev/null
+++ b/devel/p5-Module-Extract/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Module-Extract
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Extract
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Base class for working with Perl distributions
+
+BUILD_DEPENDS= ${SITE_PERL}/Archive/Extract.pm:${PORTSDIR}/archivers/p5-Archive-Extract
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Module::Extract.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Extract/distinfo b/devel/p5-Module-Extract/distinfo
new file mode 100644
index 000000000000..b38c057d94e0
--- /dev/null
+++ b/devel/p5-Module-Extract/distinfo
@@ -0,0 +1,3 @@
+MD5 (Module-Extract-0.01.tar.gz) = e75fc18af9686da49c2ee24cc555cb89
+SHA256 (Module-Extract-0.01.tar.gz) = 691a9cb10255388ded9317fed1acf01f7c5470a55637b1847a420fdda0af5929
+SIZE (Module-Extract-0.01.tar.gz) = 48138
diff --git a/devel/p5-Module-Extract/pkg-descr b/devel/p5-Module-Extract/pkg-descr
new file mode 100644
index 000000000000..767cc7878f44
--- /dev/null
+++ b/devel/p5-Module-Extract/pkg-descr
@@ -0,0 +1,12 @@
+Module::Extract is a convenience base class for creating module that work with
+Perl distributions. Its purpose is to take care of the mechanisms of locating
+and extracting a Perl distribution so that your module can do something specific
+to the distribution.
+
+This module was originally created to provide an abstraction for the extraction
+logic for both Module::Inspector and Module::P4P and to allow additional
+features to be added in the future without having to modify both of them,
+because the general problem of "locate, download, and expand a distribution"
+is one that is almost ideal for adding additional features down the line.
+
+WWW: http://search.cpan.org/dist/Module-Extract/
diff --git a/devel/p5-Module-Extract/pkg-plist b/devel/p5-Module-Extract/pkg-plist
new file mode 100644
index 000000000000..8faac52b5907
--- /dev/null
+++ b/devel/p5-Module-Extract/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Extract/.packlist
+%%SITE_PERL%%/Module/Extract.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Extract