aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2008-08-12 15:48:15 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2008-08-12 15:48:15 +0000
commita1f1642c37d0959f854316eb4f0ea0cf24ab0705 (patch)
tree495c4c5acf3e5778d9eedcc617fe6bab82fad580 /devel
parent733e6ba2bb470477fa33119b3a8af88eafe31f38 (diff)
downloadports-a1f1642c37d0959f854316eb4f0ea0cf24ab0705.tar.gz
ports-a1f1642c37d0959f854316eb4f0ea0cf24ab0705.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/pcre/Makefile1
-rw-r--r--devel/pcre/files/patch-pcre__compile.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/devel/pcre/Makefile b/devel/pcre/Makefile
index 974536cee096..dd3fc5890666 100644
--- a/devel/pcre/Makefile
+++ b/devel/pcre/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pcre
PORTVERSION= 7.7
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/programming/%SUBDIR%/ \
ftp://ftp.fu-berlin.de/unix/misc/%SUBDIR%/ \
diff --git a/devel/pcre/files/patch-pcre__compile.c b/devel/pcre/files/patch-pcre__compile.c
new file mode 100644
index 000000000000..a492df897aee
--- /dev/null
+++ b/devel/pcre/files/patch-pcre__compile.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- pcre_compile.c.orig
++++ pcre_compile.c
+@@ -4931,7 +4931,7 @@
+ (lengthptr == NULL || *lengthptr == 2 + 2*LINK_SIZE))
+ {
+ cd->external_options = newoptions;
+- options = newoptions;
++ options = *optionsptr = newoptions;
+ }
+ else
+ {