aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-09-05 06:42:25 +0000
committerWen Heping <wen@FreeBSD.org>2011-09-05 06:42:25 +0000
commitcda1a1ac1e72a6458e805526669039721d1b2f7f (patch)
tree0bf45c674ab01c2f8998f5697af7b3714ab4faa2 /devel
parentc182a89ec097e64f337114b6d7fa01794004a7b0 (diff)
downloadports-cda1a1ac1e72a6458e805526669039721d1b2f7f.tar.gz
ports-cda1a1ac1e72a6458e805526669039721d1b2f7f.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-System-Command/Makefile25
-rw-r--r--devel/p5-System-Command/distinfo2
-rw-r--r--devel/p5-System-Command/pkg-descr5
-rw-r--r--devel/p5-System-Command/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e10d7c65b03a..a9ef0fa02bcd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2314,6 +2314,7 @@
SUBDIR += p5-Sys-SigAction
SUBDIR += p5-Sys-Syscall
SUBDIR += p5-Sys-Trace
+ SUBDIR += p5-System-Command
SUBDIR += p5-System2
SUBDIR += p5-TAP-Formatter-JUnit
SUBDIR += p5-TAP-Harness-JUnit
diff --git a/devel/p5-System-Command/Makefile b/devel/p5-System-Command/Makefile
new file mode 100644
index 000000000000..dd4cd196adb7
--- /dev/null
+++ b/devel/p5-System-Command/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-System-Command
+# Date created: Sep 05, 2011
+# Whom: Wen Heping<wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= System-Command
+PORTVERSION= 1.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:BOOK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Object for running system commands
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_CONFIGURE= yes
+
+MAN3= System::Command.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-System-Command/distinfo b/devel/p5-System-Command/distinfo
new file mode 100644
index 000000000000..486381e23d11
--- /dev/null
+++ b/devel/p5-System-Command/distinfo
@@ -0,0 +1,2 @@
+SHA256 (System-Command-1.05.tar.gz) = 22fa07351ae5d78f3068876f00a9f67d5ab4fe9fc3baa7d6111405098defee03
+SIZE (System-Command-1.05.tar.gz) = 12153
diff --git a/devel/p5-System-Command/pkg-descr b/devel/p5-System-Command/pkg-descr
new file mode 100644
index 000000000000..aa23b9a57b45
--- /dev/null
+++ b/devel/p5-System-Command/pkg-descr
@@ -0,0 +1,5 @@
+System::Command is a class that launches external system commands
+and return an object representing them, allowing to interact with
+them through their STDIN, STDOUT and STDERR handles.
+
+WWW: http://search.cpan.org/dist/System-Command/
diff --git a/devel/p5-System-Command/pkg-plist b/devel/p5-System-Command/pkg-plist
new file mode 100644
index 000000000000..b61fed7288b0
--- /dev/null
+++ b/devel/p5-System-Command/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/System/Command/.packlist
+%%SITE_PERL%%/System/Command.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/System/Command
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/System
+@dirrmtry %%SITE_PERL%%/System