aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 10:53:38 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 10:53:38 +0000
commite467cb1db54df71170364ee0a9dca38a32b11b0b (patch)
tree6cb6f0da787d4b67708abc802fa739d71222bbdc /devel
parent8ae25a440e4a7875b74a89f412b5029292e6d6f1 (diff)
downloadports-e467cb1db54df71170364ee0a9dca38a32b11b0b.tar.gz
ports-e467cb1db54df71170364ee0a9dca38a32b11b0b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/avro-cpp/Makefile2
-rw-r--r--devel/cocaine-core/Makefile12
-rw-r--r--devel/codeblocks/Makefile6
-rw-r--r--devel/eblob/Makefile6
-rw-r--r--devel/kdesdk4/Makefile8
-rw-r--r--devel/kdevplatform/Makefile8
-rw-r--r--devel/libiqxmlrpc/Makefile2
-rw-r--r--devel/libslave/Makefile2
-rw-r--r--devel/luabind/Makefile2
-rw-r--r--devel/mongo-cxx-driver/Makefile4
-rw-r--r--devel/nemiver/Makefile10
-rw-r--r--devel/ros/Makefile4
-rw-r--r--devel/sdts++/Makefile2
-rw-r--r--devel/smack/Makefile4
-rw-r--r--devel/subcommander2/Makefile4
-rw-r--r--devel/uatraits/Makefile6
-rw-r--r--devel/xsd/Makefile4
17 files changed, 43 insertions, 43 deletions
diff --git a/devel/avro-cpp/Makefile b/devel/avro-cpp/Makefile
index 3771a37e8001..1729fe386412 100644
--- a/devel/avro-cpp/Makefile
+++ b/devel/avro-cpp/Makefile
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= vg@FreeBSD.org
COMMENT= Data serialization system for C++
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
USES= cmake
USE_LDCONFIG= yes
diff --git a/devel/cocaine-core/Makefile b/devel/cocaine-core/Makefile
index a19746d35678..bfac6bba15ae 100644
--- a/devel/cocaine-core/Makefile
+++ b/devel/cocaine-core/Makefile
@@ -12,12 +12,12 @@ COMMENT= Cocaine Application Engine
LICENSE= GPLv3
-LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \
- ev:${PORTSDIR}/devel/libev \
- ltdl:${PORTSDIR}/devel/libltdl \
- msgpack:${PORTSDIR}/devel/msgpack \
- uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
- zmq:${PORTSDIR}/net/libzmq2
+LIB_DEPENDS= libboost_iostreams.so:${PORTSDIR}/devel/boost-libs \
+ libev.so:${PORTSDIR}/devel/libev \
+ libltdl.so:${PORTSDIR}/devel/libltdl \
+ libmsgpack.so:${PORTSDIR}/devel/msgpack \
+ libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ libzmq.so:${PORTSDIR}/net/libzmq2
USES= cmake
USE_GCC= yes
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index fd41ce3e45d1..55029cb8467f 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -14,9 +14,9 @@ LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= boost_system:${PORTSDIR}/devel/boost-libs \
- hunspell:${PORTSDIR}/textproc/hunspell \
- rsync:${PORTSDIR}/net/librsync
+LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libhunspell.so:${PORTSDIR}/textproc/hunspell \
+ librsync.so:${PORTSDIR}/net/librsync
RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
USES= pkgconfig
diff --git a/devel/eblob/Makefile b/devel/eblob/Makefile
index a5a43e43e053..0bf736b0c583 100644
--- a/devel/eblob/Makefile
+++ b/devel/eblob/Makefile
@@ -10,7 +10,7 @@ COMMENT= Append-only low-level I/O library
LICENSE= GPLv2
-LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_iostreams.so:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
@@ -34,7 +34,7 @@ CMAKE_ARGS+= -DWITH_ASSERTS=OFF
.endif
.if ${PORT_OPTIONS:MPYTHON}
-LIB_DEPENDS+= boost_python:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
USE_PYTHON= yes
CMAKE_ARGS+= -DWITH_PYTHON=ON
INSTALLS_EGGINFO= yes
@@ -46,7 +46,7 @@ PLIST_SUB+= PYTHON="@comment "
.endif
.if ${PORT_OPTIONS:MSNAPPY}
-LIB_DEPENDS+= snappy:${PORTSDIR}/archivers/snappy
+LIB_DEPENDS+= libsnappy.so:${PORTSDIR}/archivers/snappy
CMAKE_ARGS+= -DWITH_SNAPPY=ON
.else
CMAKE_ARGS+= -DWITH_SNAPPY=OFF
diff --git a/devel/kdesdk4/Makefile b/devel/kdesdk4/Makefile
index a3ca0aa972f4..6b59178fadeb 100644
--- a/devel/kdesdk4/Makefile
+++ b/devel/kdesdk4/Makefile
@@ -12,10 +12,10 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Software Development Kit
-LIB_DEPENDS= svn_client-1.0:${PORTSDIR}/devel/subversion \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- hunspell-1.3.0:${PORTSDIR}/textproc/hunspell \
- qca.2:${PORTSDIR}/devel/qca
+LIB_DEPENDS= libsvn_client-1.so:${PORTSDIR}/devel/subversion \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
+ libqca.so:${PORTSDIR}/devel/qca
BUILD_DEPENDS= ${LOCALBASE}/include/ltdl.h:${PORTSDIR}/devel/libltdl
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
diff --git a/devel/kdevplatform/Makefile b/devel/kdevplatform/Makefile
index 89b4d2453600..1aa30a4028d7 100644
--- a/devel/kdevplatform/Makefile
+++ b/devel/kdevplatform/Makefile
@@ -11,10 +11,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Set of libraries for KDE IDE-like programs
-LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- qjson:${PORTSDIR}/devel/qjson \
- grantlee_gui:${PORTSDIR}/devel/grantlee
+LIB_DEPENDS= libsvn_client-1.so:${PORTSDIR}/devel/subversion \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libqjson.so:${PORTSDIR}/devel/qjson \
+ libgrantlee_gui.so:${PORTSDIR}/devel/grantlee
USE_KDE4= kate_run kdehier kdelibs kdeprefix automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build \
diff --git a/devel/libiqxmlrpc/Makefile b/devel/libiqxmlrpc/Makefile
index 70b0af5be3d5..17580af4c2f3 100644
--- a/devel/libiqxmlrpc/Makefile
+++ b/devel/libiqxmlrpc/Makefile
@@ -13,7 +13,7 @@ COMMENT= Free, object-oriented XML-RPC implementation written in C++
.if !defined(NOPORTDOCS)
BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
.endif
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
LICENSE= BSD
diff --git a/devel/libslave/Makefile b/devel/libslave/Makefile
index 2b04282dd713..52075dc3d41f 100644
--- a/devel/libslave/Makefile
+++ b/devel/libslave/Makefile
@@ -12,7 +12,7 @@ COMMENT= Mysql replication client library, embeddable into your C++ application
LICENSE= GPLv3
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
DATE= 20121210
USES= cmake
diff --git a/devel/luabind/Makefile b/devel/luabind/Makefile
index 30654a111c36..ea190e4884a7 100644
--- a/devel/luabind/Makefile
+++ b/devel/luabind/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Library that helps you create bindings between C++ and Lua
-LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
USE_LUA= 5.1+
USE_LDCONFIG= yes
diff --git a/devel/mongo-cxx-driver/Makefile b/devel/mongo-cxx-driver/Makefile
index cfa29973b37c..3fbc6dad3e3b 100644
--- a/devel/mongo-cxx-driver/Makefile
+++ b/devel/mongo-cxx-driver/Makefile
@@ -12,8 +12,8 @@ COMMENT= C++ 2.4 Driver for MongoDB
LICENSE= AL2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= boost_system:${PORTSDIR}/devel/boost-libs \
- sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
USE_GITHUB= yes
GH_ACCOUNT= waitman
diff --git a/devel/nemiver/Makefile b/devel/nemiver/Makefile
index 6066c16cd583..0f9b94470c82 100644
--- a/devel/nemiver/Makefile
+++ b/devel/nemiver/Makefile
@@ -12,11 +12,11 @@ DIST_SUBDIR= gnome2
MAINTAINER= romain@FreeBSD.org
COMMENT= A C/C++ Debugger for GNOME
-LIB_DEPENDS= boost_unit_test_framework:${PORTSDIR}/devel/boost-libs \
- gtop-2.0:${PORTSDIR}/devel/libgtop \
- sqlite3:${PORTSDIR}/databases/sqlite3 \
- glademm-2.4:${PORTSDIR}/devel/libglademm24 \
- gtksourceviewmm-2:${PORTSDIR}/x11-toolkits/libgtksourceviewmm
+LIB_DEPENDS= libboost_unit_test_framework.so:${PORTSDIR}/devel/boost-libs \
+ libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
+ libglademm-2.4.so:${PORTSDIR}/devel/libglademm24 \
+ libgtksourceviewmm-2.so:${PORTSDIR}/x11-toolkits/libgtksourceviewmm
BUILD_DEPENDS= ${LOCALBASE}/bin/gdb:${PORTSDIR}/devel/gdb
RUN_DEPENDS= ${LOCALBASE}/bin/gdb:${PORTSDIR}/devel/gdb
diff --git a/devel/ros/Makefile b/devel/ros/Makefile
index 42d2f911b7b9..7e84aaa44bc6 100644
--- a/devel/ros/Makefile
+++ b/devel/ros/Makefile
@@ -16,8 +16,8 @@ LICENSE= BSD
STACKNAME= ${PORTNAME:S/ros-//}
CFLAGS+= -I${LOCALBASE}/include
-LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs \
- gtest:${PORTSDIR}/devel/googletest
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
+ libgtest.so:${PORTSDIR}/devel/googletest
# we need cmake and gmake for the build, but the build is triggered by make
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/yaml/__init__.py:${PORTSDIR}/devel/py-yaml \
bash:${PORTSDIR}/shells/bash \
diff --git a/devel/sdts++/Makefile b/devel/sdts++/Makefile
index 25ce2bd4b221..0384913e0ed0 100644
--- a/devel/sdts++/Makefile
+++ b/devel/sdts++/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://thor-f5.er.usgs.gov/sdts/sdtsxx/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library for SDTS related development
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
DOS2UNIX_FILES= sdts++/io/sio_Utils.cpp
USES= bison dos2unix gmake
diff --git a/devel/smack/Makefile b/devel/smack/Makefile
index e4dca7a932b3..9b739dec28be 100644
--- a/devel/smack/Makefile
+++ b/devel/smack/Makefile
@@ -11,8 +11,8 @@ COMMENT= Low-level I/O storage library which packs data
LICENSE= GPLv2
-LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \
- snappy:${PORTSDIR}/archivers/snappy
+LIB_DEPENDS= libboost_iostreams.so:${PORTSDIR}/devel/boost-libs \
+ libsnappy.so:${PORTSDIR}/archivers/snappy
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
diff --git a/devel/subcommander2/Makefile b/devel/subcommander2/Makefile
index fcfd9f5a6405..7f9595af645a 100644
--- a/devel/subcommander2/Makefile
+++ b/devel/subcommander2/Makefile
@@ -13,8 +13,8 @@ COMMENT= Qt4 based multiplatform subversion client, diff & merge tool
LICENSE= GPLv2
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
- svn_client-1:${PORTSDIR}/devel/subversion
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libsvn_client-1.so:${PORTSDIR}/devel/subversion
LATEST_LINK= subcommander2
CONFLICTS= subcommander-1.*
diff --git a/devel/uatraits/Makefile b/devel/uatraits/Makefile
index 31f1e118e81d..2832662c68e0 100644
--- a/devel/uatraits/Makefile
+++ b/devel/uatraits/Makefile
@@ -12,9 +12,9 @@ COMMENT= User-Agent detection library
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
automake:${PORTSDIR}/devel/automake \
libtool:${PORTSDIR}/devel/libtool
-LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs \
- pcre:${PORTSDIR}/devel/pcre \
- xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
USES= pkgconfig
GNU_CONFIGURE= yes
diff --git a/devel/xsd/Makefile b/devel/xsd/Makefile
index d80658c042e0..d0728c960563 100644
--- a/devel/xsd/Makefile
+++ b/devel/xsd/Makefile
@@ -17,8 +17,8 @@ LICENSE_FILE= ${WRKSRC}/xsd/LICENSE
# check if things still work to get rid of the shells/bash dependency.
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
gm4:${PORTSDIR}/devel/m4
-LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
- xerces-c.3:${PORTSDIR}/textproc/xerces-c3
+LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3
ALL_TARGET= # no default target should be passed to gmake.
CXXFLAGS+= -I${LOCALBASE}/include