aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-02-14 18:15:23 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-02-14 18:15:23 +0000
commit81c6aea2fd6ca3c3e98b319c78fbfe7188fd6429 (patch)
treea90ef77a77b49b467d43dc6548863d754cba4131 /devel
parent7100dc35e12642e656631ec457716fbac87a330a (diff)
downloadports-81c6aea2fd6ca3c3e98b319c78fbfe7188fd6429.tar.gz
ports-81c6aea2fd6ca3c3e98b319c78fbfe7188fd6429.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/tclgetopts/Makefile6
-rw-r--r--devel/tclgetopts/distinfo4
-rw-r--r--devel/tclgetopts/files/patch-aa34
3 files changed, 14 insertions, 30 deletions
diff --git a/devel/tclgetopts/Makefile b/devel/tclgetopts/Makefile
index cfc015f76aab..03950122d5ff 100644
--- a/devel/tclgetopts/Makefile
+++ b/devel/tclgetopts/Makefile
@@ -7,10 +7,10 @@
PORTNAME= tclGetOpts
PORTVERSION= 1.0
-CATEGORIES= devel tcl80 tcl82
-MASTER_SITES= ftp://ftp.neosoft.com/languages/tcl/alcatel/code/ \
- http://www.neosoft.com/tcl/ftparchive/alcatel/code/
+CATEGORIES= devel tcl80 tcl82 tcl83 tcl84
+MASTER_SITES= http://www.waxandwane.com/toolbox/tclGetOpts/
DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= ${PORTVERSION}.tar.gz
MAINTAINER= mi@aldan.algebra.com
COMMENT= Pure TCL code for command line options parsing
diff --git a/devel/tclgetopts/distinfo b/devel/tclgetopts/distinfo
index 72d4cf35ea42..79dd0b6ade55 100644
--- a/devel/tclgetopts/distinfo
+++ b/devel/tclgetopts/distinfo
@@ -1,2 +1,2 @@
-MD5 (tclGetOpts.tar.gz) = f0a701007a5374980c97a5306ce62141
-SIZE (tclGetOpts.tar.gz) = 8675
+MD5 (tclGetOpts1.0.tar.gz) = 4de7119ffbe9b97bc09800fc210c17e3
+SIZE (tclGetOpts1.0.tar.gz) = 8901
diff --git a/devel/tclgetopts/files/patch-aa b/devel/tclgetopts/files/patch-aa
index b6758e7bbdb3..9ab821bfe4c0 100644
--- a/devel/tclgetopts/files/patch-aa
+++ b/devel/tclgetopts/files/patch-aa
@@ -1,4 +1,4 @@
---- foxTypedOpts.tcl.orig Sat Feb 19 19:46:50 1994
+--- foxTypedOpts.tcl Sat Feb 19 19:46:50 1994
+++ foxTypedOpts.tcl Thu Mar 18 16:15:13 1999
@@ -80,9 +80,8 @@
# typedopts several times with different <arg-list>s without losing the
@@ -32,7 +32,7 @@
return 0
}
}
-@@ -315,54 +312,52 @@
+@@ -320,32 +317,28 @@
"floats" -
"strings" {
if { [ llength $optlist ] } then {
@@ -55,14 +55,13 @@
if { ! [ llength $optlist ] } then {
- puts stderr "typedopts: No arguments given to type $type"
- return ""
-- }
-- if { ! [ string length [ set subtype [ parseOption $optlist ]]] } then {
-- return ""
+ return -code error "typedopts: No arguments given to type $type"
}
-+ if [catch {parseOption $optlist} subtype] {
+- if { ! [ string length [ set subtype [ parseOption $optlist ]]] } then {
+- return ""
++ if {[catch {parseOption $optlist} subtype]} then {
+ return -code error $subtype
-+ }
+ }
return [ concat [ string index $type 0 ] $subtype ]
}
default {
@@ -72,11 +71,7 @@
}
}
}
-+}
-+
-+proc typedopts { args } {
-
- set doinit 1
+@@ -354,6 +347,5 @@
if { [ llength $args ] < 5 } then {
- puts stderr "typedopts: bad number of arguments."
@@ -84,25 +79,14 @@
+ return -code error "typedopts: bad number of arguments."
}
-- set args [ extract $args arglist optlist optret argret restret ]
-+ set args [ foxOpts::extract $args arglist optlist optret argret restret ]
-
- while { [ llength $args ] } {
-- set opt [ shift args ]
-- switch -exact [ findabbr { -noinitialize } $opt ] {
-+ set opt [ foxOpts::shift args ]
-+ switch -exact [ foxOpts::findabbr { -noinitialize } $opt ] {
- -noinitialize {
- set doinit 0
+@@ -367,6 +359,5 @@
}
default {
- puts stderr "typedopts: bad option \"$opt\": should be -noinitialize or --"
- return -1
-+ return -code error \
-+ "typedopts: bad option \"$opt\": should be -noinitialize or --"
++ return -code error "typedopts: bad option \"$opt\": should be -noinitialize or --"
}
}
- }
@@ -380,16 +375,15 @@
if { [ string length $type ] } then {
foreach arg $word {