aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-02-16 09:52:05 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-02-16 09:52:05 +0000
commite89cede3255638b291700c886ffc05c932c42aaa (patch)
tree36cd80a9bd14fe07577a2cf9794cd37565859c4f /devel
parentf72c3580e1ead1ad9fd8d03af159b803e4a25650 (diff)
downloadports-e89cede3255638b291700c886ffc05c932c42aaa.tar.gz
ports-e89cede3255638b291700c886ffc05c932c42aaa.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-CPAN-Mini/Makefile34
-rw-r--r--devel/p5-CPAN-Mini/distinfo2
-rw-r--r--devel/p5-CPAN-Mini/pkg-descr5
-rw-r--r--devel/p5-CPAN-Mini/pkg-plist6
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ff7a9792bb31..babf19d25611 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -646,6 +646,7 @@
SUBDIR += p5-BSD-stat
SUBDIR += p5-C-Scan
SUBDIR += p5-CPAN-DistnameInfo
+ SUBDIR += p5-CPAN-Mini
SUBDIR += p5-Cache
SUBDIR += p5-Cache-Cache
SUBDIR += p5-Cache-FastMmap
diff --git a/devel/p5-CPAN-Mini/Makefile b/devel/p5-CPAN-Mini/Makefile
new file mode 100644
index 000000000000..70d9d02dd842
--- /dev/null
+++ b/devel/p5-CPAN-Mini/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: devel/p5-CPAN-Mini
+# Date created: 16 February 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CPAN-Mini
+PORTVERSION= 0.36
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= CPAN::Mini - create a minimal mirror of CPAN
+
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= minicpan.1
+MAN3= CPAN::Mini.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.0 or later. Install lang/perl5 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-CPAN-Mini/distinfo b/devel/p5-CPAN-Mini/distinfo
new file mode 100644
index 000000000000..d057ba42115c
--- /dev/null
+++ b/devel/p5-CPAN-Mini/distinfo
@@ -0,0 +1,2 @@
+MD5 (CPAN-Mini-0.36.tar.gz) = e7053d2adbb42bfdeab04988e5f16a46
+SIZE (CPAN-Mini-0.36.tar.gz) = 7000
diff --git a/devel/p5-CPAN-Mini/pkg-descr b/devel/p5-CPAN-Mini/pkg-descr
new file mode 100644
index 000000000000..340b51d71af9
--- /dev/null
+++ b/devel/p5-CPAN-Mini/pkg-descr
@@ -0,0 +1,5 @@
+CPAN::Mini provides a simple mechanism to build and update a minimal
+mirror of the CPAN on your local disk. It contains only those files
+needed to install the newest version of every distribution.
+
+WWW: http://search.cpan.org/dist/CPAN-Mini
diff --git a/devel/p5-CPAN-Mini/pkg-plist b/devel/p5-CPAN-Mini/pkg-plist
new file mode 100644
index 000000000000..16f6e4d8c0e5
--- /dev/null
+++ b/devel/p5-CPAN-Mini/pkg-plist
@@ -0,0 +1,6 @@
+bin/minicpan
+%%SITE_PERL%%/CPAN/Mini.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Mini/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Mini 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/CPAN 2>/dev/null || true