aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-12-31 08:59:51 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-12-31 08:59:51 +0000
commit13e30de0b874b1ef4134be51287ee67d463385a5 (patch)
tree3fc3260812ec3c87dfa58416c3e262090e54ca60 /devel
parent56d324c9e53b1a61b2a8ec1e70ee37b9d774de71 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/stlport/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index a800fdfee2a0..a10c1c704948 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -62,8 +62,15 @@ pre-configure:
${WRKSRC}/../test/unit/gcc.mak
.for lib in stlport stlportg stlportstlg
${REINPLACE_CMD} -e 's|-l${lib}$$|-l${lib}_${COMPILER}|' \
- ${PATCH_WRKSRC}/build/Makefiles/gmake/app/gcc.mak
+ ${PATCH_WRKSRC}/build/Makefiles/gmake/app/gcc.mak
.endfor
+.if ${ARCH} != i386
+. for sdir in app lib
+ # Cannot build a shared object with libsupc++
+ ${REINPLACE_CMD} -e 's|-lsupc++|-lstdc++|' \
+ ${PATCH_WRKSRC}/build/Makefiles/gmake/${sdir}/gcc.mak
+. endfor
+.endif
do-install:
${MKDIR} "${PREFIX}/include/stlport/"