aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-12-06 17:17:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-12-06 17:17:38 +0000
commit185ceb675cf8b26e316a037b83225c000ff26f23 (patch)
tree529039d77da5b882444fb862a40d4fea197d5466 /devel
parent06b18b4580a6e989c99e4e95831869330142325e (diff)
downloadports-185ceb675cf8b26e316a037b83225c000ff26f23.tar.gz
ports-185ceb675cf8b26e316a037b83225c000ff26f23.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-bsearch/Makefile25
-rw-r--r--devel/ruby-bsearch/pkg-plist4
-rw-r--r--devel/ruby-cache/pkg-plist4
-rw-r--r--devel/ruby-cvs/Makefile24
-rw-r--r--devel/ruby-cvs/pkg-plist6
-rw-r--r--devel/ruby-gemfinder/Makefile25
-rw-r--r--devel/ruby-gemfinder/pkg-plist2
-rw-r--r--devel/ruby-gettext/Makefile16
-rw-r--r--devel/ruby-gettext/pkg-plist4
-rw-r--r--devel/ruby-mmap/Makefile19
-rw-r--r--devel/ruby-mmap/pkg-plist2
-rw-r--r--devel/ruby-sdl/Makefile24
-rw-r--r--devel/ruby-sdl/pkg-plist4
-rw-r--r--devel/ruby-sysvipc/Makefile17
-rw-r--r--devel/ruby-sysvipc/pkg-plist2
-rw-r--r--devel/ruby-tzfile/Makefile22
-rw-r--r--devel/ruby-tzfile/pkg-plist2
-rw-r--r--devel/ruby-unit/Makefile24
-rw-r--r--devel/ruby-unit/pkg-plist60
-rw-r--r--devel/rubygem-gettext/Makefile16
-rw-r--r--devel/rubygem-gettext/pkg-plist4
-rw-r--r--devel/rubygem-locale/Makefile16
-rw-r--r--devel/rubygem-locale/pkg-plist4
23 files changed, 172 insertions, 154 deletions
diff --git a/devel/ruby-bsearch/Makefile b/devel/ruby-bsearch/Makefile
index 5fc0539b517b..54b53110b4fe 100644
--- a/devel/ruby-bsearch/Makefile
+++ b/devel/ruby-bsearch/Makefile
@@ -16,21 +16,24 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
-DOCS_EN= ChangeLog bsearch.en.html bsearch.en.rd
-DOCS_JA= bsearch.ja.html bsearch.ja.rd
+NO_BUILD= yes
-do-build:
-.if !defined(NOPORTDOCS)
-.for f in bsearch.en.rd bsearch.ja.rd
- @cd ${WRKSRC}; \
- ${RUBY_RD2} ${f} > ${f:R}.html
-.endfor
-.endif
+RUBY_RD_FILES= bsearch.en.rd bsearch.ja.rd
+DOCS_EN= ChangeLog \
+ ${RUBY_RD_FILES:M*.en.rd} \
+ ${RUBY_RD_HTML_FILES:M*.en.html}
+DOCS_JA= ${RUBY_RD_FILES:M*.ja.rd} \
+ ${RUBY_RD_HTML_FILES:M*.ja.html}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bsearch.rb ${RUBY_SITELIBDIR}/
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
@@ -40,5 +43,3 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-bsearch/pkg-plist b/devel/ruby-bsearch/pkg-plist
index 11b0c3c4dc9f..59b938ce76a9 100644
--- a/devel/ruby-bsearch/pkg-plist
+++ b/devel/ruby-bsearch/pkg-plist
@@ -1,8 +1,8 @@
%%RUBY_SITELIBDIR%%/bsearch.rb
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/bsearch.en.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/bsearch.en.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/bsearch.en.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/bsearch.ja.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/bsearch.ja.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/bsearch.ja.rd
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/devel/ruby-cache/pkg-plist b/devel/ruby-cache/pkg-plist
index 512f6a0d6ebb..9eb2d90b0d0d 100644
--- a/devel/ruby-cache/pkg-plist
+++ b/devel/ruby-cache/pkg-plist
@@ -1,7 +1,7 @@
%%RUBY_SITELIBDIR%%/cache.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/MANUAL.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/MANUAL.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/MANUAL.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/README.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.rd
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/filecache.rb
diff --git a/devel/ruby-cvs/Makefile b/devel/ruby-cvs/Makefile
index 262ad66b8706..25b07fcd6b1f 100644
--- a/devel/ruby-cvs/Makefile
+++ b/devel/ruby-cvs/Makefile
@@ -19,23 +19,29 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/flex.so:${PORTSDIR}/devel/ruby-flex_rb
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
+NO_BUILD= yes
+
+RUBY_RD_FILES= cvs.rb diff.rb tempdir.rb
RUBY_SHEBANG_FILES= ${WRKSRC}/viztree ${WRKSRC}/reviz/reviz
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
-DOCS= README TODO cvs.html diff.html tempdir.html
+DOCS= README TODO ${RUBY_RD_HTML_FILES}
-do-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} lib/cvs.rb > cvs.html
- cd ${WRKSRC}; ${RUBY_RD2} lib/diff.rb > diff.html
- cd ${WRKSRC}; ${RUBY_RD2} lib/tempdir.rb > tempdir.html
-.endif
+post-extract:
+.for f in ${RUBY_RD_FILES}
+ cd ${WRKSRC}; ${LN} -sf lib/${f}
+.endfor
do-install:
${CP} -R ${WRKSRC}/lib/* ${RUBY_SITELIBDIR}/
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}/reviz
${INSTALL_DATA} ${WRKSRC}/viztree ${RUBY_MODEXAMPLESDIR}/
@@ -45,5 +51,3 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-cvs/pkg-plist b/devel/ruby-cvs/pkg-plist
index c1c6ef1002d1..40128e4eb71e 100644
--- a/devel/ruby-cvs/pkg-plist
+++ b/devel/ruby-cvs/pkg-plist
@@ -34,7 +34,7 @@
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/TODO
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/cvs.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/diff.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/tempdir.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/cvs.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/diff.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/tempdir.html
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/devel/ruby-gemfinder/Makefile b/devel/ruby-gemfinder/Makefile
index ea799f98c3d1..db18572ab345 100644
--- a/devel/ruby-gemfinder/Makefile
+++ b/devel/ruby-gemfinder/Makefile
@@ -18,26 +18,31 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_LIBDIR}/tk.rb:${PORTSDIR}/x11-toolkits/ruby-tk
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
+NO_BUILD= yes
+
+RUBY_RD_FILES= gemfinder.rd
RUBY_SHEBANG_FILES= ${WRKSRC}/gemfinder
-DOCS= README gemfinder.html gemfinder.rd
+DOCS= README \
+ ${RUBY_RD_FILES} \
+ ${RUBY_RD_HTML_FILES}
-do-build:
-.if !defined(NOPORTDOCS)
- ${RUBY_RD2} < ${WRKSRC}/gemfinder.rd \
- | ${SED} -e 's/<BODY>/<body bgcolor="#ffffff">/' \
- > ${WRKSRC}/gemfinder.html
-.endif
+post-patch:
+ ${RUBY} -i -pe 'sub(/<BODY>/, "<BODY bgcolor=\"#ffffff\">")' \
+ ${WRKSRC}/gemfinder.rd
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/gemfinder ${PREFIX}/bin/
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-gemfinder/pkg-plist b/devel/ruby-gemfinder/pkg-plist
index e2f84edb970e..532e66f668f3 100644
--- a/devel/ruby-gemfinder/pkg-plist
+++ b/devel/ruby-gemfinder/pkg-plist
@@ -1,5 +1,5 @@
bin/gemfinder
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gemfinder.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/gemfinder.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gemfinder.rd
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/devel/ruby-gettext/Makefile b/devel/ruby-gettext/Makefile
index f2e7bcf0ddda..a2512d611310 100644
--- a/devel/ruby-gettext/Makefile
+++ b/devel/ruby-gettext/Makefile
@@ -19,24 +19,24 @@ MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
+RUBY_RD_FILES= # defined
RUBY_SHEBANG_FILES= ${WRKSRC}/samples/*.rb
-post-build:
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
+.if !defined(RUBY_NO_RD_HTML)
cd ${WRKSRC}/docs; ${RUBY} makehtml.rb
- cd ${WRKSRC}/samples; ${RUBY} makemo.rb
.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/samples; ${RUBY} makemo.rb
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/samples/* ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
${CP} -R ${WRKSRC}/docs/* ${RUBY_MODDOCDIR}/
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-gettext/pkg-plist b/devel/ruby-gettext/pkg-plist
index 140b127da44a..5f2a7aeda4f7 100644
--- a/devel/ruby-gettext/pkg-plist
+++ b/devel/ruby-gettext/pkg-plist
@@ -45,8 +45,8 @@ share/locale/ja/LC_MESSAGES/rgettext.mo
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/config.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/en/ruby-gettext.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/ja/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/html/en/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/html/ja/ruby-gettext.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/style.css
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/makehtml.rb
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/en/LANGUAGE
diff --git a/devel/ruby-mmap/Makefile b/devel/ruby-mmap/Makefile
index cf6b2271eb62..26d9acc95340 100644
--- a/devel/ruby-mmap/Makefile
+++ b/devel/ruby-mmap/Makefile
@@ -20,25 +20,30 @@ BUILD_DEPENDS= rdoc:${PORTSDIR}/textproc/ruby-rdoc
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_RUBY_RDTOOL= yes
+
+RUBY_RD_FILES= mmap.rd
INSTALL_TARGET= site-install
-DOCS= Changes README.en mmap.html mmap.rd \
+DOCS= Changes \
+ README.en \
+ ${RUBY_RD_FILES} \
+ ${RUBY_RD_HTML_FILES} \
docs/doc
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} mmap.rd > mmap.html
- cd ${WRKSRC}/docs; ${RUBY} b.rb mmap; rdoc mmap.rb
+ cd ${WRKSRC}/docs; ${RUBY} b.rb mmap; ${RUBY_RDOC} mmap.rb
.endif
-post-install:
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-mmap/pkg-plist b/devel/ruby-mmap/pkg-plist
index 01f7113ef980..f174228f331e 100644
--- a/devel/ruby-mmap/pkg-plist
+++ b/devel/ruby-mmap/pkg-plist
@@ -1,7 +1,7 @@
%%RUBY_SITEARCHLIBDIR%%/mmap.so
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Changes
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.en
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/mmap.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/mmap.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/mmap.rd
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/Mmap.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/Mmap.src/M000001.html
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index 9e19496fba7d..29ed31e2b35b 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -26,7 +26,6 @@ RUBY_OPENGL_WRKSRC_CMD= cd ${RUBY_OPENGL_PORTDIR}; ${MAKE} -V WRKSRC
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_RUBY_RDTOOL= yes
RUBY_WITH_PTHREAD= yes
CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
@@ -34,13 +33,15 @@ CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
--with-x11-dir="${X11BASE}"
INSTALL_TARGET= site-install
-RD_DOCS_EN= rubysdl_doc.en.rd
-RD_DOCS_JA= rubysdl_doc.rd
+RUBY_RD_FILES= rubysdl_doc.en.rd \
+ rubysdl_doc.rd
DOCS_EN= NEWS.en README.en rubysdl_const_list.txt \
- ${RD_DOCS_EN} ${RD_DOCS_EN:S/.rd$/.html/}
+ ${RUBY_RD_FILES:M*.en.rd} \
+ ${RUBY_RD_HTML_FILES:M*.en.html}
DOCS_JA= NEWS.ja README.ja \
- ${RD_DOCS_JA} ${RD_DOCS_JA:S/.rd$/.html/}
+ ${RUBY_RD_FILES:N*.en.rd} \
+ ${RUBY_RD_HTML_FILES:N*.en.html}
post-extract:
dir=`${RUBY_OPENGL_WRKSRC_CMD}`; \
@@ -52,14 +53,11 @@ post-patch:
${RUBY} -i -pe '/require \x27mkmf\x27/ and $$_ += "dir_config(\x27x11\x27)\n"' \
${WRKSRC}/${RUBY_EXTCONF}
-post-build:
-.if !defined(NOPORTDOCS)
-.for f in ${RD_DOCS_EN} ${RD_DOCS_JA}
- @cd ${WRKSRC}; ${RUBY_RD2} ${f} > ${f:S/.rd$/.html/}
-.endfor
-.endif
+post-install: doc-install
-post-install:
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
@@ -71,5 +69,3 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-sdl/pkg-plist b/devel/ruby-sdl/pkg-plist
index a520a6794b8d..bd227cb50f53 100644
--- a/devel/ruby-sdl/pkg-plist
+++ b/devel/ruby-sdl/pkg-plist
@@ -25,11 +25,11 @@
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/NEWS.en
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.en
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rubysdl_const_list.txt
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rubysdl_doc.en.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/rubysdl_doc.en.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rubysdl_doc.en.rd
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/NEWS.ja
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/rubysdl_doc.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/rubysdl_doc.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/rubysdl_doc.rd
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/devel/ruby-sysvipc/Makefile b/devel/ruby-sysvipc/Makefile
index 7a04e3550dcd..0de531392ca0 100644
--- a/devel/ruby-sysvipc/Makefile
+++ b/devel/ruby-sysvipc/Makefile
@@ -17,23 +17,22 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_RUBY_RDTOOL= yes
+
+RUBY_RD_FILES= sysvipc.rd
INSTALL_TARGET= site-install
-DOCS= sysvipc.html sysvipc.rd
+DOCS= ${RUBY_RD_FILES} \
+ ${RUBY_RD_HTML_FILES}
-post-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} sysvipc.rd > sysvipc.html
-.endif
+post-install: doc-install
-post-install:
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-sysvipc/pkg-plist b/devel/ruby-sysvipc/pkg-plist
index 9d34e6c50276..bebe68c29105 100644
--- a/devel/ruby-sysvipc/pkg-plist
+++ b/devel/ruby-sysvipc/pkg-plist
@@ -1,4 +1,4 @@
%%RUBY_SITEARCHLIBDIR%%/sysvipc.so
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/sysvipc.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/sysvipc.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/sysvipc.rd
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/devel/ruby-tzfile/Makefile b/devel/ruby-tzfile/Makefile
index fc5ce7c27c5c..a80383f9c7d7 100644
--- a/devel/ruby-tzfile/Makefile
+++ b/devel/ruby-tzfile/Makefile
@@ -16,20 +16,26 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
+
+NO_BUILD= yes
+
+RUBY_RD_FILES= tzfile.rb
WRKSRC= ${WRKDIR}/${PORTNAME}
-do-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} tzfile.rb > tzfile.html
-.endif
+DOCS= ${RUBY_RD_HTML_FILES}
do-install:
${INSTALL_DATA} ${WRKSRC}/tzfile.rb ${RUBY_SITELIBDIR}/
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/tzfile.html ${RUBY_MODDOCDIR}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-tzfile/pkg-plist b/devel/ruby-tzfile/pkg-plist
index d95efc9d09aa..5addbb35da97 100644
--- a/devel/ruby-tzfile/pkg-plist
+++ b/devel/ruby-tzfile/pkg-plist
@@ -1,3 +1,3 @@
%%RUBY_SITELIBDIR%%/tzfile.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/tzfile.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/tzfile.html
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/devel/ruby-unit/Makefile b/devel/ruby-unit/Makefile
index c734d1c49d62..423afe2fc04e 100644
--- a/devel/ruby-unit/Makefile
+++ b/devel/ruby-unit/Makefile
@@ -16,10 +16,12 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
+
+NO_BUILD= yes
RUBY_MODNAME= runit
+RUBY_RD_FILES= # defined
RUBY_SHEBANG_FILES= ${WRKSRC}/bin/c2t.rb \
${WRKSRC}/bin/runtest.rb
@@ -27,19 +29,21 @@ BINS= c2t runtest
DOCS= ChangeLog README ToDo
DOCS_JA= README.ja
-do-build:
-.if !defined(NOPORTDOCS)
- @cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${RUBY} makehtml.rb
-.endif
-
do-install:
- @cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${RUBY} install.rb
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${RUBY} install.rb
.for f in ${BINS}
${LN} -sf ${f}.rb ${PREFIX}/bin/${f}
.endfor
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
+.if !defined(RUBY_NO_RD_HTML)
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${RUBY} makehtml.rb
+.endif
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/sample/ ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}/ja
@@ -52,5 +56,3 @@ do-install:
${CP} -R ${WRKSRC}/doc_en/ ${RUBY_MODDOCDIR}/
${CP} -R ${WRKSRC}/doc_ja/ ${RUBY_MODDOCDIR}/ja/
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-unit/pkg-plist b/devel/ruby-unit/pkg-plist
index 35c1f8aeeb86..05e59411044a 100644
--- a/devel/ruby-unit/pkg-plist
+++ b/devel/ruby-unit/pkg-plist
@@ -33,66 +33,66 @@ bin/runtest.rb
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ToDo
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/assert.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/assert.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/assert.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/error.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/error.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/error.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/index.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/index.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/index.rd
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/assert.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/assert.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/assert.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/error.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/error.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/error.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/index.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/index.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/index.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/repeatedtest.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/repeatedtest.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/repeatedtest.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/robserver.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/robserver.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/robserver.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/setuppable.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/setuppable.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/setuppable.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/teardownable.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/teardownable.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/teardownable.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testcase.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/testcase.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testcase.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testdecorator.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/testdecorator.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testdecorator.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testfailure.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/testfailure.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testfailure.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testresult.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/testresult.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testresult.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testrunner.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/testrunner.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testrunner.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testsetup.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/testsetup.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testsetup.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testsuite.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/testsuite.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/testsuite.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/version.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/version.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/version.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/repeatedtest.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/repeatedtest.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/repeatedtest.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/robserver.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/robserver.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/robserver.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/setuppable.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/setuppable.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/setuppable.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/teardownable.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/teardownable.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/teardownable.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testcase.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/testcase.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testcase.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testdecorator.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/testdecorator.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testdecorator.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testfailure.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/testfailure.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testfailure.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testresult.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/testresult.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testresult.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testrunner.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/testrunner.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testrunner.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testsetup.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/testsetup.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testsetup.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testsuite.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/testsuite.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/testsuite.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/version.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/version.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/version.rd
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/devel/rubygem-gettext/Makefile b/devel/rubygem-gettext/Makefile
index f2e7bcf0ddda..a2512d611310 100644
--- a/devel/rubygem-gettext/Makefile
+++ b/devel/rubygem-gettext/Makefile
@@ -19,24 +19,24 @@ MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
+RUBY_RD_FILES= # defined
RUBY_SHEBANG_FILES= ${WRKSRC}/samples/*.rb
-post-build:
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
+.if !defined(RUBY_NO_RD_HTML)
cd ${WRKSRC}/docs; ${RUBY} makehtml.rb
- cd ${WRKSRC}/samples; ${RUBY} makemo.rb
.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/samples; ${RUBY} makemo.rb
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/samples/* ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
${CP} -R ${WRKSRC}/docs/* ${RUBY_MODDOCDIR}/
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/rubygem-gettext/pkg-plist b/devel/rubygem-gettext/pkg-plist
index 140b127da44a..5f2a7aeda4f7 100644
--- a/devel/rubygem-gettext/pkg-plist
+++ b/devel/rubygem-gettext/pkg-plist
@@ -45,8 +45,8 @@ share/locale/ja/LC_MESSAGES/rgettext.mo
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/config.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/en/ruby-gettext.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/ja/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/html/en/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/html/ja/ruby-gettext.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/style.css
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/makehtml.rb
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/en/LANGUAGE
diff --git a/devel/rubygem-locale/Makefile b/devel/rubygem-locale/Makefile
index f2e7bcf0ddda..a2512d611310 100644
--- a/devel/rubygem-locale/Makefile
+++ b/devel/rubygem-locale/Makefile
@@ -19,24 +19,24 @@ MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
+RUBY_RD_FILES= # defined
RUBY_SHEBANG_FILES= ${WRKSRC}/samples/*.rb
-post-build:
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
+.if !defined(RUBY_NO_RD_HTML)
cd ${WRKSRC}/docs; ${RUBY} makehtml.rb
- cd ${WRKSRC}/samples; ${RUBY} makemo.rb
.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/samples; ${RUBY} makemo.rb
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/samples/* ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
${CP} -R ${WRKSRC}/docs/* ${RUBY_MODDOCDIR}/
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/rubygem-locale/pkg-plist b/devel/rubygem-locale/pkg-plist
index 140b127da44a..5f2a7aeda4f7 100644
--- a/devel/rubygem-locale/pkg-plist
+++ b/devel/rubygem-locale/pkg-plist
@@ -45,8 +45,8 @@ share/locale/ja/LC_MESSAGES/rgettext.mo
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/config.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/en/ruby-gettext.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/ja/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/html/en/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/html/ja/ruby-gettext.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/style.css
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/makehtml.rb
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/en/LANGUAGE