aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-06 12:40:31 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-06 12:40:31 +0000
commit1c697d7c4e1fc35c1901b6057759c4a26dff91e2 (patch)
treeefa379d23f1d47dedb614af1c2d794bce631e257 /devel
parentd481608797af3676471c5d9e2501beef3e9e2327 (diff)
downloadports-1c697d7c4e1fc35c1901b6057759c4a26dff91e2.tar.gz
ports-1c697d7c4e1fc35c1901b6057759c4a26dff91e2.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Cdk/Makefile11
-rw-r--r--devel/p5-Cdk/distinfo3
-rw-r--r--devel/p5-Cdk/files/patch-Makefile.PL10
-rw-r--r--devel/p5-Cdk/files/patch-aa14
-rw-r--r--devel/p5-Cdk/files/patch-ab97
-rw-r--r--devel/p5-Cdk/files/patch-ac30
6 files changed, 16 insertions, 149 deletions
diff --git a/devel/p5-Cdk/Makefile b/devel/p5-Cdk/Makefile
index 426b80a142e6..bdf24eeba82b 100644
--- a/devel/p5-Cdk/Makefile
+++ b/devel/p5-Cdk/Makefile
@@ -6,21 +6,18 @@
#
PORTNAME= Cdk
-PORTVERSION= 4.9.6
-PORTREVISION= 1
+PORTVERSION= 4.9.10
CATEGORIES= devel perl5
-MASTER_SITES= http://www.vexus.ca/products/CDK/
+MASTER_SITES= ftp://dickey.his.com/cdk/
PKGNAMEPREFIX= p5-
-DISTNAME= cdkperl
+DISTNAME= cdk-perl-20031210
+EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 module for Curses Development Kit
LIB_DEPENDS= cdk.4:${PORTSDIR}/devel/cdk
-WRKSRC= ${WRKDIR}/Cdk
PERL_CONFIGURE= yes
-BROKEN= "Does not compile"
-
.include <bsd.port.mk>
diff --git a/devel/p5-Cdk/distinfo b/devel/p5-Cdk/distinfo
index 82708f45d262..592d3468ce14 100644
--- a/devel/p5-Cdk/distinfo
+++ b/devel/p5-Cdk/distinfo
@@ -1 +1,2 @@
-MD5 (cdkperl.tar.gz) = d6c97da27fbe1db572290dfc2e1dbe99
+MD5 (cdk-perl-20031210.tgz) = d5814507d7d2b5e3e7e5ababfa9e7d86
+SIZE (cdk-perl-20031210.tgz) = 82357
diff --git a/devel/p5-Cdk/files/patch-Makefile.PL b/devel/p5-Cdk/files/patch-Makefile.PL
new file mode 100644
index 000000000000..98ca6ce06cb3
--- /dev/null
+++ b/devel/p5-Cdk/files/patch-Makefile.PL
@@ -0,0 +1,10 @@
+--- Makefile.PL.orig Fri Mar 5 10:18:19 2004
++++ Makefile.PL Fri Mar 5 10:18:41 2004
+@@ -14,6 +14,6 @@
+ 'NAME' => 'Cdk',
+ 'VERSION' => '4.09010',
+ 'LIBS' => ['-L/usr/local/lib -lcdk -lcurses'],
+- 'INC' => '-I/usr/include/ncurses -I/usr/local/include/cdk',
++ 'INC' => '-I/usr/include -I/usr/local/include',
+ 'clean' => {FILES => 'Makefile.old'},
+ );
diff --git a/devel/p5-Cdk/files/patch-aa b/devel/p5-Cdk/files/patch-aa
deleted file mode 100644
index 5791e2facb01..000000000000
--- a/devel/p5-Cdk/files/patch-aa
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.PL.orig Fri Dec 11 03:50:16 1998
-+++ Makefile.PL Sun May 27 05:23:05 2001
-@@ -16,9 +16,9 @@
- WriteMakefile(
- 'NAME' => 'Cdk',
- 'VERSION' => '4.9.6',
-- 'LIBS' => ['-L/home/glover/local/lib -lcdk -lncurses'],
-+ 'LIBS' => ['-L/usr/local/lib -lcdk -lncurses'],
- 'DEFINE' => '-DHAVE_USLEEP -DHAVE_NCURSES -DHAVE_COLOR -DCDK_PERL_EXT',
-- 'INC' => '-I/usr/include/ncurses -I/home/glover/local/include/cdk',
-+ 'INC' => '-I/usr/include -I/usr/local/include -I/usr/local/include/cdk',
- 'clean' => {FILES => 'Makefile.old'},
- );
-
diff --git a/devel/p5-Cdk/files/patch-ab b/devel/p5-Cdk/files/patch-ab
deleted file mode 100644
index 703fe2156e78..000000000000
--- a/devel/p5-Cdk/files/patch-ab
+++ /dev/null
@@ -1,97 +0,0 @@
---- Cdk.xs.orig Fri Dec 11 03:03:35 1998
-+++ Cdk.xs Sun May 27 05:29:38 2001
-@@ -26,7 +26,7 @@
- for (y=0; y <= subLen; y++) \
- { \
- SV *sv = *av_fetch(subArray,y,FALSE); \
-- (NEWARRAY)[x+(START)][y+(START)] = copyChar((char *)SvPV(sv,na)); \
-+ (NEWARRAY)[x+(START)][y+(START)] = copyChar((char *)SvPV(sv,PL_na)); \
- } \
- } \
- (ARRAYLEN)++; \
-@@ -87,7 +87,7 @@
- for (x=0; x <= (LEN); x++) \
- { \
- SV *foo = *av_fetch(src, x, FALSE); \
-- (DEST)[x+(START)] = copyChar((char *)SvPV(foo,na)); \
-+ (DEST)[x+(START)] = copyChar((char *)SvPV(foo,PL_na)); \
- } \
- (LEN)++; \
- } while (0)
-@@ -107,11 +107,11 @@
- SV *foo = *av_fetch(src, x, FALSE); \
- if (lines == 0) \
- { \
-- sprintf ((DEST), "%s", (char *)SvPV(foo,na)); \
-+ sprintf ((DEST), "%s", (char *)SvPV(foo,PL_na)); \
- } \
- else \
- { \
-- sprintf ((DEST), "%s\n%s", (DEST), (char *)SvPV(foo,na)); \
-+ sprintf ((DEST), "%s\n%s", (DEST), (char *)SvPV(foo,PL_na)); \
- } \
- lines++; \
- } \
-@@ -123,7 +123,7 @@
- } \
- else \
- { \
-- sprintf ((DEST), "%s", (char *)SvPV(INPUT,na)); \
-+ sprintf ((DEST), "%s", (char *)SvPV(INPUT,PL_na)); \
- } \
- } while (0)
-
-@@ -299,7 +299,7 @@
- {
- if (SvPOK(sv))
- {
-- char *name = SvPV(sv,na);
-+ char *name = SvPV(sv,PL_na);
- chtype *fillerChtype;
- chtype filler;
- int j1, j2;
-@@ -608,7 +608,7 @@
- {
- if (SvPOK(sv))
- {
-- char *name = SvPV(sv,na);
-+ char *name = SvPV(sv,PL_na);
- if (strEQ (name, "vENTRY"))
- return vENTRY;
- if (strEQ (name, "vMENTRY"))
-@@ -646,7 +646,7 @@
- {
- if (SvPOK(sv))
- {
-- char *name = SvPV(sv,na);
-+ char *name = SvPV(sv,PL_na);
- if (strEQ (name, "CHAR"))
- return vCHAR;
- if (strEQ (name, "HCHAR"))
-@@ -697,7 +697,7 @@
- {
- if (SvPOK(sv))
- {
-- char *name = SvPV(sv,na);
-+ char *name = SvPV(sv,PL_na);
- if (strEQ(name, "BOTTOM"))
- return BOTTOM;
- if (strEQ(name, "CENTER"))
-@@ -736,7 +736,7 @@
- sv2CharPtr(inp)
- SV *inp;
- {
-- char *name = (char *)SvPV(inp,na);
-+ char *name = (char *)SvPV(inp,PL_na);
- return (name);
- }
-
-@@ -6424,7 +6424,7 @@
- CDKALPHALIST * object
- PPCODE:
- {
-- SV *sv = (SV *)&sv_undef;
-+ SV *sv = (SV *)&PL_sv_undef;
- chtype Keys[300];
- int arrayLen;
- char *value;
diff --git a/devel/p5-Cdk/files/patch-ac b/devel/p5-Cdk/files/patch-ac
deleted file mode 100644
index ca94edd5078e..000000000000
--- a/devel/p5-Cdk/files/patch-ac
+++ /dev/null
@@ -1,30 +0,0 @@
---- Cdk.xs.orig Fri Jan 31 15:36:39 2003
-+++ Cdk.xs Fri Jan 31 15:32:12 2003
-@@ -130,7 +130,7 @@
- /*
- * The callback callback to run Perl callback routines. Are you confused???
- */
--void PerlBindCB (EObjectType cdktype, void *object, void *data, chtype input)
-+int PerlBindCB (EObjectType cdktype, void *object, void *data, chtype input)
- {
- dSP ;
-
-@@ -2385,12 +2385,13 @@
- RETVAL
-
- void
--Draw(object)
-+Draw(object,Box=TRUE)
- CDKMENU * object
-- CODE:
-- {
-- drawCDKMenu (object);
-- }
-+ int Box = sv2int ($arg);
-+ CODE:
-+ {
-+ drawCDKMenu (object,Box);
-+ }
-
- void
- Erase(object)