aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 06:51:30 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 06:51:30 +0000
commit1e0c74a04598a4561e4d2bd460888c23ee9ba0ca (patch)
tree43a7d00a40229f8178e6db99f8e228dcbd1ba1c6 /devel
parent5d080083375244f9031e01a0f061c720d30d42ab (diff)
downloadports-1e0c74a04598a4561e4d2bd460888c23ee9ba0ca.tar.gz
ports-1e0c74a04598a4561e4d2bd460888c23ee9ba0ca.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-res/Makefile67
-rw-r--r--devel/ocaml-res/distinfo3
-rw-r--r--devel/ocaml-res/pkg-descr12
4 files changed, 83 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b740f80a3b83..0f2d2bcd40c6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -707,6 +707,7 @@
SUBDIR += ocaml-ounit
SUBDIR += ocaml-pcre
SUBDIR += ocaml-pomap
+ SUBDIR += ocaml-res
SUBDIR += ocaml-sdl
SUBDIR += ocaml-sem
SUBDIR += ocaml-sexplib
diff --git a/devel/ocaml-res/Makefile b/devel/ocaml-res/Makefile
new file mode 100644
index 000000000000..46669751a99a
--- /dev/null
+++ b/devel/ocaml-res/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: res
+# Date created: 2006-08-15
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= res
+PORTVERSION= 2.2.4
+CATEGORIES= devel
+MASTER_SITES= http://www.ocaml.info/ocaml_sources/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Automatically Resizing Contiguous Memory for OCaml
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+USE_OCAML_WASH= yes
+
+DOCS= README
+DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
+
+# XXX: exists untill it will be committed to bsd.port.mk
+COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
+ 2>&1) && \
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
+ ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
+ ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${TARGETDIR}/,," >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
+ @${FIND} ${EXAMPLESDIR}/ ! -type d | \
+ ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
+ ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR}/ ! -type d | \
+ ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
+ ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+# XXX: temporary workaround for non-standard PREFIX
+ @${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
+ >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/share/examples/ocaml 2>/dev/null||true" \
+ >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-res/distinfo b/devel/ocaml-res/distinfo
new file mode 100644
index 000000000000..39d28b54e100
--- /dev/null
+++ b/devel/ocaml-res/distinfo
@@ -0,0 +1,3 @@
+MD5 (res-2.2.4.tar.bz2) = 1d1c522c193ad1bc9bd13760bc34f778
+SHA256 (res-2.2.4.tar.bz2) = a38dccb25822112a1e69acba6b271f587d299a7e3bd2cb0e8a09d11307744ac7
+SIZE (res-2.2.4.tar.bz2) = 33581
diff --git a/devel/ocaml-res/pkg-descr b/devel/ocaml-res/pkg-descr
new file mode 100644
index 000000000000..c2394643c306
--- /dev/null
+++ b/devel/ocaml-res/pkg-descr
@@ -0,0 +1,12 @@
+This OCaml-library consists of a set of modules which implement
+automatically resizing (= reallocating) datastructures that consume
+a contiguous part of memory. This allows appending and removing of
+elements to/from arrays (both boxed and unboxed), strings (-> buffers),
+bit strings and weak arrays while still maintaining fast constant-time
+access to elements.
+
+There are also functors that allow the generation of similar modules
+which use different reallocation strategies.
+
+Author: Markus Mottl <markus.mottl@gmail.com>
+WWW: http://www.ocaml.info/home/ocaml_sources.html