aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-15 07:59:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-15 07:59:39 +0000
commit4ef1b1e55b6dde21fb147018d9b3cebc05eb5f3d (patch)
tree3f9cabd8cd43d95aa025496e67ab3bb3d0f59e5b /devel
parent248b0da7e38c4b66c45e7546e615465e79ef9bf2 (diff)
downloadports-4ef1b1e55b6dde21fb147018d9b3cebc05eb5f3d.tar.gz
ports-4ef1b1e55b6dde21fb147018d9b3cebc05eb5f3d.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-period/Makefile29
-rw-r--r--devel/py-period/distinfo1
-rw-r--r--devel/py-period/pkg-comment1
-rw-r--r--devel/py-period/pkg-descr5
-rw-r--r--devel/py-period/pkg-plist4
6 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 069a610a37c6..8c192a151b95 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -548,6 +548,7 @@
SUBDIR += py-omniorb
SUBDIR += py-optik
SUBDIR += py-orbit
+ SUBDIR += py-period
SUBDIR += py-pqueue
SUBDIR += py-twisted
SUBDIR += py-unit
diff --git a/devel/py-period/Makefile b/devel/py-period/Makefile
new file mode 100644
index 000000000000..b83841676fad
--- /dev/null
+++ b/devel/py-period/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: py-period
+# Date created: Mar 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= period
+PORTVERSION= 0.5
+CATEGORIES= devel python
+MASTER_SITES= http://www.biostat.wisc.edu/~annis/creations/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@geeksrus.net
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/period.py ${PYTHON_SITELIBDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for ex in html txt
+ ${INSTALL_DATA} ${WRKSRC}/period.${ex} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-period/distinfo b/devel/py-period/distinfo
new file mode 100644
index 000000000000..3e56eea60ebc
--- /dev/null
+++ b/devel/py-period/distinfo
@@ -0,0 +1 @@
+MD5 (period-0.5.tar.gz) = 89d0fd410eecf54b702837ce61a0d8f0
diff --git a/devel/py-period/pkg-comment b/devel/py-period/pkg-comment
new file mode 100644
index 000000000000..f80357eb7b4e
--- /dev/null
+++ b/devel/py-period/pkg-comment
@@ -0,0 +1 @@
+A basic time period checking libary
diff --git a/devel/py-period/pkg-descr b/devel/py-period/pkg-descr
new file mode 100644
index 000000000000..793881b02d1e
--- /dev/null
+++ b/devel/py-period/pkg-descr
@@ -0,0 +1,5 @@
+This is an early version of a basic time period checking libary for Python.
+It is in part inspired by perl's Time::Period module and the time class
+mechanism of Cfengine.
+
+WWW: http://www.biostat.wisc.edu/~annis/creations/period.py.html
diff --git a/devel/py-period/pkg-plist b/devel/py-period/pkg-plist
new file mode 100644
index 000000000000..fe3cbb896adb
--- /dev/null
+++ b/devel/py-period/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%PYTHON_VERSION%%/site-packages/period.py
+%%PORTDOCS%%share/doc/period/period.html
+%%PORTDOCS%%share/doc/period/period.txt
+%%PORTDOCS%%@dirrm share/doc/period