aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-16 09:13:28 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-16 09:13:28 +0000
commit4f18c570eeea14273ebf788cb1e0c110fcc51280 (patch)
treea12c4fb25259c3fda74af3cdb2112bf0f6717478 /devel
parentdf018b30f883af31c964ca36e8feb6434ced1bf2 (diff)
downloadports-4f18c570eeea14273ebf788cb1e0c110fcc51280.tar.gz
ports-4f18c570eeea14273ebf788cb1e0c110fcc51280.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gconf2/Makefile28
-rw-r--r--devel/gconf2/distinfo2
-rw-r--r--devel/gconf2/files/patch-ab24
-rw-r--r--devel/gconf2/files/patch-backends::bdb-backend.c6
-rw-r--r--devel/gconf2/files/patch-configure19
-rw-r--r--devel/gconf2/files/patch-gconf::gconf-internals.c6
-rw-r--r--devel/gconf2/files/patch-ltmain.sh25
-rw-r--r--devel/gconf2/pkg-plist164
9 files changed, 154 insertions, 121 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 04853bf3609f..7c2fa8454ac0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -158,6 +158,7 @@
SUBDIR += gaa
SUBDIR += gcc-6811
SUBDIR += gconf
+ SUBDIR += gconf2
SUBDIR += gcvs
SUBDIR += gdb51
SUBDIR += gengameng
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index fe9cb36ffc55..06bef7f26eef 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -1,46 +1,40 @@
-# New ports collection makefile for: gconf
+# New ports collection makefile for: gconf2
# Date created: 28th June 2000
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= gconf
-PORTVERSION= 1.0.8
+PORTNAME= gconf2
+PORTVERSION= 1.1.6
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/GConf
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
DISTNAME= GConf-${PORTVERSION}
-DIST_SUBDIR= gnome
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile \
- oaf.0:${PORTSDIR}/devel/oaf \
+LIB_DEPENDS= ORBit-2.0:${PORTSDIR}/devel/ORBit2 \
db3.2:${PORTSDIR}/databases/db3
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-db3-includes=${LOCALBASE}/include \
+ --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-post-install:
- @if [ ! -f ${PREFIX}/etc/gconf/1/path ]; then \
- ${CP} -p ${PREFIX}/etc/gconf/1/path.example ${PREFIX}/etc/gconf/1/path ; \
- fi
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/apps
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/schemas/apps
-
-
.include <bsd.port.mk>
diff --git a/devel/gconf2/distinfo b/devel/gconf2/distinfo
index 873588bf3e98..28803dfa8122 100644
--- a/devel/gconf2/distinfo
+++ b/devel/gconf2/distinfo
@@ -1 +1 @@
-MD5 (gnome/GConf-1.0.8.tar.bz2) = 3a7c7a1ba84e29c24f1522e53eab89cc
+MD5 (gnome2/GConf-1.1.6.tar.bz2) = 950e2c7abcbca2b1639d7b6585436abd
diff --git a/devel/gconf2/files/patch-ab b/devel/gconf2/files/patch-ab
index 032c7e5eab94..3384f04f7c78 100644
--- a/devel/gconf2/files/patch-ab
+++ b/devel/gconf2/files/patch-ab
@@ -1,19 +1,25 @@
---- Makefile.in.orig Mon May 14 13:07:48 2001
-+++ Makefile.in Mon May 21 23:29:41 2001
-@@ -37,3 +37,3 @@
+
+$FreeBSD$
+
+--- Makefile.in 2002/02/15 19:08:06 1.1
++++ Makefile.in 2002/02/15 19:10:01
+@@ -35,7 +35,7 @@
+ DESTDIR =
+
pkgdatadir = $(datadir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
+pkglibdir = $(prefix)/libdata/pkgconfig
pkgincludedir = $(includedir)/@PACKAGE@
-@@ -144,3 +144,3 @@
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(pkglibdir)
- pkgconfig_DATA = gconf.pc gconfgtk.pc
-@@ -476,4 +476,4 @@
+ top_builddir = .
+@@ -450,8 +450,8 @@
+
+
install-data-local:
- -mkdir -p $(DESTDIR)$(datadir)/aclocal
- $(INSTALL_DATA) gconf.m4 $(DESTDIR)$(datadir)/aclocal/gconf-$(MAJOR_VERSION).m4
+ -mkdir -p $(DESTDIR)$(prefix)/share/aclocal
+ $(INSTALL_DATA) gconf.m4 $(DESTDIR)$(prefix)/share/aclocal/gconf-$(MAJOR_VERSION).m4
- @echo "**** NOTE ****"
+ -mkdir -p $(DESTDIR)$(sysconfdir)/gconf/gconf.xml.defaults
+ -chmod 755 $(DESTDIR)$(sysconfdir)/gconf/gconf.xml.defaults
+ -mkdir -p $(DESTDIR)$(sysconfdir)/gconf/gconf.xml.mandatory
diff --git a/devel/gconf2/files/patch-backends::bdb-backend.c b/devel/gconf2/files/patch-backends::bdb-backend.c
index bb839b4e4f52..9c7fa1e3fdd4 100644
--- a/devel/gconf2/files/patch-backends::bdb-backend.c
+++ b/devel/gconf2/files/patch-backends::bdb-backend.c
@@ -1,9 +1,9 @@
$FreeBSD$
---- backends/bdb-backend.c 2001/08/02 17:59:13 1.1
-+++ backends/bdb-backend.c 2001/08/02 18:03:23
-@@ -25,10 +25,9 @@
+--- backends/bdb-backend.c 2002/02/15 19:10:46 1.1
++++ backends/bdb-backend.c 2002/02/15 19:11:25
+@@ -29,10 +29,9 @@
#include <gconf/gconf-internals.h>
#include <gconf/gconf.h>
diff --git a/devel/gconf2/files/patch-configure b/devel/gconf2/files/patch-configure
index 1e91b12da41c..13d38f0f5156 100644
--- a/devel/gconf2/files/patch-configure
+++ b/devel/gconf2/files/patch-configure
@@ -1,7 +1,14 @@
---- configure.orig Mon Feb 11 15:20:43 2002
-+++ configure Mon Feb 11 15:22:24 2002
-@@ -8516,3 +8516,3 @@
+
+$FreeBSD$
+
+--- configure 2002/02/15 19:11:46 1.1
++++ configure 2002/02/15 19:12:30
+@@ -7752,7 +7752,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
--for dblib in db-3.3 db-3.2 db-3.1 db-3; do
-+for dblib in db-3.3 db-3.2 db-3.1 db-3 db3; do
- as_ac_Lib=`echo "ac_cv_lib_$dblib''_db_env_create" | $as_tr_sh`
+- for db3libs in "-ldb-3.3" "-ldb-3.2" "-ldb-3.1" "-ldb-3"; do
++ for db3libs in "-ldb-3.3" "-ldb-3.2" "-ldb-3.1" "-ldb-3" "-ldb3"; do
+ if test "x${with_db3_libs}" != "x"; then
+ LIBS="$LIBS -L$with_db3_libs $db3libs"
+ else
diff --git a/devel/gconf2/files/patch-gconf::gconf-internals.c b/devel/gconf2/files/patch-gconf::gconf-internals.c
index db4e8c961980..cc04f6913284 100644
--- a/devel/gconf2/files/patch-gconf::gconf-internals.c
+++ b/devel/gconf2/files/patch-gconf::gconf-internals.c
@@ -1,9 +1,9 @@
$FreeBSD$
---- gconf/gconf-internals.c 2001/11/07 11:27:13 1.1
-+++ gconf/gconf-internals.c 2001/11/07 11:27:52
-@@ -28,6 +28,9 @@
+--- gconf/gconf-internals.c 2002/02/15 19:13:07 1.1
++++ gconf/gconf-internals.c 2002/02/15 19:13:32
+@@ -26,6 +26,9 @@
#include <string.h>
#include <sys/stat.h>
#include <sys/types.h>
diff --git a/devel/gconf2/files/patch-ltmain.sh b/devel/gconf2/files/patch-ltmain.sh
index 98cb05e4ddb3..91713d2306f8 100644
--- a/devel/gconf2/files/patch-ltmain.sh
+++ b/devel/gconf2/files/patch-ltmain.sh
@@ -1,9 +1,26 @@
$FreeBSD$
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
@@ -13,7 +30,7 @@ $FreeBSD$
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
+@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/devel/gconf2/pkg-plist b/devel/gconf2/pkg-plist
index 814f8554eff6..47f6f13d6cb8 100644
--- a/devel/gconf2/pkg-plist
+++ b/devel/gconf2/pkg-plist
@@ -1,79 +1,87 @@
-bin/gconf-config
-bin/gconf-config-1
-bin/gconfd-1
+bin/gconfd-2
bin/gconftool
-bin/gconftool-1
-etc/gconf/1/path
-etc/gconf/schemas/desktop.schemas
-include/gconf/1/gconf/gconf-changeset.h
-include/gconf/1/gconf/gconf-client.h
-include/gconf/1/gconf/gconf-engine.h
-include/gconf/1/gconf/gconf-error.h
-include/gconf/1/gconf/gconf-glib-public.h
-include/gconf/1/gconf/gconf-listeners.h
-include/gconf/1/gconf/gconf-schema.h
-include/gconf/1/gconf/gconf-value.h
-include/gconf/1/gconf/gconf.h
-lib/GConf/1/libgconfbackend-bdb.a
-lib/GConf/1/libgconfbackend-bdb.so
-lib/GConf/1/libgconfbackend-xml.a
-lib/GConf/1/libgconfbackend-xml.so
-lib/libgconf-1.a
-lib/libgconf-1.so
-lib/libgconf-1.so.1
-lib/libgconf-gtk-1.a
-lib/libgconf-gtk-1.so
-lib/libgconf-gtk-1.so.1
-libdata/pkgconfig/gconf.pc
-libdata/pkgconfig/gconfgtk.pc
-share/aclocal/gconf-1.m4
-share/locale/az/LC_MESSAGES/GConf.mo
-share/locale/ca/LC_MESSAGES/GConf.mo
-share/locale/cs/LC_MESSAGES/GConf.mo
-share/locale/da/LC_MESSAGES/GConf.mo
-share/locale/de/LC_MESSAGES/GConf.mo
-share/locale/el/LC_MESSAGES/GConf.mo
-share/locale/es/LC_MESSAGES/GConf.mo
-share/locale/eu/LC_MESSAGES/GConf.mo
-share/locale/fi/LC_MESSAGES/GConf.mo
-share/locale/fr/LC_MESSAGES/GConf.mo
-share/locale/ga/LC_MESSAGES/GConf.mo
-share/locale/gl/LC_MESSAGES/GConf.mo
-share/locale/hu/LC_MESSAGES/GConf.mo
-share/locale/it/LC_MESSAGES/GConf.mo
-share/locale/ja/LC_MESSAGES/GConf.mo
-share/locale/ko/LC_MESSAGES/GConf.mo
-share/locale/nl/LC_MESSAGES/GConf.mo
-share/locale/nn/LC_MESSAGES/GConf.mo
-share/locale/no/LC_MESSAGES/GConf.mo
-share/locale/pl/LC_MESSAGES/GConf.mo
-share/locale/pt/LC_MESSAGES/GConf.mo
-share/locale/pt_BR/LC_MESSAGES/GConf.mo
-share/locale/ru/LC_MESSAGES/GConf.mo
-share/locale/sk/LC_MESSAGES/GConf.mo
-share/locale/sl/LC_MESSAGES/GConf.mo
-share/locale/sv/LC_MESSAGES/GConf.mo
-share/locale/tr/LC_MESSAGES/GConf.mo
-share/locale/uk/LC_MESSAGES/GConf.mo
-share/locale/zh_CN.GB2312/LC_MESSAGES/GConf.mo
-@exec mkdir -p %D/etc/gconf/gconf.xml.defaults/apps
-@exec mkdir -p %D/etc/gconf/gconf.xml.defaults/schemas/apps
-@unexec rm -f %D/etc/gconf/gconf.xml.defaults/%%gconf.xml 2>/dev/null || true
-@unexec rm -f %D/etc/gconf/gconf.xml.defaults/apps/%%gconf.xml 2>/dev/null || true
-@unexec rm -f %D/etc/gconf/gconf.xml.defaults/schemas/%%gconf.xml 2>/dev/null || true
-@unexec rm -f %D/etc/gconf/gconf.xml.defaults/schemas/apps/%%gconf.xml 2>/dev/null || true
-@dirrm share/gnome/gconf/1
-@dirrm share/gnome/gconf
-@dirrm lib/GConf/1
-@dirrm lib/GConf
-@dirrm include/gconf/1/gconf
-@dirrm include/gconf/1
-@dirrm include/gconf
-@dirrm etc/gconf/schemas
-@dirrm etc/gconf/gconf.xml.mandatory
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps
-@dirrm etc/gconf/gconf.xml.defaults/schemas
-@dirrm etc/gconf/gconf.xml.defaults/apps
-@dirrm etc/gconf/gconf.xml.defaults
-@dirrm etc/gconf/1
-@dirrm etc/gconf
+bin/gconftool-2
+etc/gconf/2/path
+include/gconf/2/gconf/gconf-changeset.h
+include/gconf/2/gconf/gconf-client.h
+include/gconf/2/gconf/gconf-engine.h
+include/gconf/2/gconf/gconf-error.h
+include/gconf/2/gconf/gconf-listeners.h
+include/gconf/2/gconf/gconf-schema.h
+include/gconf/2/gconf/gconf-value.h
+include/gconf/2/gconf/gconf.h
+lib/GConf/2/libgconfbackend-bdb.so
+lib/GConf/2/libgconfbackend-xml.so
+lib/libgconf-2.a
+lib/libgconf-2.so
+lib/libgconf-2.so.3
+libdata/pkgconfig/gconf-2.0.pc
+share/aclocal/gconf-2.m4
+share/doc/gconf/c120.html
+share/doc/gconf/c21.html
+share/doc/gconf/c381.html
+share/doc/gconf/c490.html
+share/doc/gconf/conventions.html
+share/doc/gconf/gconf-client-reference.html
+share/doc/gconf/gconf-client.html
+share/doc/gconf/gconf-gconf-backend.html
+share/doc/gconf/gconf-gconf-changeset.html
+share/doc/gconf/gconf-gconf-engine.html
+share/doc/gconf/gconf-gconf-error.html
+share/doc/gconf/gconf-gconf-internals.html
+share/doc/gconf/gconf-gconf-listeners.html
+share/doc/gconf/gconf-gconf-locale.html
+share/doc/gconf/gconf-gconf-schema.html
+share/doc/gconf/gconf-gconf-sources.html
+share/doc/gconf/gconf-gconf-value.html
+share/doc/gconf/gconf-gconf.html
+share/doc/gconf/gconf-internals-reference.html
+share/doc/gconf/gconf-reference.html
+share/doc/gconf/gconfclient.html
+share/doc/gconf/gconftool.html
+share/doc/gconf/index.html
+share/doc/gconf/index.sgml
+share/doc/gconf/x184.html
+share/doc/gconf/x236.html
+share/doc/gconf/x289.html
+share/doc/gconf/x42.html
+share/doc/gconf/x462.html
+share/doc/gconf/x485.html
+share/locale/az/LC_MESSAGES/GConf2.mo
+share/locale/ca/LC_MESSAGES/GConf2.mo
+share/locale/cs/LC_MESSAGES/GConf2.mo
+share/locale/da/LC_MESSAGES/GConf2.mo
+share/locale/de/LC_MESSAGES/GConf2.mo
+share/locale/el/LC_MESSAGES/GConf2.mo
+share/locale/es/LC_MESSAGES/GConf2.mo
+share/locale/fi/LC_MESSAGES/GConf2.mo
+share/locale/fr/LC_MESSAGES/GConf2.mo
+share/locale/ga/LC_MESSAGES/GConf2.mo
+share/locale/gl/LC_MESSAGES/GConf2.mo
+share/locale/hu/LC_MESSAGES/GConf2.mo
+share/locale/it/LC_MESSAGES/GConf2.mo
+share/locale/ja/LC_MESSAGES/GConf2.mo
+share/locale/ko/LC_MESSAGES/GConf2.mo
+share/locale/nl/LC_MESSAGES/GConf2.mo
+share/locale/nn/LC_MESSAGES/GConf2.mo
+share/locale/no/LC_MESSAGES/GConf2.mo
+share/locale/pt/LC_MESSAGES/GConf2.mo
+share/locale/pt_BR/LC_MESSAGES/GConf2.mo
+share/locale/ro/LC_MESSAGES/GConf2.mo
+share/locale/ru/LC_MESSAGES/GConf2.mo
+share/locale/sk/LC_MESSAGES/GConf2.mo
+share/locale/sl/LC_MESSAGES/GConf2.mo
+share/locale/sv/LC_MESSAGES/GConf2.mo
+share/locale/tr/LC_MESSAGES/GConf2.mo
+share/locale/uk/LC_MESSAGES/GConf2.mo
+share/locale/zh_CN/LC_MESSAGES/GConf2.mo
+@dirrm share/doc/gconf
+@dirrm lib/GConf/2
+@unexec /bin/rmdir %D/lib/GConf 2>/dev/null || /usr/bin/true
+@dirrm include/gconf/2/gconf
+@dirrm include/gconf/2
+@unexec /bin/rmdir %D/include/gconf 2>/dev/null || /usr/bin/true
+@dirrm etc/gconf/2
+@unexec /bin/rmdir %D/etc/gconf/gconf.xml.mandatory 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/etc/gconf 2>/dev/null || /usr/bin/true