aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 05:57:22 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 05:57:22 +0000
commit61b3509ced58f64082e64db4aaa9f04a33f144f0 (patch)
tree0d1f12ad77a4595e1528da43a26267ec13f5ae57 /devel
parent73e4bb4e43b5584f68e9344c83e18cfe4a6d1f14 (diff)
downloadports-61b3509ced58f64082e64db4aaa9f04a33f144f0.tar.gz
ports-61b3509ced58f64082e64db4aaa9f04a33f144f0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IO-YAML/Makefile35
-rw-r--r--devel/p5-IO-YAML/distinfo3
-rw-r--r--devel/p5-IO-YAML/pkg-descr4
-rw-r--r--devel/p5-IO-YAML/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0bdb621eb7ab..11cb6b748377 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1118,6 +1118,7 @@
SUBDIR += p5-IO-Toolkit
SUBDIR += p5-IO-Tty
SUBDIR += p5-IO-Util
+ SUBDIR += p5-IO-YAML
SUBDIR += p5-IO-stringy
SUBDIR += p5-IPC-Cache
SUBDIR += p5-IPC-Cmd
diff --git a/devel/p5-IO-YAML/Makefile b/devel/p5-IO-YAML/Makefile
new file mode 100644
index 000000000000..f6ee9e6dd984
--- /dev/null
+++ b/devel/p5-IO-YAML/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-IO-YAML
+# Date created: 2006-08-17
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-YAML
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Read and write YAML streams incrementally
+
+RUN_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::YAML.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601 # Inherited from textproc/p5-YAML
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500801
+RUN_DEPENDS+= ${SITE_PERL}/Errno.pm:${PORTSDIR}/devel/p5-Errno
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IO-YAML/distinfo b/devel/p5-IO-YAML/distinfo
new file mode 100644
index 000000000000..624129c98465
--- /dev/null
+++ b/devel/p5-IO-YAML/distinfo
@@ -0,0 +1,3 @@
+MD5 (IO-YAML-0.05.tar.gz) = 88291f0aa587b88cb8514511ed1e85f2
+SHA256 (IO-YAML-0.05.tar.gz) = 7b7d2a6d00714ddba26ac9f1816fe896e69deb1672b201ef7a2baca9ded6c57a
+SIZE (IO-YAML-0.05.tar.gz) = 9728
diff --git a/devel/p5-IO-YAML/pkg-descr b/devel/p5-IO-YAML/pkg-descr
new file mode 100644
index 000000000000..55d98cda7d79
--- /dev/null
+++ b/devel/p5-IO-YAML/pkg-descr
@@ -0,0 +1,4 @@
+IO::YAML may be used to read and write YAML streams one document
+(i.e., one value) at a time.
+
+WWW: http://search.cpan.org/dist/IO-YAML/
diff --git a/devel/p5-IO-YAML/pkg-plist b/devel/p5-IO-YAML/pkg-plist
new file mode 100644
index 000000000000..0e8f599b0eee
--- /dev/null
+++ b/devel/p5-IO-YAML/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO-YAML/.packlist
+%%SITE_PERL%%/IO/YAML.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO-YAML
+@dirrmtry %%SITE_PERL%%/IO